aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-04 08:17:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-04 08:17:09 +0000
commit697e6bea23feca666e06249f21eff49553080099 (patch)
tree2f961be4e5389f06b1c2cd7b8ccdf243f23d07c3 /www
parentbc2e87ec1bed01cf2d5f2a74afe04d650a8082ed (diff)
downloadports-697e6bea23feca666e06249f21eff49553080099.tar.gz
ports-697e6bea23feca666e06249f21eff49553080099.zip
www/bozohttpd: update the port to version 20210227 and unbreak on i386.
Diffstat (limited to 'www')
-rw-r--r--www/bozohttpd/Makefile4
-rw-r--r--www/bozohttpd/distinfo6
-rw-r--r--www/bozohttpd/files/patch-bozohttpd.84
-rw-r--r--www/bozohttpd/files/patch-bozohttpd.c24
-rw-r--r--www/bozohttpd/files/patch-bozohttpd.h11
5 files changed, 37 insertions, 12 deletions
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index c22d35e2305e..f7525f382451 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -1,7 +1,7 @@
# Created by: Janos.Mohacsi@bsd.hu
PORTNAME= bozohttpd
-PORTVERSION= 20201014
+PORTVERSION= 20210227
CATEGORIES= www
MASTER_SITES= http://www.eterna.com.au/bozohttpd/ \
NETBSD
@@ -11,8 +11,6 @@ COMMENT= Bozotic HTTP server from NetBSD
LICENSE= BSD2CLAUSE
-BROKEN_i386= Doesn't compile, error: comparison of integers of different signs: 'unsigned int' and 'time_t' (aka 'int')
-
USES= cpe uidfix tar:bzip2
CPE_VENDOR= eterna
diff --git a/www/bozohttpd/distinfo b/www/bozohttpd/distinfo
index 7aabcd144bbe..86e0c19344b6 100644
--- a/www/bozohttpd/distinfo
+++ b/www/bozohttpd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613243155
-SHA256 (bozohttpd-20201014.tar.bz2) = 5bbca7a3cf5cdadb1de2a40c41c51c8e8ded8569dd1e8f81962cca6b4c0b97ed
-SIZE (bozohttpd-20201014.tar.bz2) = 76913
+TIMESTAMP = 1614489706
+SHA256 (bozohttpd-20210227.tar.bz2) = 23f6708be9e4f1b151718320228bf6765586965db48e2b0e5a943c4020e8adff
+SIZE (bozohttpd-20210227.tar.bz2) = 63732
diff --git a/www/bozohttpd/files/patch-bozohttpd.8 b/www/bozohttpd/files/patch-bozohttpd.8
index 716db4f239da..64267d5088ea 100644
--- a/www/bozohttpd/files/patch-bozohttpd.8
+++ b/www/bozohttpd/files/patch-bozohttpd.8
@@ -146,8 +146,8 @@
.An Jukka Ruohonen
.Aq Mt jruoho@NetBSD.org
provided support for
--.Xr blocklist 8
-+.Xr blacklist 8
+-.Xr blocklistd 8
++.Xr blacklistd 8
.It
.An Jared McNeill
.Aq Mt jmcneill@NetBSD.org
diff --git a/www/bozohttpd/files/patch-bozohttpd.c b/www/bozohttpd/files/patch-bozohttpd.c
index c2d52f91fd33..7582fc976623 100644
--- a/www/bozohttpd/files/patch-bozohttpd.c
+++ b/www/bozohttpd/files/patch-bozohttpd.c
@@ -1,6 +1,15 @@
---- bozohttpd.c.orig 2021-02-14 09:40:33 UTC
+--- bozohttpd.c.orig 2021-02-28 05:20:51 UTC
+++ bozohttpd.c
-@@ -2174,22 +2174,22 @@ http_errors_long(int code)
+@@ -240,7 +240,7 @@ bozo_set_pref(bozohttpd_t *httpd, bozoprefs_t *bozopre
+ }
+
+ static void
+-bozo_clear_prefs(bozohttpd_t *httpd, bozoprefs_t *prefs)
++bozo_clear_prefs(bozoprefs_t *prefs)
+ {
+ size_t i;
+
+@@ -2197,22 +2197,22 @@ http_errors_long(int code)
return (help);
}
@@ -28,7 +37,7 @@
/* the follow functions and variables are used in handling HTTP errors */
int
-@@ -2294,18 +2294,18 @@ bozo_http_error(bozohttpd_t *httpd, int code, bozo_htt
+@@ -2317,18 +2317,18 @@ bozo_http_error(bozohttpd_t *httpd, int code, bozo_htt
bozo_printf(httpd, "%s", httpd->errorbuf);
bozo_flush(httpd, stdout);
@@ -51,3 +60,12 @@
return code;
}
+@@ -2714,7 +2714,7 @@ bozo_setup(bozohttpd_t *httpd, bozoprefs_t *prefs, con
+ void
+ bozo_cleanup(bozohttpd_t *httpd, bozoprefs_t *prefs)
+ {
+- bozo_clear_prefs(httpd, prefs);
++ bozo_clear_prefs(prefs);
+
+ free(httpd->virthostname);
+ free(httpd->errorbuf);
diff --git a/www/bozohttpd/files/patch-bozohttpd.h b/www/bozohttpd/files/patch-bozohttpd.h
index cd728903cfd3..f9d4ccb75867 100644
--- a/www/bozohttpd/files/patch-bozohttpd.h
+++ b/www/bozohttpd/files/patch-bozohttpd.h
@@ -1,4 +1,4 @@
---- bozohttpd.h.orig 2021-02-13 19:42:32 UTC
+--- bozohttpd.h.orig 2021-02-28 05:20:51 UTC
+++ bozohttpd.h
@@ -44,8 +44,8 @@
#include <lua.h>
@@ -11,3 +11,12 @@
void pfilter_notify(const int, const int);
#endif
+@@ -129,7 +129,7 @@ typedef struct bozohttpd_t {
+ unsigned ssl_timeout; /* ssl timeout */
+ unsigned initial_timeout;/* first line timeout */
+ unsigned header_timeout; /* header lines timeout */
+- unsigned request_timeout;/* total session timeout */
++ int request_timeout;/* total session timeout */
+ #ifndef NO_LUA_SUPPORT
+ int process_lua; /* use the Lua handler */
+ SIMPLEQ_HEAD(, lua_state_map) lua_states;