aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-12-09 17:35:42 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-12-09 17:35:42 +0000
commit6da0935debfccac428d69d0a370c35766f6dc1ea (patch)
treeff13fb05d127c393355db86821ca4f6ec724c327 /www
parent3da06622f6bac7a04d021e72c24cf4cb78d21d83 (diff)
downloadports-6da0935debfccac428d69d0a370c35766f6dc1ea.tar.gz
ports-6da0935debfccac428d69d0a370c35766f6dc1ea.zip
www/rubygem-tumblr_client: create port
This is the official Ruby wrapper for the Tumblr v2 API. It supports all endpoints currently available on the Tumblr API. WWW: https://github.com/tumblr/tumblr_client PR: 195758 Differential Revision: https://reviews.freebsd.org/D1278 Submitted by: Michael Moll <kvedulv@kvedulv.de> Approved by: kswills (mentor)
Notes
Notes: svn path=/head/; revision=374412
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-tumblr_client/Makefile27
-rw-r--r--www/rubygem-tumblr_client/distinfo2
-rw-r--r--www/rubygem-tumblr_client/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cb5ae525c99b..aa49979f94c6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1900,6 +1900,7 @@
SUBDIR += rubygem-thin
SUBDIR += rubygem-tinyatom
SUBDIR += rubygem-tinymce-rails
+ SUBDIR += rubygem-tumblr_client
SUBDIR += rubygem-turbolinks
SUBDIR += rubygem-typhoeus
SUBDIR += rubygem-uglifier
diff --git a/www/rubygem-tumblr_client/Makefile b/www/rubygem-tumblr_client/Makefile
new file mode 100644
index 000000000000..c933d020c51b
--- /dev/null
+++ b/www/rubygem-tumblr_client/Makefile
@@ -0,0 +1,27 @@
+# Created by: Michael Moll <kvedulv@kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= tumblr_client
+PORTVERSION= 0.8.5
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= kvedulv@kvedulv.de
+COMMENT= Ruby Wrapper for the Tumblr v2 API
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= rubygem-faraday>=0.9.0:${PORTSDIR}/www/rubygem-faraday \
+ rubygem-faraday_middleware>=0.9.1:${PORTSDIR}/www/rubygem-faraday_middleware \
+ rubygem-json>0:${PORTSDIR}/devel/rubygem-json \
+ rubygem-mime-types>0:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-oauth>0:${PORTSDIR}/net/rubygem-oauth \
+ rubygem-simple_oauth>0:${PORTSDIR}/net/rubygem-simple_oauth
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= bin/tumblr
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-tumblr_client/distinfo b/www/rubygem-tumblr_client/distinfo
new file mode 100644
index 000000000000..517ffb07833e
--- /dev/null
+++ b/www/rubygem-tumblr_client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/tumblr_client-0.8.5.gem) = 6078f6ff48f0755fa610e6b53760f8fc08e01d4d26707cb34c4a7d808150ba34
+SIZE (rubygem/tumblr_client-0.8.5.gem) = 17920
diff --git a/www/rubygem-tumblr_client/pkg-descr b/www/rubygem-tumblr_client/pkg-descr
new file mode 100644
index 000000000000..336bc2ac3491
--- /dev/null
+++ b/www/rubygem-tumblr_client/pkg-descr
@@ -0,0 +1,4 @@
+This is the official Ruby wrapper for the Tumblr v2 API.
+It supports all endpoints currently available on the Tumblr API.
+
+WWW: https://github.com/tumblr/tumblr_client