aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-19 12:25:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-19 12:25:40 +0000
commit8283956ce48512bb213db1673d5c3fc87680038c (patch)
tree0985876717493aa969957964f79ff1381659aa75 /www
parent71bacc3ebe0ed54e1e809fc1adeb7c393138baef (diff)
downloadports-8283956ce48512bb213db1673d5c3fc87680038c.tar.gz
ports-8283956ce48512bb213db1673d5c3fc87680038c.zip
- Fix shebangs
- Added options helpers - NO_ARCH
Notes
Notes: svn path=/head/; revision=438837
Diffstat (limited to 'www')
-rw-r--r--www/py-HTMLgen/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/py-HTMLgen/Makefile b/www/py-HTMLgen/Makefile
index ce9afba6d05c..8c342bfdebf9 100644
--- a/www/py-HTMLgen/Makefile
+++ b/www/py-HTMLgen/Makefile
@@ -3,6 +3,7 @@
PORTNAME= HTMLgen
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= LOCAL/dryice \
http://dryice.name/computer/FreeBSD/distfiles/ \
@@ -13,8 +14,10 @@ DISTNAME= HTMLgen
MAINTAINER= python@FreeBSD.org
COMMENT= Python library for the generation of HTML documents
-USES= python:2
+USES= python:2 shebangfix
NO_BUILD= yes
+NO_ARCH= yes
+SHEBANG_FILES= HTMLutil.py barchart.py
OPTIONS_DEFINE= DOCS
@@ -23,7 +26,7 @@ PORTDOCS= *
post-patch:
@${REINPLACE_CMD} -e 's|python |${PYTHON_CMD} |' ${WRKSRC}/Makefile
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "README html image" ${STAGEDIR}${DOCSDIR})