aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-09-26 12:06:44 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-09-26 12:06:44 +0000
commit88c1e044458f4fd7dbbfe0fd455f0303ca251400 (patch)
treee11da9f2027561d78c8d744c0dd1aeff13b8945f /www
parent3f59c0cc15076a529598f27983c64efdf2e2966a (diff)
downloadports-88c1e044458f4fd7dbbfe0fd455f0303ca251400.tar.gz
ports-88c1e044458f4fd7dbbfe0fd455f0303ca251400.zip
www/nextcloud: Update to 14.0.1
- Fix broken apps-pkg path [1] - Fix plist issues [2] - Add caching, pcntl, imagick options [3] - Remove redundant USES (mysql, pgsql) PR: 231391 [1], 231419 [2], 231704 [3] Submitted by: Nathan <ndowens yahoo com> [2] Submitted by: Matt <fsbruva yahoo com> [3] Reported by: Damjan Jovanovic <damjan jov gmail.com> [1] Reported by: mfechner [2]
Notes
Notes: svn path=/head/; revision=480730
Diffstat (limited to 'www')
-rw-r--r--www/nextcloud/Makefile36
-rw-r--r--www/nextcloud/distinfo6
-rw-r--r--www/nextcloud/files/patch-config_config.sample.php2
-rw-r--r--www/nextcloud/files/pkg-message.in3
-rw-r--r--www/nextcloud/pkg-plist1
5 files changed, 34 insertions, 14 deletions
diff --git a/www/nextcloud/Makefile b/www/nextcloud/Makefile
index 96206f20215a..fde5aa880e00 100644
--- a/www/nextcloud/Makefile
+++ b/www/nextcloud/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nextcloud
-DISTVERSION= 14.0.0
+DISTVERSION= 14.0.1
CATEGORIES= www
MASTER_SITES= https://download.nextcloud.com/server/releases/
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -11,7 +11,7 @@ COMMENT= Personal cloud which runs on your own server
LICENSE= AGPLv3
-USES= cpe gettext-runtime php:flavors,web tar:bzip2 ssl
+USES= cpe gettext-runtime php:flavors,web tar:bzip2
USE_PHP= bz2 ctype curl dom fileinfo filter gd hash iconv json \
mbstring pdo posix session simplexml xml xmlreader xmlwriter \
xsl wddx zip zlib
@@ -26,26 +26,43 @@ SUB_FILES= pkg-message
PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
-OPTIONS_DEFINE= EXIF LDAP OPCACHE SMB SSL
-OPTIONS_MULTI= DB
+OPTIONS_DEFINE= EXIF IMAGICK LDAP PCNTL SMB SSL
+OPTIONS_GROUP= CACHING
+OPTIONS_GROUP_CACHING= APCU MEMCACHED OPCACHE REDIS
+OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
-OPTIONS_DEFAULT= EXIF LDAP MYSQL OPCACHE SSL
+OPTIONS_DEFAULT= APCU EXIF LDAP MYSQL OPCACHE SSL
+APCU_DESC= Local data caching using APCu (recommended)
+CACHING_DESC= Caching
DB_DESC= Database backend(s)
EXIF_DESC= Image rotation support
-OPCACHE_DESC= Enable (Nextcloud recommended) OpCache
+IMAGICK_DESC= Thumbnail support (recommended)
+MEMCACHED_DESC= Distributed data caching using Memcached
+OPCACHE_DESC= Enable OPcode caching (recommended)
+PCNTL_DESC= Long-running process control (recommended)
+REDIS_DESC= Distributed data caching using Redis
EXIF_USE= PHP=exif
+IMAGICK_RUN_DEPENDS= ${PECL_PKGNAMEPREFIX}imagick>=2.2.2:graphics/pecl-imagick@${PHP_FLAVOR}
LDAP_USE= PHP=ldap
-MYSQL_USES= mysql
MYSQL_USE= PHP=pdo_mysql
OPCACHE_USE= PHP=opcache
-PGSQL_USES= pgsql
+PCNTL_USE= PHP=pcntl
PGSQL_USE= PHP=pdo_pgsql,pgsql
+REDIS_RUN_DEPENDS= ${PECL_PKGNAMEPREFIX}redis>=2.2.6:databases/pecl-redis@${PHP_FLAVOR}
SMB_RUN_DEPENDS= ${PECL_PKGNAMEPREFIX}smbclient>=0.9.0:net/pecl-smbclient@${PHP_FLAVOR}
SQLITE_USE= PHP=pdo_sqlite,sqlite3
SSL_USE= PHP=openssl
+.include <bsd.port.pre.mk>
+
+.if ${PHP_VER} >= 70
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu@${PHP_FLAVOR}
+.else
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu4@${PHP_FLAVOR}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/var/www/${PORTNAME}|${WWWDIR}|' ${WRKSRC}/config/config.sample.php
@${MV} ${WRKSRC}/apps ${WRKSRC}/apps-pkg
@@ -56,6 +73,5 @@ do-install:
@${RM} ${STAGEDIR}${WWWDIR}/updater/updater.phar
@${MKDIR} ${STAGEDIR}${WWWDIR}/data
@${MKDIR} ${STAGEDIR}${WWWDIR}/apps
- @${MKDIR} ${STAGEDIR}${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/nextcloud/distinfo b/www/nextcloud/distinfo
index f8418eb29a98..c05276901435 100644
--- a/www/nextcloud/distinfo
+++ b/www/nextcloud/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536578830
-SHA256 (nextcloud-14.0.0.tar.bz2) = f965c14286e7aabbfe49c947d86af59597af302c35d10e0b5440e7e6c53b8f47
-SIZE (nextcloud-14.0.0.tar.bz2) = 49762528
+TIMESTAMP = 1537957022
+SHA256 (nextcloud-14.0.1.tar.bz2) = aafc81e81177a69b9971da4358d5d37cad9a103b103fc1bc2fe384949d61d593
+SIZE (nextcloud-14.0.1.tar.bz2) = 49761953
diff --git a/www/nextcloud/files/patch-config_config.sample.php b/www/nextcloud/files/patch-config_config.sample.php
index 370970ba87ad..4f99b2497530 100644
--- a/www/nextcloud/files/patch-config_config.sample.php
+++ b/www/nextcloud/files/patch-config_config.sample.php
@@ -6,7 +6,7 @@
),
+ array(
+ 'path'=> '/var/www/nextcloud/apps-pkg',
-+ 'url' => '/var/www/apps-pkg',
++ 'url' => '/apps-pkg',
+ 'writable' => false,
+ ),
),
diff --git a/www/nextcloud/files/pkg-message.in b/www/nextcloud/files/pkg-message.in
index a6a232968815..7c7724737818 100644
--- a/www/nextcloud/files/pkg-message.in
+++ b/www/nextcloud/files/pkg-message.in
@@ -16,6 +16,9 @@ like this:
And restart Apache.
+The caching options require additional Nextcloud configuration, see
+https://docs.nextcloud.com/server/12/admin_manual/configuration_server/caching_configuration.html
+
***********************************************************************
* NEXTCLOUD VERSION UPGRADE *
***********************************************************************
diff --git a/www/nextcloud/pkg-plist b/www/nextcloud/pkg-plist
index 71db824e7f1f..841df35bb31a 100644
--- a/www/nextcloud/pkg-plist
+++ b/www/nextcloud/pkg-plist
@@ -8430,6 +8430,7 @@
%%WWWDIR%%/apps-pkg/nextcloud_announcements/lib/Notification/Notifier.php
%%WWWDIR%%/apps-pkg/nextcloud_announcements/lib/Settings/Admin.php
%%WWWDIR%%/apps-pkg/nextcloud_announcements/templates/admin.php
+%%WWWDIR%%/apps-pkg/notifications/.babelrc.js
%%WWWDIR%%/apps-pkg/notifications/.github/contributing.md
%%WWWDIR%%/apps-pkg/notifications/.github/issue_template.md
%%WWWDIR%%/apps-pkg/notifications/.tx/config