aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-13 11:30:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-13 11:39:25 +0000
commit8e8786689a3eb0976c77a253e63fa91ab528c98c (patch)
tree704da5b284c9a118d4250c720e33742e66edd1cf /www
parent0238cce3e936367fa72f5f31e5388d524f2e731b (diff)
downloadports-8e8786689a3eb0976c77a253e63fa91ab528c98c.tar.gz
ports-8e8786689a3eb0976c77a253e63fa91ab528c98c.zip
www/py-boto3: Allow build with py-jmespath 1.0.0+
Diffstat (limited to 'www')
-rw-r--r--www/py-boto3/Makefile3
-rw-r--r--www/py-boto3/files/patch-setup.cfg11
-rw-r--r--www/py-boto3/files/patch-setup.py15
3 files changed, 22 insertions, 7 deletions
diff --git a/www/py-boto3/Makefile b/www/py-boto3/Makefile
index aaa63667dd22..0e8fc0838604 100644
--- a/www/py-boto3/Makefile
+++ b/www/py-boto3/Makefile
@@ -12,9 +12,8 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.21.61<1.22.0:devel/py-botocore@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jmespath>=0.7.1<1.0.0:devel/py-jmespath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jmespath>=0.7.1<2.0.0:devel/py-jmespath@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}s3transfer>=0.5.0<0.6.0:net/py-s3transfer@${PY_FLAVOR}
-
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
diff --git a/www/py-boto3/files/patch-setup.cfg b/www/py-boto3/files/patch-setup.cfg
new file mode 100644
index 000000000000..fecac01126f4
--- /dev/null
+++ b/www/py-boto3/files/patch-setup.cfg
@@ -0,0 +1,11 @@
+--- setup.cfg.orig 2021-10-13 18:09:14 UTC
++++ setup.cfg
+@@ -4,7 +4,7 @@ universal = 0
+ [metadata]
+ requires_dist =
+ botocore>=1.21.61,<1.22.0
+- jmespath>=0.7.1,<1.0.0
++ jmespath>=0.7.1,<2.0.0
+ s3transfer>=0.5.0,<0.6.0
+
+ [options.extras_require]
diff --git a/www/py-boto3/files/patch-setup.py b/www/py-boto3/files/patch-setup.py
index e3203e030bd3..5dec2da0c688 100644
--- a/www/py-boto3/files/patch-setup.py
+++ b/www/py-boto3/files/patch-setup.py
@@ -1,7 +1,12 @@
---- setup.py.orig 2019-03-01 20:19:03 UTC
+--- setup.py.orig 2021-10-13 18:09:14 UTC
+++ setup.py
-@@ -19,6 +19,9 @@ requires = [
- 's3transfer>=0.2.0,<0.3.0'
+@@ -14,10 +14,13 @@ VERSION_RE = re.compile(r'''__version__ = ['"]([0-9.]+
+
+ requires = [
+ 'botocore>=1.21.61,<1.22.0',
+- 'jmespath>=0.7.1,<1.0.0',
++ 'jmespath>=0.7.1,<2.0.0',
+ 's3transfer>=0.5.0,<0.6.0'
]
+tests_require = [
@@ -10,12 +15,12 @@
def get_version():
init = open(os.path.join(ROOT, 'boto3', '__init__.py')).read()
-@@ -42,6 +45,8 @@ setup(
+@@ -41,6 +44,8 @@ setup(
},
include_package_data=True,
install_requires=requires,
+ tests_require=tests_require,
+ test_suite='nose.collector',
license="Apache License 2.0",
+ python_requires=">= 3.6",
classifiers=[
- 'Development Status :: 5 - Production/Stable',