aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2014-07-21 15:22:11 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2014-07-21 15:22:11 +0000
commit90205107da11a8a9a66526201225d2b0e4ac159e (patch)
treeab1cfbd379a0e45dd10470f755b5d39c996a7d33 /www
parent94e77bcbc767884cd3f99f00f63ccc669013aa49 (diff)
downloadports-90205107da11a8a9a66526201225d2b0e4ac159e.tar.gz
ports-90205107da11a8a9a66526201225d2b0e4ac159e.zip
Upgrade to version 0.10.0 and clean up plist.
Notes
Notes: svn path=/head/; revision=362444
Diffstat (limited to 'www')
-rw-r--r--www/cowboy/Makefile12
-rw-r--r--www/cowboy/distinfo4
-rw-r--r--www/cowboy/files/patch-Makefile10
-rw-r--r--www/cowboy/files/patch-rebar.config10
-rw-r--r--www/cowboy/pkg-plist304
5 files changed, 153 insertions, 187 deletions
diff --git a/www/cowboy/Makefile b/www/cowboy/Makefile
index 724c621bd5e2..bc9343518b0c 100644
--- a/www/cowboy/Makefile
+++ b/www/cowboy/Makefile
@@ -1,15 +1,17 @@
# $FreeBSD$
PORTNAME= cowboy
-PORTVERSION= 0.8.6
+PORTVERSION= 0.10.0
CATEGORIES= www
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Small, fast and modular HTTP server written in Erlang
-BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
+ cowlib>=0.6.2:${PORTSDIR}/devel/cowlib
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
- ranch>=0:${PORTSDIR}/net/ranch
+ cowlib>=0.6.2:${PORTSDIR}/devel/cowlib \
+ ranch>=0.10.0:${PORTSDIR}/net/ranch
PLIST_SUB= VERSION="${PORTVERSION}"
@@ -17,13 +19,11 @@ USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= extend
GH_PROJECT= cowboy
-GH_COMMIT= 9eaee45
+GH_COMMIT= ee3ad5e
GH_TAGNAME= ${PORTVERSION}
PORTDOCS= *
-.include <bsd.port.options.mk>
-
do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/guide/* ${STAGEDIR}${DOCSDIR}
diff --git a/www/cowboy/distinfo b/www/cowboy/distinfo
index 6b1746d0120c..dd288214eb9c 100644
--- a/www/cowboy/distinfo
+++ b/www/cowboy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cowboy-0.8.6.tar.gz) = bc89daa585f370b85a4c5ada7d8ea457fe2dca03469b10004f82fb9d802137be
-SIZE (cowboy-0.8.6.tar.gz) = 3931343
+SHA256 (cowboy-0.10.0.tar.gz) = a9672d1fc6a07087b2d28b6dbc22a59d01538c021358e27dcbf814a55eace239
+SIZE (cowboy-0.10.0.tar.gz) = 3990523
diff --git a/www/cowboy/files/patch-Makefile b/www/cowboy/files/patch-Makefile
index 288c7f351ddd..a56614dde021 100644
--- a/www/cowboy/files/patch-Makefile
+++ b/www/cowboy/files/patch-Makefile
@@ -3,12 +3,12 @@ $FreeBSD$
--- Makefile.orig
+++ Makefile
-@@ -10,7 +10,7 @@
+@@ -13,7 +13,7 @@
# Dependencies.
--DEPS = ranch
+-DEPS = cowlib ranch
+DEPS =
- TEST_DEPS = ct_helper
- dep_ranch = https://github.com/extend/ranch.git 0.8.4
- dep_ct_helper = https://github.com/extend/ct_helper.git master
+ dep_cowlib = pkg://cowlib 0.6.2
+ dep_ranch = pkg://ranch 0.10.0
+
diff --git a/www/cowboy/files/patch-rebar.config b/www/cowboy/files/patch-rebar.config
deleted file mode 100644
index 93d28ecd7aed..000000000000
--- a/www/cowboy/files/patch-rebar.config
+++ /dev/null
@@ -1,10 +0,0 @@
-
-$FreeBSD$
-
---- rebar.config.orig
-+++ rebar.config
-@@ -1,3 +1,3 @@
- {deps, [
-- {ranch, ".*", {git, "git://github.com/extend/ranch.git", "0.8.4"}}
-+ {ranch, ".*"}
- ]}.
diff --git a/www/cowboy/pkg-plist b/www/cowboy/pkg-plist
index 7cda4b0dbb39..0eefe7a6619a 100644
--- a/www/cowboy/pkg-plist
+++ b/www/cowboy/pkg-plist
@@ -1,263 +1,239 @@
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.app
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_app.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_bstr.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_client.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_clock.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_handler.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http_handler.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_loop_handler.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_middleware.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_multipart.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_protocol.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_req.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_rest.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_router.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_spdy.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_static.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sub_protocol.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sup.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket_handler.beam
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy.app.src
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_app.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_bstr.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_client.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_clock.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_handler.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http_handler.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_loop_handler.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_middleware.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_multipart.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_protocol.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_req.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_rest.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_router.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_spdy.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_spdy.hrl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_static.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sub_protocol.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sup.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket.erl
-%%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.app
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_app.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_bstr.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_clock.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_loop_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_middleware.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_protocol.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_req.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_rest.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_router.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_spdy.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_static.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sub_protocol.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sup.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy.app.src
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_app.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_bstr.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_clock.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_loop_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_middleware.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_protocol.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_req.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_rest.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_router.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_spdy.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_static.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sub_protocol.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sup.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/rebar.config
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth_app.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/basic_auth_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic_auth/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/start.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/templates/toppage.dtl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/curl_post.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/start.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world.ex
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world/supervisor.ex
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world/top_page_handler.ex
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/mix.exs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/test/elixir_hello_world_test.exs
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/elixir_hello_world/test/test_helper.exs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_app.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_responder.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/priv/index.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/small.mp4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/small.ogv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/video.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/erlmarkdown.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_converter.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/rest_basic_auth.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/rest_basic_auth_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/rest_basic_auth_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/priv/index.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/priv/index.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/cowboy-ca.crt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/server.crt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/server.key
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/toppage_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/small.mp4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/small.ogv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/test.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/video.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/priv/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/README.md
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/small.mp4
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/small.ogv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/test.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/video.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/rebar.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/directory_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/directory_lister.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/start.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/html_ws_client.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/index.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/static/jquery.min.js
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/rebar.config
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/relx.config
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/ws_handler.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/start.sh
-@dirrm %%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/src
-@dirrm %%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%/ebin
-@dirrm %%LIB32DIR%%/erlang/lib/cowboy-%%VERSION%%
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket/priv/static
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/websocket
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/web_server/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/web_server/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/web_server
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/static_world/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/static_world/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/static_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world/priv/ssl
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ssl_hello_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_stream_response/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_stream_response
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_pastebin/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_pastebin/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_pastebin
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_hello_world/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rest_hello_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/markdown_middleware/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/markdown_middleware/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/markdown_middleware
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hello_world/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hello_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eventsource/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eventsource/priv
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eventsource
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/error_hook/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/error_hook
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world/test
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world/lib/elixir_hello_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world/lib
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/elixir_hello_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_post/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_post
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_get/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo_get
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie/templates
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cookie
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/compress_response/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/compress_response
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/chunked_hello_world/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/chunked_hello_world
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/basic_auth/src
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/basic_auth
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry lib/erlang/lib/cowboy-%%VERSION%%/src
+@dirrmtry lib/erlang/lib/cowboy-%%VERSION%%/ebin
+@dirrmtry lib/erlang/lib/cowboy-%%VERSION%%
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket/priv/static
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/web_server/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/web_server/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/web_server
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/upload/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/upload/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/upload
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/static_world/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/static_world/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/static_world
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world/priv/ssl
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_stream_response/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_stream_response
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_pastebin/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_pastebin/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_pastebin
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_hello_world/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_hello_world
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_basic_auth/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_basic_auth
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/markdown_middleware/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/markdown_middleware/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/markdown_middleware
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/hello_world/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/hello_world
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/eventsource/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/eventsource/priv
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/eventsource
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/error_hook/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/error_hook
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_post/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_post
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_get/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_get
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cookie/templates
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cookie/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cookie
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/compress_response/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/compress_response
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/chunked_hello_world/src
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/chunked_hello_world
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%