aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-01-06 16:53:07 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-01-06 16:53:07 +0000
commit9168603ee2a4caf0184a678f8c87fd4c35b5309e (patch)
treebeed789c375f11c48d387803bbb6f26ed98f78ab /www
parent7d2247fbb14d14757e294626dc02ce359ccf9953 (diff)
downloadports-9168603ee2a4caf0184a678f8c87fd4c35b5309e.tar.gz
ports-9168603ee2a4caf0184a678f8c87fd4c35b5309e.zip
- Remove conditional checks for FreeBSD 5.x and older
Approved by: pav
Notes
Notes: svn path=/head/; revision=225331
Diffstat (limited to 'www')
-rw-r--r--www/abyssws/Makefile4
-rw-r--r--www/apache20/Makefile8
-rw-r--r--www/apache22/Makefile4
-rw-r--r--www/cacheboy/Makefile15
-rw-r--r--www/cacheboy15-devel/Makefile16
-rw-r--r--www/cacheboy16/Makefile16
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox36/Makefile2
-rw-r--r--www/flock/Makefile2
-rw-r--r--www/linuxpluginwrapper/Makefile32
-rw-r--r--www/opera-devel/Makefile4
-rw-r--r--www/opera/Makefile10
-rw-r--r--www/opera/distinfo3
-rw-r--r--www/pecl-pecl_http/Makefile8
-rw-r--r--www/seamonkey/Makefile4
-rw-r--r--www/seamonkey2/Makefile4
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid26/Makefile15
-rw-r--r--www/squid30/Makefile15
-rw-r--r--www/squid31/Makefile15
-rw-r--r--www/thttpd/Makefile2
-rw-r--r--www/w3m/Makefile5
-rw-r--r--www/webkit-gtk2/Makefile4
-rw-r--r--www/yabb/Makefile4
25 files changed, 9 insertions, 189 deletions
diff --git a/www/abyssws/Makefile b/www/abyssws/Makefile
index e5b7e86bfdd4..72b2f7e99800 100644
--- a/www/abyssws/Makefile
+++ b/www/abyssws/Makefile
@@ -25,10 +25,6 @@ USE_RC_SUBR= abyssws.sh
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= is for FreeBSD 6.x and newer
-.endif
-
.if ${OSVERSION} >= 700043
LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
.endif
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 81946d9f805f..5c7ee3c2b4e8 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -139,7 +139,7 @@ CONFIGURE_ARGS+= --with-ldap \
.include "${APACHEDIR}/Makefile.modules"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600023 && ${OSVERSION} < 700014 && ${ARCH} == i386
+.if ${OSVERSION} < 700014 && ${ARCH} == i386
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
.endif
@@ -149,12 +149,8 @@ IGNORE= : apr from ports (WITH_APR_FROM_PORTS) is no longer supported
.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
-. if ${OSVERSION} > 500023
-. if ${ARCH} == i386
+. if ${ARCH} == i386
CONFIGURE_ARGS+= --enable-nonportable-atomics
-. endif
-. else
-CFLAGS+= -DFREEBSD_THREAD_HACK
. endif
.endif
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 98ad5bae9a0c..ff7f8ced8064 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -167,10 +167,8 @@ CONFIGURE_ARGS+= --enable-v4-mapped
.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
-. if ${OSVERSION} > 500023
-. if ${ARCH} == i386
+. if ${ARCH} == i386
CONFIGURE_ARGS+= --enable-nonportable-atomics
-. endif
. endif
.endif
diff --git a/www/cacheboy/Makefile b/www/cacheboy/Makefile
index fa272f0319be..2b4256509d60 100644
--- a/www/cacheboy/Makefile
+++ b/www/cacheboy/Makefile
@@ -230,10 +230,8 @@ libexec+= squid_kerb_auth
storage_schemes= ufs diskd null
.if defined(WITH_SQUID_AUFS)
storage_schemes+= aufs
-.if ${OSVERSION}>=501000
# Only document libmap.conf where it is available:
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
-.endif
# Nil aufs threads is default, set any other value via SQUID_CONFIGURE_ARGS
CONFIGURE_ARGS+= --with-pthreads
CFLAGS+= ${PTHREAD_CFLAGS}
@@ -313,23 +311,10 @@ CONFIGURE_ARGS+= --enable-arp-acl
.endif
.if defined(WITH_SQUID_PF)
CONFIGURE_ARGS+= --enable-pf-transparent
-.if ${OSVERSION} < 502106
-IGNORE= pf available only in FreeBSD 5.3 and newer
-.endif
.endif
-# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
-# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
-# 2003-06-27 (OSVERSION < 501101).
-#
-# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
-# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= the IPFilter headers are not part of the base system
-.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
-.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
CONFIGURE_ARGS+= --enable-follow-x-forwarded-for
.endif
diff --git a/www/cacheboy15-devel/Makefile b/www/cacheboy15-devel/Makefile
index 05fa640153dd..dc026347ec18 100644
--- a/www/cacheboy15-devel/Makefile
+++ b/www/cacheboy15-devel/Makefile
@@ -232,10 +232,7 @@ libexec+= squid_kerb_auth
storage_schemes= ufs diskd null
.if defined(WITH_SQUID_AUFS)
storage_schemes+= aufs
-.if ${OSVERSION}>=501000
-# Only document libmap.conf where it is available:
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
-.endif
# Nil aufs threads is default, set any other value via SQUID_CONFIGURE_ARGS
CONFIGURE_ARGS+= --with-pthreads
CFLAGS+= ${PTHREAD_CFLAGS}
@@ -315,23 +312,10 @@ CONFIGURE_ARGS+= --enable-arp-acl
.endif
.if defined(WITH_SQUID_PF)
CONFIGURE_ARGS+= --enable-pf-transparent
-.if ${OSVERSION} < 502106
-IGNORE= pf available only in FreeBSD 5.3 and newer
-.endif
.endif
-# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
-# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
-# 2003-06-27 (OSVERSION < 501101).
-#
-# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
-# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= the IPFilter headers are not part of the base system
-.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
-.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
CONFIGURE_ARGS+= --enable-follow-x-forwarded-for
.endif
diff --git a/www/cacheboy16/Makefile b/www/cacheboy16/Makefile
index 05fa640153dd..dc026347ec18 100644
--- a/www/cacheboy16/Makefile
+++ b/www/cacheboy16/Makefile
@@ -232,10 +232,7 @@ libexec+= squid_kerb_auth
storage_schemes= ufs diskd null
.if defined(WITH_SQUID_AUFS)
storage_schemes+= aufs
-.if ${OSVERSION}>=501000
-# Only document libmap.conf where it is available:
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
-.endif
# Nil aufs threads is default, set any other value via SQUID_CONFIGURE_ARGS
CONFIGURE_ARGS+= --with-pthreads
CFLAGS+= ${PTHREAD_CFLAGS}
@@ -315,23 +312,10 @@ CONFIGURE_ARGS+= --enable-arp-acl
.endif
.if defined(WITH_SQUID_PF)
CONFIGURE_ARGS+= --enable-pf-transparent
-.if ${OSVERSION} < 502106
-IGNORE= pf available only in FreeBSD 5.3 and newer
-.endif
.endif
-# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
-# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
-# 2003-06-27 (OSVERSION < 501101).
-#
-# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
-# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= the IPFilter headers are not part of the base system
-.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
-.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
CONFIGURE_ARGS+= --enable-follow-x-forwarded-for
.endif
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 29fceb2cfa2f..ae3cb3d3a96c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -63,9 +63,7 @@ MOZ_OPTIONS+= --disable-gnomeui
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
-.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
-.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 29fceb2cfa2f..ae3cb3d3a96c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -63,9 +63,7 @@ MOZ_OPTIONS+= --disable-gnomeui
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
-.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
-.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 29fceb2cfa2f..ae3cb3d3a96c 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -63,9 +63,7 @@ MOZ_OPTIONS+= --disable-gnomeui
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
-.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
-.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
diff --git a/www/flock/Makefile b/www/flock/Makefile
index f791148b335d..07a8f62d7f9e 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -63,9 +63,7 @@ BROKEN= does not compile
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
-.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
-.endif
post-extract::
@${SED} -e 's|@FLOCK_ICON@|${FLOCK_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
index bd63cdd90cfd..36667364950a 100644
--- a/www/linuxpluginwrapper/Makefile
+++ b/www/linuxpluginwrapper/Makefile
@@ -44,44 +44,12 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST= ${WRKDIR}/pkg-plist
.endif
-.if ${OSVERSION} >= 700001
LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD6
-.elif ${OSVERSION} >= 600033 && ${OSVERSION} < 700000
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD6
-.elif ${OSVERSION} >= 503001
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-stable
-.else
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-current
-.endif
-
-.if ${OSVERSION} < 501105
-RTLD= /usr/libexec/ld-elf.so.1
-.else
-RTLD= /libexec/ld-elf.so.1
-.endif
.if defined(WITH_DEBUG)
CFLAGS+= -DDEBUG=1
.endif
-.if !defined(PACKAGE_BUILDING)
-.if ${OSVERSION} < 501107
-pre-everything::
- @if ! strings ${RTLD} | ${GREP} libmap.conf > /dev/null 2>&1; then \
- ${ECHO_MSG} 'Please enable libmap.conf(5) feature for rtld(1).'; \
- ${ECHO_MSG} '4-stable user:'; \
- ${ECHO_MSG} ' You can get a following patch.'; \
- ${ECHO_MSG} ' http://people.FreeBSD.org/~nork/libmap_4stable.diff'; \
- ${ECHO_MSG} ' Please apply on /usr/src and make install on /usr/src/libexec/rtld-elf:'; \
- ${ECHO_MSG} ' # cd /usr/src ; patch -p0 < /tmp/libmap_4stable.diff'; \
- ${ECHO_MSG} ' # cd libexec/rtld-elf ; make clean all install'; \
- ${ECHO_MSG} '5.1-RELEASE user:'; \
- ${ECHO_MSG} ' Please see /usr/src/libexec/rtld-elf/Makefile.'; \
- ${FALSE}; \
- fi
-.endif
-.endif
-
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},' \
-e 's,%%LOCALBASE%%,${LOCALBASE},' \
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
index bd16ac27ca25..7a2189607222 100644
--- a/www/opera-devel/Makefile
+++ b/www/opera-devel/Makefile
@@ -42,10 +42,8 @@ ONLY_FOR_ARCHS= i386 amd64
.if ${OSVERSION} >= 700000
OPERA_TYPE= 7
-.elif ${OSVERSION} >= 600000
+.else
OPERA_TYPE= 6
-.else
-IGNORE= is only supported on FreeBSD 6.x and higher
.endif
.if !defined(WITHOUT_ASPELL)
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 13c36ba414ef..3f7c8dec21a8 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -51,11 +51,7 @@ OPTIONS= ASPELL "Use the aspell library for spell checking" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600000
ONLY_FOR_ARCHS= i386 amd64
-.else
-ONLY_FOR_ARCHS= i386
-.endif
.if ${ARCH} == amd64
OPERA_ARCH= amd64
@@ -65,12 +61,8 @@ OPERA_ARCH= intel
.if ${OSVERSION} >= 700000
OPERA_TYPE= 7
-.elif ${OSVERSION} >= 600000
-OPERA_TYPE= 6
-.elif ${OSVERSION} >= 500000
-OPERA_TYPE= 5
.else
-IGNORE= is only supported on FreeBSD 5.x and higher
+OPERA_TYPE= 6
.endif
.if !defined(WITHOUT_ASPELL)
diff --git a/www/opera/distinfo b/www/opera/distinfo
index 6efac1d0861e..567c30733f24 100644
--- a/www/opera/distinfo
+++ b/www/opera/distinfo
@@ -4,9 +4,6 @@ SIZE (opera-9.63-freebsd6-shared-qt3.amd64.tar.bz2) = 7996409
MD5 (opera-9.63-freebsd7-shared-qt3.amd64.tar.bz2) = b7f23283c4e81e4257301b1c0199a31e
SHA256 (opera-9.63-freebsd7-shared-qt3.amd64.tar.bz2) = 566d9f255c889dd24d8f023abc1199a7d087d61fa1b8b637040f7fb3c9f5c423
SIZE (opera-9.63-freebsd7-shared-qt3.amd64.tar.bz2) = 7889803
-MD5 (opera-9.63-freebsd5-shared-qt3.i386.tar.bz2) = a69a3661f1714c44f2ed88049fd29c92
-SHA256 (opera-9.63-freebsd5-shared-qt3.i386.tar.bz2) = ce93c627c81e73baebff54c00abdeb683e9509684b0ef137bf88fa4024a321a5
-SIZE (opera-9.63-freebsd5-shared-qt3.i386.tar.bz2) = 7490934
MD5 (opera-9.63-freebsd6-shared-qt3.i386.tar.bz2) = cca4ece9b44d72986887862ae8c7b661
SHA256 (opera-9.63-freebsd6-shared-qt3.i386.tar.bz2) = b1f037f010a28735e92c9735dae5295d562ff604a833836cae82199d73591023
SIZE (opera-9.63-freebsd6-shared-qt3.i386.tar.bz2) = 7493282
diff --git a/www/pecl-pecl_http/Makefile b/www/pecl-pecl_http/Makefile
index 1b39bb6f2f6e..af2b4c8f5121 100644
--- a/www/pecl-pecl_http/Makefile
+++ b/www/pecl-pecl_http/Makefile
@@ -40,13 +40,7 @@ CONFIGURE_ARGS+=--without-http-curl-requests
.endif
.if defined(WITH_MAGIC_MIME)
-. if ${OSVERSION} < 502128
-LIB_DEPENDS+= magic.1:${PORTSDIR}/sysutils/file
-MAGICBASE= ${LOCALBASE}
-. else
-MAGICBASE= /usr
-. endif
-CONFIGURE_ARGS+=--with-http-magic-mime=${MAGICBASE}
+CONFIGURE_ARGS+=--with-http-magic-mime=/usr
.else
CONFIGURE_ARGS+=--without-http-magic-mime
.endif
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index a5e41cc5e6b2..0fd7441d7342 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -60,10 +60,6 @@ MOZ_OPTIONS+= --enable-glitz
LIB_DEPENDS+= glitz.1:${PORTSDIR}/graphics/glitz
.endif
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
-IGNORE= core dumps on ${ARCH} during post-build
-.endif
-
.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
IGNORE= core dumps on ${ARCH}, need kern.osreldate>=601101
.endif
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index a5e41cc5e6b2..0fd7441d7342 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -60,10 +60,6 @@ MOZ_OPTIONS+= --enable-glitz
LIB_DEPENDS+= glitz.1:${PORTSDIR}/graphics/glitz
.endif
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
-IGNORE= core dumps on ${ARCH} during post-build
-.endif
-
.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
IGNORE= core dumps on ${ARCH}, need kern.osreldate>=601101
.endif
diff --git a/www/squid/Makefile b/www/squid/Makefile
index decd01c5bd55..1a343be37693 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -253,7 +253,7 @@ libexec+= squid_kerb_auth
storage_schemes= ufs diskd null
.if defined(WITH_SQUID_AUFS)
storage_schemes+= aufs
-.if ${OSVERSION}>=501000 && ${OSVERSION}<700055
+.if ${OSVERSION}<700055
# Only document libmap.conf for releases where it may be needed to
# switch from libpthread (aka libkse) to libthr:
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
diff --git a/www/squid26/Makefile b/www/squid26/Makefile
index 0a5aa1c03336..a8a7caf3bb86 100644
--- a/www/squid26/Makefile
+++ b/www/squid26/Makefile
@@ -266,10 +266,8 @@ EXTRA_PATCHES+= ${PATCHDIR}/fix-kerberos.patch
storage_schemes= ufs diskd null
.if defined(WITH_SQUID_AUFS)
storage_schemes+= aufs
-.if ${OSVERSION}>=501000
# Only document libmap.conf where it is available:
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
-.endif
# Nil aufs threads is default, set any other value via SQUID_CONFIGURE_ARGS
CONFIGURE_ARGS+= --with-pthreads
CFLAGS+= ${PTHREAD_CFLAGS}
@@ -349,23 +347,10 @@ CONFIGURE_ARGS+= --enable-arp-acl
.endif
.if defined(WITH_SQUID_PF)
CONFIGURE_ARGS+= --enable-pf-transparent
-.if ${OSVERSION} < 502106
-IGNORE= pf available only in FreeBSD 5.3 and newer
-.endif
.endif
-# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
-# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
-# 2003-06-27 (OSVERSION < 501101).
-#
-# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
-# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= the IPFilter headers are not part of the base system
-.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
-.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
CONFIGURE_ARGS+= --enable-follow-x-forwarded-for
.endif
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 0e62de8c8b20..4ec60e74d0c2 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -245,7 +245,7 @@ storage_schemes= ufs diskd null
storage_schemes+= aufs
# Only document switching from libpthread to libthr using libmap.conf
# where lipthread is the default threading library:
-.if (${OSVERSION} >= 501000) && (${OSVERSION} < 700041)
+.if ${OSVERSION} < 700041
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
.endif
# Nil aufs threads is default, set any other value via SQUID_CONFIGURE_ARGS
@@ -324,23 +324,10 @@ CONFIGURE_ARGS+= --enable-ipfw-transparent
.endif
.if defined(WITH_SQUID_PF)
CONFIGURE_ARGS+= --enable-pf-transparent
-.if ${OSVERSION} < 502106
-IGNORE= pf available only in FreeBSD 5.3 and newer
.endif
-.endif
-# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
-# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
-# 2003-06-27 (OSVERSION < 501101).
-#
-# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
-# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= the IPFilter headers are not part of the base system
-.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
-.endif
.if defined(WITH_SQUID_ICAP)
CONFIGURE_ARGS+= --enable-icap-client
.endif
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 0e62de8c8b20..4ec60e74d0c2 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -245,7 +245,7 @@ storage_schemes= ufs diskd null
storage_schemes+= aufs
# Only document switching from libpthread to libthr using libmap.conf
# where lipthread is the default threading library:
-.if (${OSVERSION} >= 501000) && (${OSVERSION} < 700041)
+.if ${OSVERSION} < 700041
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.aufs
.endif
# Nil aufs threads is default, set any other value via SQUID_CONFIGURE_ARGS
@@ -324,23 +324,10 @@ CONFIGURE_ARGS+= --enable-ipfw-transparent
.endif
.if defined(WITH_SQUID_PF)
CONFIGURE_ARGS+= --enable-pf-transparent
-.if ${OSVERSION} < 502106
-IGNORE= pf available only in FreeBSD 5.3 and newer
.endif
-.endif
-# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
-# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
-# 2003-06-27 (OSVERSION < 501101).
-#
-# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
-# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= the IPFilter headers are not part of the base system
-.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
-.endif
.if defined(WITH_SQUID_ICAP)
CONFIGURE_ARGS+= --enable-icap-client
.endif
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index 920d7426c36d..ce8c9fb179fa 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -40,10 +40,8 @@ post-patch:
${MV} ${WRKSRC}/extras/htpasswd.1 ${WRKSRC}/extras/thttpdpasswd.1
${MV} ${WRKSRC}/extras/htpasswd.c ${WRKSRC}/extras/thttpdpasswd.c
-.if ${OSVERSION} > 502101
post-configure:
@cd ${WRKSRC} && ${PATCH} < ${PATCHDIR}/extra-patch-config.h
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/thttpd ${PREFIX}/sbin
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 89d78543b035..d4196d822227 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -91,17 +91,12 @@ CONFIGURE_ARGS+= --enable-keymap=lynx
.endif
.if defined(WITH_THREADING)
-.if ${OSVERSION} < 502102
-CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lc_r/}"
-.else
# Use -lpthread instead of ${PTHREAD_LIBS} to link libpthread
# and libc before libgc.
# This is necessary to avoid build error with boehm-gc with REDIRECT and
# THREADING options.
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/} -lc"
-.endif
.else
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include"
.endif
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 8b52e2a12748..f57de73b67aa 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -39,10 +39,6 @@ MAKEFILE= GNUmakefile
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= Does not build
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
diff --git a/www/yabb/Makefile b/www/yabb/Makefile
index 5303e84fc042..b5dbe7efc520 100644
--- a/www/yabb/Makefile
+++ b/www/yabb/Makefile
@@ -39,10 +39,6 @@ ISOFILES= Setup.pl Admin/ManageTemplates.pl Languages/English/Admin.lng \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600021 && ( ${OSVERSION} < 504102 || ${OSVERSION} > 599999 )
-RUN_DEPENDS+= sha256:${PORTSDIR}/sysutils/freebsd-sha256
-.endif
-
post-extract:
@${RM} -rf ${WCGI}/Convert ${WCGI}/Modules ${WCGI}/FixFile.pl
@${CHMOD} -R a=,u+rwX ${WCGI}/*