aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-02 10:00:38 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-02 10:00:38 +0000
commit993c8c265e497561b44b4090a45d2e34a3ef5010 (patch)
tree068a07562a1372ec07bf2b251c30ed8bb4b8b553 /www
parentd06c0e64eea7c8474748b1e3083c9df4f53dda5d (diff)
downloadports-993c8c265e497561b44b4090a45d2e34a3ef5010.tar.gz
ports-993c8c265e497561b44b4090a45d2e34a3ef5010.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=325965
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-FCKeditor/Makefile3
-rw-r--r--www/p5-Catalyst-Controller-RequestToken/Makefile3
-rw-r--r--www/p5-Google-Search/Makefile3
-rw-r--r--www/p5-HTML-Chunks/Makefile3
-rw-r--r--www/p5-HTML-Display/Makefile3
-rw-r--r--www/p5-HTML-GoogleMaps/Makefile3
-rw-r--r--www/p5-HTML-TableContentParser/Makefile3
-rw-r--r--www/p5-HTML-Toc/Makefile3
-rw-r--r--www/p5-HTTP-Parser/Makefile3
-rw-r--r--www/p5-LWP-UserAgent-Determined/Makefile3
-rw-r--r--www/p5-Mason/Makefile3
-rw-r--r--www/p5-Plack-Middleware-IEnosniff/Makefile3
-rw-r--r--www/p5-Plack-Middleware-MemoryUsage/Makefile3
-rw-r--r--www/p5-Tenjin/Makefile3
-rw-r--r--www/p5-URI-ToDisk/Makefile3
-rw-r--r--www/p5-WWW-Mechanize-DecodedContent/Makefile3
-rw-r--r--www/p5-WWW-Plurk/Makefile3
-rw-r--r--www/p5-WWW-Shorten-0rz/Makefile3
-rw-r--r--www/p5-WebService-Pushover/Makefile3
19 files changed, 38 insertions, 19 deletions
diff --git a/www/p5-CGI-FCKeditor/Makefile b/www/p5-CGI-FCKeditor/Makefile
index 76c39f5e6440..545f4be96f31 100644
--- a/www/p5-CGI-FCKeditor/Makefile
+++ b/www/p5-CGI-FCKeditor/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= This's FCKeditor Controller for Perl OOP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::FCKeditor.3
diff --git a/www/p5-Catalyst-Controller-RequestToken/Makefile b/www/p5-Catalyst-Controller-RequestToken/Makefile
index 240d15085e7e..7803a46ae879 100644
--- a/www/p5-Catalyst-Controller-RequestToken/Makefile
+++ b/www/p5-Catalyst-Controller-RequestToken/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Catalyst-Action-RenderView>=0:${PORTSDIR}/www/p5-Catalyst-Acti
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Controller::RequestToken.3 \
Catalyst::Controller::RequestToken::Action::CreateToken.3 \
diff --git a/www/p5-Google-Search/Makefile b/www/p5-Google-Search/Makefile
index 147ec318296c..223d40468a80 100644
--- a/www/p5-Google-Search/Makefile
+++ b/www/p5-Google-Search/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-Try-Tiny>=0.07:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Google::Search.3 Google::Search::Result.3
diff --git a/www/p5-HTML-Chunks/Makefile b/www/p5-HTML-Chunks/Makefile
index 3e8c6c9c9b58..d1b38558c0d6 100644
--- a/www/p5-HTML-Chunks/Makefile
+++ b/www/p5-HTML-Chunks/Makefile
@@ -16,7 +16,8 @@ COMMENT= A simple nested template engine for HTML, XML and XHTML
RUN_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/www/p5-HTML-Display/Makefile b/www/p5-HTML-Display/Makefile
index 7c708778ca1a..441a575a7c4f 100644
--- a/www/p5-HTML-Display/Makefile
+++ b/www/p5-HTML-Display/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-HTML-TokeParser-Simple>=2:${PORTSDIR}/www/p5-HTML-TokeParser-Sim
BUILD_DEPENDS:= ${RUN_DEPENDS} \
p5-Test-Harness>=2.30:${PORTSDIR}/devel/p5-Test-Harness
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Display.3 \
HTML::Display::Common.3 \
diff --git a/www/p5-HTML-GoogleMaps/Makefile b/www/p5-HTML-GoogleMaps/Makefile
index c315349f6678..a839be9c7c75 100644
--- a/www/p5-HTML-GoogleMaps/Makefile
+++ b/www/p5-HTML-GoogleMaps/Makefile
@@ -18,7 +18,8 @@ COMMENT= A simple wrapper around the Google Maps API
RUN_DEPENDS= p5-Geo-Coder-Google>=0.02:${PORTSDIR}/misc/p5-Geo-Coder-Google
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::GoogleMaps.3
diff --git a/www/p5-HTML-TableContentParser/Makefile b/www/p5-HTML-TableContentParser/Makefile
index d8978a2b02d1..0f0991b1654f 100644
--- a/www/p5-HTML-TableContentParser/Makefile
+++ b/www/p5-HTML-TableContentParser/Makefile
@@ -12,7 +12,8 @@ COMMENT= Do interesting things with the contents of tables
RUN_DEPENDS= p5-HTML-Parser>=3.68:${PORTSDIR}/www/p5-HTML-Parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::TableContentParser.3
diff --git a/www/p5-HTML-Toc/Makefile b/www/p5-HTML-Toc/Makefile
index fc070a45bc94..67862ab9de94 100644
--- a/www/p5-HTML-Toc/Makefile
+++ b/www/p5-HTML-Toc/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Parser/Makefile b/www/p5-HTTP-Parser/Makefile
index f4a69de95d25..a17154743424 100644
--- a/www/p5-HTTP-Parser/Makefile
+++ b/www/p5-HTTP-Parser/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-URI>=0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Parser.3
diff --git a/www/p5-LWP-UserAgent-Determined/Makefile b/www/p5-LWP-UserAgent-Determined/Makefile
index 08f816f010ed..a48e7e6250cc 100644
--- a/www/p5-LWP-UserAgent-Determined/Makefile
+++ b/www/p5-LWP-UserAgent-Determined/Makefile
@@ -18,7 +18,8 @@ COMMENT= A virtual browser that retries errors
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= LWP::UserAgent::Determined.3
diff --git a/www/p5-Mason/Makefile b/www/p5-Mason/Makefile
index a0bf25cbc491..6a6ea3ff407d 100644
--- a/www/p5-Mason/Makefile
+++ b/www/p5-Mason/Makefile
@@ -35,7 +35,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Class-Most>=0:${PORTSDIR}/devel/p5-Test-Class-Most \
p5-Test-LongString>=0:${PORTSDIR}/devel/p5-Test-LongString
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mason.pl.1
MAN3= Mason.3 \
diff --git a/www/p5-Plack-Middleware-IEnosniff/Makefile b/www/p5-Plack-Middleware-IEnosniff/Makefile
index 7f1f068ff025..53c3178b7636 100644
--- a/www/p5-Plack-Middleware-IEnosniff/Makefile
+++ b/www/p5-Plack-Middleware-IEnosniff/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= \
p5-Plack>0:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::IEnosniff.3
diff --git a/www/p5-Plack-Middleware-MemoryUsage/Makefile b/www/p5-Plack-Middleware-MemoryUsage/Makefile
index 7d39b63e7558..e49e758d85d6 100644
--- a/www/p5-Plack-Middleware-MemoryUsage/Makefile
+++ b/www/p5-Plack-Middleware-MemoryUsage/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
p5-Plack>0:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::MemoryUsage.3
diff --git a/www/p5-Tenjin/Makefile b/www/p5-Tenjin/Makefile
index 5fecc69b8d43..f61ae9bc92ca 100644
--- a/www/p5-Tenjin/Makefile
+++ b/www/p5-Tenjin/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tenjin.3 \
Tenjin::Context.3 \
diff --git a/www/p5-URI-ToDisk/Makefile b/www/p5-URI-ToDisk/Makefile
index 3c0a7efef888..d60ab227ac49 100644
--- a/www/p5-URI-ToDisk/Makefile
+++ b/www/p5-URI-ToDisk/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
p5-Params-Util>=0.31:${PORTSDIR}/devel/p5-Params-Util
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::ToDisk.3
diff --git a/www/p5-WWW-Mechanize-DecodedContent/Makefile b/www/p5-WWW-Mechanize-DecodedContent/Makefile
index 3169149a6069..f06162398324 100644
--- a/www/p5-WWW-Mechanize-DecodedContent/Makefile
+++ b/www/p5-WWW-Mechanize-DecodedContent/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
p5-HTTP-Response-Encoding>=0:${PORTSDIR}/www/p5-HTTP-Response-Encoding
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Mechanize::DecodedContent.3
diff --git a/www/p5-WWW-Plurk/Makefile b/www/p5-WWW-Plurk/Makefile
index 1b64f52468ac..0fba267ff259 100644
--- a/www/p5-WWW-Plurk/Makefile
+++ b/www/p5-WWW-Plurk/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-DateTime-Format-Mail>=0:${PORTSDIR}/devel/p5-DateTime-Format-Mai
BUILD_DEPENDS:= ${RUN_DEPENDS}
BUILD_DEPENDS+= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Plurk.3 WWW::Plurk::Friend.3 WWW::Plurk::Message.3
diff --git a/www/p5-WWW-Shorten-0rz/Makefile b/www/p5-WWW-Shorten-0rz/Makefile
index 67b9f0f7f3a1..f29522e3fb7b 100644
--- a/www/p5-WWW-Shorten-0rz/Makefile
+++ b/www/p5-WWW-Shorten-0rz/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-WWW-Shorten>=0:${PORTSDIR}/www/p5-WWW-Shorten \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Shorten::0rz.3
diff --git a/www/p5-WebService-Pushover/Makefile b/www/p5-WebService-Pushover/Makefile
index a3df6d4692f9..86450cb586c7 100644
--- a/www/p5-WebService-Pushover/Makefile
+++ b/www/p5-WebService-Pushover/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-WebService-Simple>=0:${PORTSDIR}/www/p5-WebService-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::Pushover.3