aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-09-19 10:36:57 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-09-19 10:39:10 +0000
commit99b83a62da63aaa25880c914f339754172aec798 (patch)
tree04d1bd276fc97fa8e0cad4ee1cd8dda5a000164d /www
parent4609aa022f0ad712f7a323d024fc0a82ce08d3fd (diff)
downloadports-99b83a62da63aaa25880c914f339754172aec798.tar.gz
ports-99b83a62da63aaa25880c914f339754172aec798.zip
www/py-dj32-django-treebeard: Add new port
django-treebeard is a library that implements efficient tree implementations for the Django Web Framework 1.8 and later. Features: - Flexible: Includes 3 different tree implementations with the same API: * Adjacency List * Materialized Path * Nested Sets - Fast: Optimized non-naive tree operations - Easy: Uses Django Model Inheritance with abstract classes to define your own models. - Clean: Testable and well tested code base. Code/branch test coverage is above 96%. WWW: https://github.com/django-treebeard/django-treebeard NB: This port is assigned to Django 3.2 and www/py-django-treebeard was used as a template. Reported by: sunpoet (via mail)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-dj32-django-treebeard/Makefile44
-rw-r--r--www/py-dj32-django-treebeard/distinfo3
-rw-r--r--www/py-dj32-django-treebeard/pkg-descr16
4 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 61a07dd85ef5..160f4ab43603 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1467,6 +1467,7 @@
SUBDIR += py-dj32-django-tables2
SUBDIR += py-dj32-django-taggit
SUBDIR += py-dj32-django-timezone-field
+ SUBDIR += py-dj32-django-treebeard
SUBDIR += py-dj32-djangorestframework
SUBDIR += py-dj32-drf-yasg
SUBDIR += py-django
diff --git a/www/py-dj32-django-treebeard/Makefile b/www/py-dj32-django-treebeard/Makefile
new file mode 100644
index 000000000000..723f50155474
--- /dev/null
+++ b/www/py-dj32-django-treebeard/Makefile
@@ -0,0 +1,44 @@
+PORTNAME= django-treebeard
+DISTVERSION= 4.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj32-
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Efficient tree implementations for Django
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}graphviz>0:graphics/py-graphviz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
+
+.include <bsd.port.pre.mk>
+# Set a locale to avoid build/configure errors. The UTF-8 mode is enabled by
+# default when the locale is C since Python 3.7.
+.if ${PYTHON_REL} < 30700
+USE_LOCALE= en_US.UTF-8
+.endif
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/build/sphinx/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
+ "! -name .buildinfo -and ! -name objects.inv")
+
+do-test:
+ @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.post.mk>
diff --git a/www/py-dj32-django-treebeard/distinfo b/www/py-dj32-django-treebeard/distinfo
new file mode 100644
index 000000000000..04d0e8cf8482
--- /dev/null
+++ b/www/py-dj32-django-treebeard/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1611419684
+SHA256 (django-treebeard-4.4.tar.gz) = f50e4eea146f7af6702decf7ef198ac1eee1fb9bb4af2c5dba276c3c48f76623
+SIZE (django-treebeard-4.4.tar.gz) = 310658
diff --git a/www/py-dj32-django-treebeard/pkg-descr b/www/py-dj32-django-treebeard/pkg-descr
new file mode 100644
index 000000000000..ffc8415ab637
--- /dev/null
+++ b/www/py-dj32-django-treebeard/pkg-descr
@@ -0,0 +1,16 @@
+django-treebeard is a library that implements efficient tree implementations for
+the Django Web Framework 1.8 and later.
+
+Features:
+
+- Flexible: Includes 3 different tree implementations with the same API:
+ * Adjacency List
+ * Materialized Path
+ * Nested Sets
+- Fast: Optimized non-naive tree operations
+- Easy: Uses Django Model Inheritance with abstract classes to define your own
+ models.
+- Clean: Testable and well tested code base. Code/branch test coverage is
+ above 96%.
+
+WWW: https://github.com/django-treebeard/django-treebeard