aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2020-02-13 22:08:56 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2020-02-13 22:08:56 +0000
commit9d9f11f94b71fc0240b4ad623f75d6a82b95975e (patch)
tree22e95a3b4c5d90d41335e5720b95f0e4f9c5df6f /www
parentc23b989f95bf4f956805d22261e290ff8a1b8199 (diff)
downloadports-9d9f11f94b71fc0240b4ad623f75d6a82b95975e.tar.gz
ports-9d9f11f94b71fc0240b4ad623f75d6a82b95975e.zip
This commit introduces two new knobs:
o) SSL - enable SSL/TLS, disable by default; o) DEVKIT - install unit static library and headers for development. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=526068
Diffstat (limited to 'www')
-rw-r--r--www/unit/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/unit/Makefile b/www/unit/Makefile
index 686398f61613..5013baad32a9 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= unit
PORTVERSION= 1.15.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://unit.nginx.org/download/
@@ -19,11 +20,15 @@ CPE_PRODUCT= unit
OPTIONS_DEFINE?= \
DEBUG \
+ DEVKIT \
IPV6 \
+ SSL \
UNIXSOCK
OPTIONS_DEFAULT?=UNIXSOCK
DEBUG_DESC= Enable debug logging
+DEVKIT_DESC= Install headers and library
+SSL_DESC= Enable SSL/TLS
UNIXSOCK_DESC= Enable unix sockets
.include <bsd.port.options.mk>
@@ -57,16 +62,37 @@ SUB_LIST= UNIT_PIDFILE=${UNIT_PIDFILE} \
CONFIGURE_ARGS+=--debug
.endif
+.if ${PORT_OPTIONS:MDEVKIT}
+PLIST_FILES+= include/nxt_unit_field.h \
+ include/nxt_unit.h \
+ include/nxt_unit_request.h \
+ include/nxt_unit_response.h \
+ include/nxt_unit_sptr.h \
+ include/nxt_unit_typedefs.h \
+ include/nxt_unit_websocket.h \
+ include/nxt_version.h \
+ include/nxt_websocket_header.h \
+ lib/libunit.a
+.endif
+
.if empty(PORT_OPTIONS:MIPV6)
CONFIGURE_ARGS+=--no-ipv6
.endif
+.if ${PORT_OPTIONS:MSSL}
+CONFIGURE_ARGS+=--openssl
+USES+= ssl
+.endif
+
.if empty(PORT_OPTIONS:MUNIXSOCK)
CONFIGURE_ARGS+=--no-unix-sockets
.else
CONFIGURE_ARGS+=--control=unix:${UNIT_SOCK}
.endif
+post-build-DEVKIT-on:
+ @cd ${WRKSRC} && ${GMAKE} build/libunit.a
+
.if !target(post-install)
post-install:
${MKDIR} ${STAGEDIR}${UNIT_LOGDIR}
@@ -74,6 +100,9 @@ post-install:
${ECHO_CMD} @dir ${UNIT_LOGDIR} >> ${TMPPLIST}
${ECHO_CMD} @dir ${UNIT_RUNDIR} >> ${TMPPLIST}
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unit/modules
+
+post-install-DEVKIT-on:
+ ${GMAKE} -C ${WRKSRC} libunit-install DESTDIR=${STAGEDIR}
.endif
.include <bsd.port.mk>