aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2023-01-31 12:20:43 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2023-02-01 09:21:09 +0000
commita996b5d8e9f736b9c47b3cf4fc7bda445ef2a4cf (patch)
tree26156121f793be41de536dae17d7d402ba2e50ad /www
parent2cbee9b2a834583bfbb14c31720adad04730dabb (diff)
downloadports-a996b5d8e9f736b9c47b3cf4fc7bda445ef2a4cf.tar.gz
ports-a996b5d8e9f736b9c47b3cf4fc7bda445ef2a4cf.zip
www/gitlab-ce: major upgrade to 15.8.0
Diffstat (limited to 'www')
-rw-r--r--www/gitlab-ce/Makefile25
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/files/patch-Gemfile19
-rw-r--r--www/gitlab-ce/files/patch-config_gitlab.yml.example14
-rw-r--r--www/gitlab-ce/pkg-message4
5 files changed, 31 insertions, 37 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 763a29731b66..7ce5407bb3f1 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gitlab-ce
-PORTVERSION= 15.7.5
+PORTVERSION= 15.8.0
PORTREVISION= 0
CATEGORIES= www devel
@@ -16,11 +16,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# see https://gitlab.com/gitlab-org/gitlab/-/issues/350866
MY_DEPENDS= git>=2.39.1:devel/git \
gitaly>=${PORTVERSION}:devel/gitaly \
- gitlab-elasticsearch-indexer>=3.1.0:textproc/gitlab-elasticsearch-indexer \
- gitlab-agent>=15.7.0:net/gitlab-agent \
+ gitlab-elasticsearch-indexer>=3.2.0:textproc/gitlab-elasticsearch-indexer \
+ gitlab-agent>=15.8.0:net/gitlab-agent \
gitlab-metrics-exporter>0:devel/gitlab-metrics-exporter \
gitlab-pages>=${PORTVERSION}:www/gitlab-pages \
- gitlab-shell>=14.14.0:devel/gitlab-shell \
+ gitlab-shell>=14.15.0:devel/gitlab-shell \
gitlab-workhorse>=${PORTVERSION}:www/gitlab-workhorse \
redis>=6.0.14:databases/redis \
yarn>=1.10.0:www/yarn \
@@ -34,7 +34,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-sprockets3>=3.7<3.8:devel/rubygem-sprockets3 \
rubygem-view_component-rails61>=2.74.1<2.75:devel/rubygem-view_component-rails61 \
rubygem-default_value_for>=3.4.0<3.5.0:devel/rubygem-default_value_for \
- rubygem-pg>=1.4.3<1.5:databases/rubygem-pg \
+ rubygem-pg>=1.4.5<1.5:databases/rubygem-pg \
rubygem-rugged>=1.2<2:devel/rubygem-rugged \
rubygem-grape-path-helpers>=1.7.1<1.8:devel/rubygem-grape-path-helpers \
rubygem-faraday1>=1.10.0<2:www/rubygem-faraday1 \
@@ -65,7 +65,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-rack-oauth2>=1.21.3<1.22.0:security/rubygem-rack-oauth2 \
rubygem-jwt25>=2.5.0<2.6:www/rubygem-jwt25 \
rubygem-gssapi>0:security/rubygem-gssapi \
- rubygem-recaptcha>=4.11<5.0:devel/rubygem-recaptcha \
+ rubygem-recaptcha>=5.12<6.0:devel/rubygem-recaptcha \
rubygem-akismet>=3.0<4.0:devel/rubygem-akismet \
rubygem-invisible_captcha>=2.0.0<2.1.0:graphics/rubygem-invisible_captcha \
rubygem-devise-two-factor-rails61>=4.0.2<4.1:security/rubygem-devise-two-factor-rails61 \
@@ -78,7 +78,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-ohai>=16.10<17:sysutils/rubygem-ohai \
rubygem-gpgme>=2.0.22<2.1.0:security/rubygem-gpgme \
rubygem-gitlab_omniauth-ldap>=2.2.0<2.3.0:net/rubygem-gitlab_omniauth-ldap \
- rubygem-net-ldap>0.16.3:net/rubygem-net-ldap \
+ rubygem-net-ldap>=0.17.1<0.18:net/rubygem-net-ldap \
rubygem-grape15>=1.5.2<1.6:devel/rubygem-grape15 \
rubygem-grape-entity>=0.10.0<0.11.0,1:devel/rubygem-grape-entity \
rubygem-rack-cors>=1.1.1<1.2.0:www/rubygem-rack-cors \
@@ -134,7 +134,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-icalendar>=0:devel/rubygem-icalendar \
rubygem-diffy>=3.4<4:textproc/rubygem-diffy \
rubygem-diff_match_patch>=0.1.0<0.2.0:textproc/rubygem-diff_match_patch \
- rubygem-rack22>=2.2.4<2.3,3:www/rubygem-rack22 \
+ rubygem-rack22>=2.2.6.2<2.3,3:www/rubygem-rack22 \
rubygem-rack-timeout>=0.6.3<0.7:www/rubygem-rack-timeout \
rubygem-puma>=5.6.5<5.7:www/rubygem-puma \
rubygem-puma_worker_killer>=0.3.1:www/rubygem-puma_worker_killer \
@@ -173,7 +173,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-fast_blank>=0:devel/rubygem-fast_blank \
rubygem-gitlab-chronic>=0.10.5<0.11.0:devel/rubygem-gitlab-chronic \
rubygem-gitlab_chronic_duration>=0.10.6.2<0.10.7:devel/rubygem-gitlab_chronic_duration \
- rubygem-rack-proxy>=0.7.4<0.8.0:www/rubygem-rack-proxy \
+ rubygem-rack-proxy>=0.7.6<0.8.0:www/rubygem-rack-proxy \
rubygem-sassc-rails-rails61>=2.1.0<2.2.0:textproc/rubygem-sassc-rails-rails61 \
rubygem-autoprefixer-rails1025>=10.2.5.1<10.2.6:textproc/rubygem-autoprefixer-rails1025 \
rubygem-terser>=1.0.2:textproc/rubygem-terser \
@@ -238,7 +238,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-retriable>=3.1.2<3.2.0:devel/rubygem-retriable \
rubygem-lru_redux>0:devel/rubygem-lru_redux \
rubygem-mail27>=2.7.1<2.7.2,2:mail/rubygem-mail27 \
- rubygem-lockbox>=0.6.2<0.7:security/rubygem-lockbox \
+ rubygem-lockbox>=1.1.1<1.2:security/rubygem-lockbox \
rubygem-valid_email>=0.1<1:mail/rubygem-valid_email \
rubygem-json>=2.5.1<3:devel/rubygem-json \
rubygem-json_schemer>=0.2.18<0.3:devel/rubygem-json_schemer \
@@ -254,6 +254,7 @@ MY_DEPENDS= git>=2.39.1:devel/git \
rubygem-cvss-suite>=3.0.1<3.1:security/rubygem-cvss-suite \
rubygem-arr-pm>=0.0.12<0.1:devel/rubygem-arr-pm \
rubygem-CFPropertyList>=0:devel/rubygem-CFPropertyList \
+ rubygem-app_store_connect>=0:net/rubygem-app_store_connect \
rubygem-telesignenterprise>=2.2<3:devel/rubygem-telesignenterprise \
rubygem-kubeclient>=4.9.3<4.10.0:www/rubygem-kubeclient
@@ -275,7 +276,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= 358d690d91c78748a130cb46358c12eaa22275aa
+GL_COMMIT= c052f86b6b4d2428b62a2baac77aee4cc91fc2b1
USERS= git
GROUPS= git
@@ -299,6 +300,8 @@ post-patch:
# Remove symlink a create a file with content
${RM} ${WRKSRC}/GITLAB_WORKHORSE_VERSION
${ECHO} ${PORTVERSION} > ${WRKSRC}/GITLAB_WORKHORSE_VERSION
+ # Issue: https://gitlab.com/gitlab-org/gitlab/-/issues/389843
+ ${MV} ${WRKSRC}/spec/features/projects/pipelines/legacy_pipelines_spec.rb\ ${WRKSRC}/spec/features/projects/pipelines/legacy_pipelines_spec.rb
do-install:
${CP} ${WRKSRC}/config/database.yml.postgresql ${WRKSRC}/config/database.yml.sample
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 1f9021304f3a..4f6e5c6f580f 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674281592
-SHA256 (gitlab-org-gitlab-foss-358d690d91c78748a130cb46358c12eaa22275aa_GL0.tar.gz) = 748ad48fdce4849f9ea8291437968cd4af9f9b5c09ea2dcd93f31fc3b575f12b
-SIZE (gitlab-org-gitlab-foss-358d690d91c78748a130cb46358c12eaa22275aa_GL0.tar.gz) = 99979703
+TIMESTAMP = 1675117666
+SHA256 (gitlab-org-gitlab-foss-c052f86b6b4d2428b62a2baac77aee4cc91fc2b1_GL0.tar.gz) = d06969d74cbce8bc2f4a073cae41f133ce0ef6e1d1a9304df6b9d614112bb7bb
+SIZE (gitlab-org-gitlab-foss-c052f86b6b4d2428b62a2baac77aee4cc91fc2b1_GL0.tar.gz) = 99749997
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index 7fc7a295d360..29e7c33283b7 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -1,4 +1,4 @@
---- Gemfile.orig 2023-01-12 20:03:13 UTC
+--- Gemfile.orig 2023-01-20 09:57:01 UTC
+++ Gemfile
@@ -13,13 +13,13 @@ gem 'bundler-checksum', '~> 0.1.0', path: 'vendor/gems
# NOTE: When incrementing the major or minor version here, also increment activerecord_version
@@ -48,15 +48,6 @@
# Kerberos authentication. EE-only
gem 'gssapi', group: :kerberos
-@@ -113,7 +113,7 @@ gem 'gpgme', '~> 2.0.22'
- # GitLab fork with several improvements to original library. For full list of changes
- # see https://github.com/intridea/omniauth-ldap/compare/master...gitlabhq:master
- gem 'gitlab_omniauth-ldap', '~> 2.2.0', require: 'omniauth-ldap'
--gem 'net-ldap', '~> 0.16.3'
-+gem 'net-ldap', '~> 0.17.1'
-
- # API
- gem 'grape', '~> 1.5.2'
@@ -223,7 +223,7 @@ gem 'redis-namespace', '~> 1.9.0'
gem 'gitlab-sidekiq-fetcher', '0.9.0', require: 'sidekiq-reliable-fetch'
@@ -77,12 +68,12 @@
gem 'warning', '~> 1.3.0'
-group :development do
-- gem 'lefthook', '~> 1.2.6', require: false
+- gem 'lefthook', '~> 1.2.7', require: false
- gem 'rubocop'
- gem 'solargraph', '~> 0.47.2', require: false
-
- gem 'letter_opener_web', '~> 2.0.0'
-- gem 'lookbook', '~> 1.2', '>= 1.2.1'
+- gem 'lookbook', '~> 1.4', '>= 1.4.5'
-
- # Better errors handler
- gem 'better_errors', '~> 2.9.1'
@@ -114,7 +105,7 @@
- gem 'spring', '~> 4.1.0'
- gem 'spring-commands-rspec', '~> 1.0.4'
-
-- gem 'gitlab-styles', '~> 9.1.0', require: false
+- gem 'gitlab-styles', '~> 9.2.0', require: false
-
- gem 'haml_lint', '~> 0.40.0', require: false
- gem 'bundler-audit', '~> 0.7.0.1', require: false
@@ -202,7 +193,7 @@
gem 'retriable', '~> 3.1.2'
-@@ -544,7 +448,7 @@ gem 'lockbox', '~> 0.6.2'
+@@ -544,7 +448,7 @@ gem 'lockbox', '~> 1.1.1'
gem 'valid_email', '~> 0.1'
# JSON
diff --git a/www/gitlab-ce/files/patch-config_gitlab.yml.example b/www/gitlab-ce/files/patch-config_gitlab.yml.example
index 8cf45402cf93..10531ba84daa 100644
--- a/www/gitlab-ce/files/patch-config_gitlab.yml.example
+++ b/www/gitlab-ce/files/patch-config_gitlab.yml.example
@@ -1,6 +1,6 @@
---- config/gitlab.yml.example.orig 2023-01-12 20:03:13 UTC
+--- config/gitlab.yml.example.orig 2023-01-20 09:57:01 UTC
+++ config/gitlab.yml.example
-@@ -1187,14 +1187,14 @@ production: &base
+@@ -1192,14 +1192,14 @@ production: &base
# real path not the symlink.
storages: # You must have at least a `default` storage path.
default:
@@ -18,7 +18,7 @@
# archive_permissions: 0640 # Permissions for the resulting backup.tar file (default: 0600)
# keep_time: 604800 # default: 0 (forever) (in seconds)
# pg_schema: public # default: nil, it means that all schemas will be backed up
-@@ -1229,12 +1229,12 @@ production: &base
+@@ -1234,12 +1234,12 @@ production: &base
## GitLab Shell settings
gitlab_shell:
@@ -34,7 +34,7 @@
# Git over HTTP
upload_pack: true
-@@ -1249,13 +1249,13 @@ production: &base
+@@ -1254,13 +1254,13 @@ production: &base
workhorse:
# File that contains the secret key for verifying access for gitlab-workhorse.
# Default is '.gitlab_workhorse_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -50,7 +50,7 @@
# The URL to the external KAS API (used by the Kubernetes agents)
# external_url: wss://kas.example.com
-@@ -1268,13 +1268,13 @@ production: &base
+@@ -1278,13 +1278,13 @@ production: &base
## GitLab Elasticsearch settings
elasticsearch:
@@ -66,7 +66,7 @@
## Webpack settings
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
-@@ -1295,18 +1295,18 @@ production: &base
+@@ -1305,18 +1305,18 @@ production: &base
# Sidekiq exporter is a dedicated Prometheus metrics server optionally running alongside Sidekiq.
sidekiq_exporter:
@@ -92,7 +92,7 @@
# Web exporter is a dedicated Prometheus metrics server optionally running alongside Puma.
web_exporter:
-@@ -1531,13 +1531,13 @@ test:
+@@ -1541,13 +1541,13 @@ test:
gitaly_address: unix:tmp/tests/gitaly/praefect.socket
gitaly:
diff --git a/www/gitlab-ce/pkg-message b/www/gitlab-ce/pkg-message
index c47845377130..7d789fc096ef 100644
--- a/www/gitlab-ce/pkg-message
+++ b/www/gitlab-ce/pkg-message
@@ -6,7 +6,7 @@ Gitlab was installed successfully.
You now need to set up the various components of Gitlab, so please
follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/15.7-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/15.8-freebsd.md
EOM
type: install
}
@@ -20,7 +20,7 @@ EOM
If you just installed an major upgrade of GitLab, for example you
switched from 14.5.x to 14.6.x, please follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/15.6-15.7-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/15.7-15.8-freebsd.md
If you just installed an minor upgrade of GitLab please follow
the instructions in the guide at: