aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-23 13:21:30 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-23 13:21:30 +0000
commitb345c8414c43014002a5062ee018d2379b61d89e (patch)
treedfe8a935dd07ca1eb10a2f6638298eafe0147ea0 /www
parentbe05f9c26269e82a60a6bee205b5600f7031e5f3 (diff)
downloadports-b345c8414c43014002a5062ee018d2379b61d89e.tar.gz
ports-b345c8414c43014002a5062ee018d2379b61d89e.zip
- Update to 6.0.4 and unbreak build with gcc 3.4
- Added USE_GCC=3.4 for FreeBSD 4.x users PR: ports/74274 Submitted by: Sergio Mangialardi <sergio(at)softshark.org>
Notes
Notes: svn path=/head/; revision=122220
Diffstat (limited to 'www')
-rw-r--r--www/swish++/Makefile11
-rw-r--r--www/swish++/distinfo4
-rw-r--r--www/swish++/files/patch-GNUmakefile8
-rw-r--r--www/swish++/files/patch-config::config.mk32
-rw-r--r--www/swish++/files/patch-searchd.in11
-rw-r--r--www/swish++/files/patch-searchmonitor.in11
-rw-r--r--www/swish++/pkg-plist4
7 files changed, 29 insertions, 52 deletions
diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index 1478cbf45134..6fe9361163ef 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= swish++
-PORTVERSION= 5.15.3
-PORTREVISION= 1
+PORTVERSION= 6.0.4
CATEGORIES= www textproc
MASTER_SITES= http://homepage.mac.com/pauljlucas/software/
@@ -31,13 +30,13 @@ MAN8= searchd.8 searchmonitor.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
.endif
post-patch:
@${REINPLACE_CMD} -e '/^#error/d' ${WRKSRC}/config.h
-.for file in searchd searchmonitor
+.for file in scripts/searchd scripts/searchmonitor
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}.in
.endfor
@@ -45,6 +44,6 @@ pre-install:
@${MKDIR} ${SITE_PERL}
post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/swish++.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${FILESDIR}/swish++.sh ${PREFIX}/etc/rc.d/swish++.sh.sample
.include <bsd.port.post.mk>
diff --git a/www/swish++/distinfo b/www/swish++/distinfo
index fe29af0d95c7..31781db65ddf 100644
--- a/www/swish++/distinfo
+++ b/www/swish++/distinfo
@@ -1,2 +1,2 @@
-MD5 (swish++-5.15.3.tar.gz) = 5d480381946c4ee6764c449083360282
-SIZE (swish++-5.15.3.tar.gz) = 279128
+MD5 (swish++-6.0.4.tar.gz) = 3a81a1ca59addd6198f89e680bc77bff
+SIZE (swish++-6.0.4.tar.gz) = 292826
diff --git a/www/swish++/files/patch-GNUmakefile b/www/swish++/files/patch-GNUmakefile
index 442c710b4e75..ab0ce4186d6b 100644
--- a/www/swish++/files/patch-GNUmakefile
+++ b/www/swish++/files/patch-GNUmakefile
@@ -1,7 +1,7 @@
---- GNUmakefile.orig Tue Mar 11 03:33:13 2003
-+++ GNUmakefile Tue Apr 15 13:42:35 2003
-@@ -229,7 +229,7 @@
- cd $(I_BIN) && $(STRIP) $(CPP_TARGET)
+--- GNUmakefile.orig Mon Nov 22 23:41:54 2004
++++ GNUmakefile Mon Nov 22 23:43:19 2004
+@@ -236,7 +236,7 @@
+ @$(MAKE) -C scripts $@
install_lib: $(I_LIB)
- $(INSTALL) $(I_OWNER) $(I_GROUP) $(I_MODE) $(LIB_TARGET) $(I_LIB)
diff --git a/www/swish++/files/patch-config::config.mk b/www/swish++/files/patch-config::config.mk
index cfc0513a4398..4698ceb06924 100644
--- a/www/swish++/files/patch-config::config.mk
+++ b/www/swish++/files/patch-config::config.mk
@@ -1,17 +1,17 @@
---- config/config.mk.orig Tue Dec 24 15:59:08 2002
-+++ config/config.mk Tue Apr 15 13:40:16 2003
-@@ -33,8 +33,8 @@
+--- config/config.mk.orig Mon Nov 22 23:44:48 2004
++++ config/config.mk Mon Nov 22 23:48:27 2004
+@@ -34,8 +34,8 @@
#
###############################################################################
--#FREE_BSD:= -DFreeBSD
--LINUX:= -DLinux -D_BSD_SOURCE
-+FREE_BSD:= -DFreeBSD
-+#LINUX:= -DLinux -D_BSD_SOURCE
- #MAC_OS_X:= -DMacOSX
- #SOLARIS:= -DSolaris
- #WIN32:= -DWIN32
-@@ -112,7 +112,7 @@
+-#FREE_BSD:=1
+-LINUX:=1
++FREE_BSD:=1
++#LINUX:=1
+ #MAC_OS_X:=1
+ #SOLARIS:=1
+ #WIN32:=1
+@@ -118,7 +118,7 @@
ifdef SEARCH_DAEMON
ifdef FREE_BSD
@@ -20,7 +20,7 @@
else
PTHREAD_LINK:= -lpthread
endif
-@@ -149,7 +149,7 @@
+@@ -159,7 +159,7 @@
# The command to remove files recursively and ignore errors;
# usually "rm -fr" for Unix or "erase" for Windows.
@@ -28,13 +28,13 @@
+#PERL:= /usr/local/bin/perl
# The full path to the Perl 5 executable; usually "/bin/perl" or
# "/usr/local/bin/perl" for Unix or "\Perl\bin\perl" for
- # Windows. You need this only if you intend on using
-@@ -176,14 +176,14 @@
+ # Windows.
+@@ -185,14 +185,14 @@
#
###############################################################################
-CC:= g++
-+CC:= ${CXX}
++CC:= ${CXX}
# The C++ compiler you are using; usually "CC" or "g++".
#DEBUG:= true
@@ -46,7 +46,7 @@
# The optimization level. Many compilers allow a digit after the
# O to specify the level of optimization; if so, set yours to the
# highest number your compiler allows without eliciting problems
-@@ -227,7 +227,7 @@
+@@ -254,7 +254,7 @@
INSTALL:= $(ROOT)/install-sh
# Install command; usually "$(ROOT)/install-sh".
diff --git a/www/swish++/files/patch-searchd.in b/www/swish++/files/patch-searchd.in
deleted file mode 100644
index 2ac66f21f004..000000000000
--- a/www/swish++/files/patch-searchd.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- searchd.in.orig Sun Jan 13 12:00:35 2002
-+++ searchd.in Sun Jan 13 12:00:53 2002
-@@ -27,7 +27,7 @@
- SEARCH="search"
- SEARCH_PATH="%%I_BIN%%/$SEARCH"
- SEARCHMONITOR="%%I_BIN%%/searchmonitor"
--CONF_FILE="/etc/swish++.conf"
-+CONF_FILE="%%PREFIX%%/etc/swish++.conf"
- PID_FILE_DEFAULT="/var/run/search.pid"
-
- ##
diff --git a/www/swish++/files/patch-searchmonitor.in b/www/swish++/files/patch-searchmonitor.in
deleted file mode 100644
index 5e3b5e79972d..000000000000
--- a/www/swish++/files/patch-searchmonitor.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- searchmonitor.in.orig Sun Jan 13 12:01:32 2002
-+++ searchmonitor.in Sun Jan 13 12:01:47 2002
-@@ -63,7 +63,7 @@
- CONF_FILE="swish++.conf"
- if [ ! -f "$CONF_FILE" ]
- then
-- CONF_FILE="/etc/$CONF_FILE"
-+ CONF_FILE="%%PREFIX%%/etc/$CONF_FILE"
- [ -f "$CONF_FILE" ] ||
- { echo "$ME: no configuration file found" >&2; exit 3; }
- fi
diff --git a/www/swish++/pkg-plist b/www/swish++/pkg-plist
index e5bfa7b94b8a..ede451c96f45 100644
--- a/www/swish++/pkg-plist
+++ b/www/swish++/pkg-plist
@@ -3,8 +3,8 @@ bin/httpindex
bin/index
bin/search
bin/searchc
+bin/searchd
bin/searchmonitor
bin/splitmail
+etc/rc.d/swish++.sh.sample
etc/swish++.conf
-etc/rc.d/swish++.sh
-%%SITE_PERL%%/WWW.pm