aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-05 19:02:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-05 19:14:01 +0000
commitb5e1c5e21682bf5e152d42e2ecaea35b7c6f156b (patch)
tree581af9d8db013fd0327810d0c09a4b456125806e /www
parent7746765bb0e27636d807cc590b4e1a82b5e0788b (diff)
downloadports-b5e1c5e21682bf5e152d42e2ecaea35b7c6f156b.tar.gz
ports-b5e1c5e21682bf5e152d42e2ecaea35b7c6f156b.zip
www/npm: Add NODE16 option
- Update CONFLICTS_INSTALL
Diffstat (limited to 'www')
-rw-r--r--www/npm/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 5db1f36b82e2..24c6ada8b40a 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -19,13 +19,14 @@ NO_ARCH= yes
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-CONFLICTS_INSTALL?= npm-node14
+CONFLICTS_INSTALL?= npm-node14 npm-node16
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE14
+OPTIONS_SINGLE_BACKEND= NODE NODE14 NODE16
OPTIONS_DEFAULT=NODE
NODE_DESC= Use www/node as backend
NODE14_DESC= Use www/node14 as backend
+NODE16_DESC= Use www/node16 as backend
CPE_VENDOR= npmjs
@@ -34,6 +35,7 @@ SHEBANG_FILES= lib/node_modules/npm/node_modules/node-gyp/gyp/samples/samples
NODE_RUN_DEPENDS= node>=0.8.0:www/node
NODE14_RUN_DEPENDS= node14>=0.8.0:www/node14
+NODE16_RUN_DEPENDS= node16>=0.8.0:www/node16
.include <bsd.port.pre.mk>