aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2020-02-17 08:30:00 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2020-02-17 08:30:00 +0000
commitbe1afc68935df0cb08159ee0623a6ed1e9ab0a7a (patch)
tree86c18f786a0e467b388e9c26c248a9a64b711908 /www
parent4020008ac574a3ef4bc147bf02138e7929ae5805 (diff)
downloadports-be1afc68935df0cb08159ee0623a6ed1e9ab0a7a.tar.gz
ports-be1afc68935df0cb08159ee0623a6ed1e9ab0a7a.zip
www/tomcat85,9: Improve port quality
- Don't echo automatic actions unlike other manual actions - Don't perform ${RM} -R because the OPTIONS system takes @comment parts in pkg-plist into account, poudriere build does not complain. - Don't provide samples for XML schema files, these are NOT intended to be modified by the user PR: 243648 Submitted by: Michael Osipov <michael.osipov siemens com> Approved by: VVD <vvd unislabs com> MFH: 2020Q1 (blanket: ports compliance, bugfixes)
Notes
Notes: svn path=/head/; revision=526349
Diffstat (limited to 'www')
-rw-r--r--www/tomcat85/Makefile26
-rw-r--r--www/tomcat85/pkg-plist4
-rw-r--r--www/tomcat9/Makefile27
-rw-r--r--www/tomcat9/pkg-plist4
4 files changed, 16 insertions, 45 deletions
diff --git a/www/tomcat85/Makefile b/www/tomcat85/Makefile
index ac9d7b6c6780..a327ddb8fe99 100644
--- a/www/tomcat85/Makefile
+++ b/www/tomcat85/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tomcat
PORTVERSION= 8.5.50
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/([0-9])(.*)/\1/}/v${PORTVERSION}/bin
PKGNAMESUFFIX= 85
@@ -50,36 +51,21 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${TOMCAT_HOME}/logs
@${MKDIR} ${STAGEDIR}${TOMCAT_HOME}/endorsed
- ${CP} -R ${WRKSRC}/* ${STAGEDIR}${TOMCAT_HOME}
+ @${CP} -R ${WRKSRC}/* ${STAGEDIR}${TOMCAT_HOME}
post-install:
@${RM} ${STAGEDIR}${TOMCAT_HOME}/bin/*.bat
- (cd ${STAGEDIR}${TOMCAT_HOME}/conf &&\
- for f in $$(find . -type f); do ${MV} $$f $$f.sample; done)
+ @(cd ${STAGEDIR}${TOMCAT_HOME}/conf &&\
+ for f in $$(find . -type f -not -name '*.xsd'); do ${MV} $$f $$f.sample; done)
post-install-HOST_MANAGER-on:
- (cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
+ @(cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
for f in host-manager/META-INF/context.xml host-manager/WEB-INF/web.xml; do \
${MV} $$f $$f.sample; done)
-post-install-HOST_MANAGER-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/host-manager
-
post-install-MANAGER-on:
- (cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
+ @(cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
for f in manager/META-INF/context.xml manager/WEB-INF/web.xml; do \
${MV} $$f $$f.sample; done)
-post-install-MANAGER-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/manager
-
-post-install-DOCS-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/docs
-
-post-install-EXAMPLES-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/examples
-
-post-install-ROOT-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/ROOT
-
.include <bsd.port.mk>
diff --git a/www/tomcat85/pkg-plist b/www/tomcat85/pkg-plist
index 55d96c6ca344..eb3ba3372f2c 100644
--- a/www/tomcat85/pkg-plist
+++ b/www/tomcat85/pkg-plist
@@ -60,11 +60,11 @@
@sample %%T%%/conf/catalina.properties.sample
@sample %%T%%/conf/context.xml.sample
@sample %%T%%/conf/jaspic-providers.xml.sample
-@sample %%T%%/conf/jaspic-providers.xsd.sample
+%%T%%/conf/jaspic-providers.xsd
@sample %%T%%/conf/logging.properties.sample
@sample %%T%%/conf/server.xml.sample
@sample %%T%%/conf/tomcat-users.xml.sample
-@sample %%T%%/conf/tomcat-users.xsd.sample
+%%T%%/conf/tomcat-users.xsd
@sample %%T%%/conf/web.xml.sample
%%T%%/temp/safeToDelete.tmp
%%DOCS%%%%T%%/webapps/docs/BUILDING.txt
diff --git a/www/tomcat9/Makefile b/www/tomcat9/Makefile
index a947c51a07ea..5dae28335de6 100644
--- a/www/tomcat9/Makefile
+++ b/www/tomcat9/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tomcat
PORTVERSION= 9.0.30
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/([0-9])(.*)/\1/}/v${PORTVERSION}/bin
PKGNAMESUFFIX= 9
@@ -52,36 +52,21 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${TOMCAT_HOME}/logs
@${MKDIR} ${STAGEDIR}${TOMCAT_HOME}/endorsed
- ${CP} -R ${WRKSRC}/* ${STAGEDIR}${TOMCAT_HOME}
+ @${CP} -R ${WRKSRC}/* ${STAGEDIR}${TOMCAT_HOME}
post-install:
@${RM} ${STAGEDIR}${TOMCAT_HOME}/bin/*.bat
- (cd ${STAGEDIR}${TOMCAT_HOME}/conf &&\
- for f in $$(find . -type f); do ${MV} $$f $$f.sample; done)
+ @(cd ${STAGEDIR}${TOMCAT_HOME}/conf &&\
+ for f in $$(find . -type f -not -name '*.xsd'); do ${MV} $$f $$f.sample; done)
post-install-HOST_MANAGER-on:
- (cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
+ @(cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
for f in host-manager/META-INF/context.xml host-manager/WEB-INF/web.xml; do \
${MV} $$f $$f.sample; done)
-post-install-HOST_MANAGER-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/host-manager
-
post-install-MANAGER-on:
- (cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
+ @(cd ${STAGEDIR}${TOMCAT_HOME}/webapps &&\
for f in manager/META-INF/context.xml manager/WEB-INF/web.xml; do \
${MV} $$f $$f.sample; done)
-post-install-MANAGER-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/manager
-
-post-install-DOCS-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/docs
-
-post-install-EXAMPLES-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/examples
-
-post-install-ROOT-off:
- @${RM} -R ${STAGEDIR}${TOMCAT_HOME}/webapps/ROOT
-
.include <bsd.port.mk>
diff --git a/www/tomcat9/pkg-plist b/www/tomcat9/pkg-plist
index d54b4b824032..b9f3f5299355 100644
--- a/www/tomcat9/pkg-plist
+++ b/www/tomcat9/pkg-plist
@@ -64,11 +64,11 @@
@sample %%T%%/conf/catalina.properties.sample
@sample %%T%%/conf/context.xml.sample
@sample %%T%%/conf/jaspic-providers.xml.sample
-@sample %%T%%/conf/jaspic-providers.xsd.sample
+%%T%%/conf/jaspic-providers.xsd
@sample %%T%%/conf/logging.properties.sample
@sample %%T%%/conf/server.xml.sample
@sample %%T%%/conf/tomcat-users.xml.sample
-@sample %%T%%/conf/tomcat-users.xsd.sample
+%%T%%/conf/tomcat-users.xsd
@sample %%T%%/conf/web.xml.sample
%%T%%/temp/safeToDelete.tmp
%%DOCS%%%%T%%/webapps/docs/BUILDING.txt