aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-12 11:48:55 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-12 11:48:55 +0000
commitbe4ae2c39aa4a2ab7ecca6f0fe87b2375604212e (patch)
treee9d723ec12d3c9bcf62c9ebe12515d6860ea416c /www
parent0538b8c20cf990175efd8f2a2cd9ae535a96c9c5 (diff)
downloadports-be4ae2c39aa4a2ab7ecca6f0fe87b2375604212e.tar.gz
ports-be4ae2c39aa4a2ab7ecca6f0fe87b2375604212e.zip
- Remove installation of unused highperformance*.conf
- Move examples config files to ${EXAMPLESDIR} - Relax permissions on ${PREFIX}/www instead of ${PREFIX}/www/data
Notes
Notes: svn path=/head/; revision=123807
Diffstat (limited to 'www')
-rw-r--r--www/apache2/Makefile7
-rw-r--r--www/apache2/Makefile.doc2
-rw-r--r--www/apache2/files/patch-Makefile.in40
-rw-r--r--www/apache2/files/patch-docs:conf:httpd-std.conf.in15
-rw-r--r--www/apache2/pkg-plist37
-rw-r--r--www/apache20/Makefile7
-rw-r--r--www/apache20/Makefile.doc2
-rw-r--r--www/apache20/files/patch-Makefile.in40
-rw-r--r--www/apache20/files/patch-docs:conf:httpd-std.conf.in15
-rw-r--r--www/apache20/pkg-plist37
10 files changed, 140 insertions, 62 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 9e4b8b1b76f5..06ca4fed3835 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -196,6 +196,7 @@ post-patch:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
+ @${RM} -f ${WRKSRC}/docs/conf/highperformance-std.conf
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
@${REINPLACE_CMD} -e 's,freebsd\[2345\],freebsd\[23456\],' \
@@ -209,7 +210,8 @@ post-configure:
@FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
${REINPLACE_CMD} -e "s,%%FTPUSERS%%,$$FTPUSERS, ; \
s,%%WWWOWN%%,${WWWOWN}, ; \
- s,%%WWWGRP%%,${WWWGRP}, " \
+ s,%%WWWGRP%%,${WWWGRP}, ; \
+ s,%%WWWBASEDIR%%,${PREFIX}/www," \
${WRKSRC}/docs/conf/httpd-std.conf
pre-install:
@@ -223,6 +225,7 @@ post-install:
.endif
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup script."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
- @@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} ""
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/apache2/Makefile.doc b/www/apache2/Makefile.doc
index cf8abcb1ccf1..3e029f0d548f 100644
--- a/www/apache2/Makefile.doc
+++ b/www/apache2/Makefile.doc
@@ -90,6 +90,8 @@
##
DOCSDIR= ${PREFIX}/share/doc/apache2
+EXAMPLESDIR= ${PREFIX}/share/examples/apache2
+MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS=yes
diff --git a/www/apache2/files/patch-Makefile.in b/www/apache2/files/patch-Makefile.in
index 59c5532562bd..5af8aa5efa29 100644
--- a/www/apache2/files/patch-Makefile.in
+++ b/www/apache2/files/patch-Makefile.in
@@ -1,11 +1,19 @@
---- Makefile.in.orig Tue Jul 29 15:40:09 2003
-+++ Makefile.in Tue Sep 30 00:31:14 2003
-@@ -37,10 +37,13 @@
+--- Makefile.in.orig Thu Aug 26 15:01:18 2004
++++ Makefile.in Sun Dec 12 12:07:11 2004
+@@ -31,15 +31,21 @@
+ if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
+ $(MKINSTALLDIRS) $(DESTDIR)$(sysconfdir) ; \
+ fi ; \
++ if [ ! -d $(DESTDIR)$(EXAMPLESDIR) ]; then \
++ $(MKINSTALLDIRS) $(DESTDIR)$(EXAMPLESDIR) ; \
++ fi ; \
+ cd $(top_srcdir)/docs/conf; \
+ for i in mime.types magic; do \
if test ! -f $(DESTDIR)$(sysconfdir)/$$i; then \
$(INSTALL_DATA) $$i $(DESTDIR)$(sysconfdir); \
fi; \
+ cp -f $$i $$i-dist; \
-+ $(INSTALL_DATA) $$i-dist $(DESTDIR)$(sysconfdir); \
++ $(INSTALL_DATA) $$i-dist $(DESTDIR)$(EXAMPLESDIR); \
done; \
for j in $(top_srcdir)/docs/conf $(top_builddir)/docs/conf ; do \
cd $$j ; \
@@ -14,7 +22,7 @@
( \
n_lm=`awk 'BEGIN {n=0} /@@LoadModule@@/ {n+=1} END {print n}' < $$i`; \
if test $$n_lm -eq 0 -o "x$(DSO_MODULES)" = "x"; then \
-@@ -58,6 +61,9 @@
+@@ -57,6 +63,9 @@
if test "x$$j" = "xssl"; then \
echo "<IfDefine SSL>"; \
fi; \
@@ -24,7 +32,25 @@
if test $$j != "^EOL^"; then \
echo "LoadModule $${j}_module $(rel_libexecdir)/mod_$${j}.so"; \
fi; \
-@@ -109,45 +115,41 @@
+@@ -70,14 +79,14 @@
+ -e 's#@@Port@@#$(PORT)#g' \
+ < $$i; \
+ fi \
+- ) > $(DESTDIR)$(sysconfdir)/$$i; \
+- chmod 0644 $(DESTDIR)$(sysconfdir)/$$i; \
++ ) > $(DESTDIR)$(EXAMPLESDIR)/$$i; \
++ chmod 0644 $(DESTDIR)$(EXAMPLESDIR)/$$i; \
+ file=`echo $$i|sed s/-std//`; \
+ if [ "$$file" = "httpd.conf" ]; then \
+ file=`echo $$file|sed s/.*.conf/$(PROGRAM_NAME).conf/`; \
+ fi; \
+ if test "$$file" != "$$i" && test ! -f $(DESTDIR)$(sysconfdir)/$$file; then \
+- $(INSTALL_DATA) $(DESTDIR)$(sysconfdir)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
++ $(INSTALL_DATA) $(DESTDIR)$(EXAMPLESDIR)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
+ fi; \
+ done ; \
+ done ; \
+@@ -108,45 +117,41 @@
doxygen $(top_srcdir)/docs/doxygen.conf
install-htdocs:
@@ -99,7 +125,7 @@
install-other:
@test -d $(DESTDIR)$(logfiledir) || $(MKINSTALLDIRS) $(DESTDIR)$(logfiledir)
@test -d $(DESTDIR)$(runtimedir) || $(MKINSTALLDIRS) $(DESTDIR)$(runtimedir)
-@@ -190,11 +192,13 @@
+@@ -188,11 +193,13 @@
@test -d $(DESTDIR)$(mandir) || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)
@test -d $(DESTDIR)$(mandir)/man1 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man1
@test -d $(DESTDIR)$(mandir)/man8 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man8
diff --git a/www/apache2/files/patch-docs:conf:httpd-std.conf.in b/www/apache2/files/patch-docs:conf:httpd-std.conf.in
index 16abb83030ba..7a09e89ea821 100644
--- a/www/apache2/files/patch-docs:conf:httpd-std.conf.in
+++ b/www/apache2/files/patch-docs:conf:httpd-std.conf.in
@@ -1,5 +1,5 @@
---- docs/conf/httpd-std.conf.in.orig Sat Apr 24 20:13:43 2004
-+++ docs/conf/httpd-std.conf.in Tue Aug 17 12:11:17 2004
+--- docs/conf/httpd-std.conf.in.orig Mon Aug 16 01:43:56 2004
++++ docs/conf/httpd-std.conf.in Sun Dec 12 12:34:08 2004
@@ -68,7 +68,7 @@
#
<IfModule !mpm_netware.c>
@@ -34,6 +34,15 @@
</Directory>
#
+@@ -330,7 +331,7 @@
+ #
+ # This should be changed to whatever you set DocumentRoot to.
+ #
+-<Directory "@exp_htdocsdir@">
++<Directory "%%WWWBASEDIR%%">
+
+ #
+ # Possible values for the Options directive are "None", "All",
@@ -365,24 +366,29 @@
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
@@ -110,7 +119,7 @@
#
# ServerTokens
-@@ -1049,3 +1055,5 @@
+@@ -1043,3 +1049,5 @@
# ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
# CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
#</VirtualHost>
diff --git a/www/apache2/pkg-plist b/www/apache2/pkg-plist
index 129f80464599..b541c70585b6 100644
--- a/www/apache2/pkg-plist
+++ b/www/apache2/pkg-plist
@@ -1,19 +1,17 @@
@comment $FreeBSD$
-@unexec if cmp -s %D/etc/apache2/highperformance.conf %D/etc/apache2/highperformance-std.conf; then rm -f %D/etc/apache2/highperformance.conf; fi
-etc/apache2/highperformance-std.conf
-@exec [ -f %B/highperformance.conf ] || cp %B/%f %B/highperformance.conf
-@unexec if cmp -s %D/etc/apache2/httpd.conf %D/etc/apache2/httpd-std.conf; then rm -f %D/etc/apache2/httpd.conf; fi
-etc/apache2/httpd-std.conf
-@exec [ -f %B/httpd.conf ] || cp %B/%f %B/httpd.conf
-@unexec if cmp -s %D/etc/apache2/magic %D/etc/apache2/magic-dist; then rm -f %D/etc/apache2/magic; fi
-etc/apache2/magic-dist
-@exec [ -f %B/magic ] || cp %B/%f %B/magic
-@unexec if cmp -s %D/etc/apache2/mime.types %D/etc/apache2/mime.types-dist; then rm -f %D/etc/apache2/mime.types; fi
-etc/apache2/mime.types-dist
-@exec [ -f %B/mime.types ] || cp %B/%f %B/mime.types
-@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
-etc/apache2/ssl-std.conf
-@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
+@exec mkdir -p %D/etc/apache2 2> /dev/null
+@unexec if cmp -s %D/etc/apache2/httpd.conf %D/%%EXAMPLESDIR%%/httpd-std.conf; then rm -f %D/etc/apache2/httpd.conf; fi
+%%EXAMPLESDIR%%/httpd-std.conf
+@exec [ -f %D/etc/apache2/httpd.conf ] || cp %D/%%EXAMPLESDIR%%/httpd-std.conf %D/etc/apache2/httpd.conf
+@unexec if cmp -s %D/etc/apache2/magic %D/%%EXAMPLESDIR%%/magic-dist; then rm -f %D/etc/apache2/magic; fi
+%%EXAMPLESDIR%%/magic-dist
+@exec [ -f %D/etc/apache2/magic ] || cp %D/%%EXAMPLESDIR%%/magic-dist %D/etc/apache2/magic
+@unexec if cmp -s %D/etc/apache2/mime.types %D/%%EXAMPLESDIR%%/mime.types-dist; then rm -f %D/etc/apache2/mime.types; fi
+%%EXAMPLESDIR%%/mime.types-dist
+@exec [ -f %D/etc/apache2/mime.types ] || cp %D/%%EXAMPLESDIR%%/mime.types-dist %D/etc/apache2/mime.types
+@unexec if cmp -s %D/etc/apache2/ssl.conf %D/%%EXAMPLESDIR%%/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
+%%EXAMPLESDIR%%/ssl-std.conf
+@exec [ -f %D/etc/apache2/ssl.conf ] || cp %D/%%EXAMPLESDIR%%/ssl-std.conf %D/etc/apache2/ssl.conf
etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
@@ -223,11 +221,10 @@ share/apache2/build/program.mk
share/apache2/build/rules.mk
share/apache2/build/special.mk
%%CGI%%@unexec if [ -L %D/www/cgi-bin ]; then rm -f %D/www/cgi-bin; fi
-%%CGI%%@exec [ ! -d %D/www/cgi-bin ] && ln -fs %D/www/cgi-bin-dist %D/www/cgi-bin
%%CGI%%www/cgi-bin-dist/printenv
%%CGI%%www/cgi-bin-dist/test-cgi
+%%CGI%%@exec [ ! -d %D/www/cgi-bin ] && ln -fs %D/www/cgi-bin-dist %D/www/cgi-bin
%%WWWDATA%%@unexec if [ -L %D/www/data ]; then rm -f %D/www/data; fi
-%%WWWDATA%%@exec [ ! -d %D/www/data ] && ln -fs %D/www/data-dist %D/www/data
%%WWWDATA%%www/data-dist/apache_pb.gif
%%WWWDATA%%www/data-dist/apache_pb.png
%%WWWDATA%%www/data-dist/apache_pb2.gif
@@ -264,8 +261,8 @@ share/apache2/build/special.mk
%%WWWDATA%%www/data-dist/index.html.var
%%WWWDATA%%www/data-dist/index.html.zh-cn.gb2312
%%WWWDATA%%www/data-dist/index.html.zh-tw.big5
+%%WWWDATA%%@exec [ ! -d %D/www/data ] && ln -fs %D/www/data-dist %D/www/data
%%ERROR%%@unexec if [ -L %D/www/error ]; then rm -f %D/www/error; fi
-%%ERROR%%@exec [ ! -d %D/www/error ] && ln -fs %D/www/error-dist %D/www/error
%%ERROR%%www/error-dist/HTTP_BAD_GATEWAY.html.var
%%ERROR%%www/error-dist/HTTP_BAD_REQUEST.html.var
%%ERROR%%www/error-dist/HTTP_FORBIDDEN.html.var
@@ -289,8 +286,8 @@ share/apache2/build/special.mk
%%ERROR%%www/error-dist/include/bottom.html
%%ERROR%%www/error-dist/include/spacer.html
%%ERROR%%www/error-dist/include/top.html
+%%ERROR%%@exec [ ! -d %D/www/error ] && ln -fs %D/www/error-dist %D/www/error
%%ICONS%%@unexec if [ -L %D/www/icons ]; then rm -f %D/www/icons; fi
-%%ICONS%%@exec [ ! -d %D/www/icons ] && ln -fs %D/www/icons-dist %D/www/icons
%%ICONS%%www/icons-dist/README
%%ICONS%%www/icons-dist/a.gif
%%ICONS%%www/icons-dist/a.png
@@ -515,10 +512,12 @@ share/apache2/build/special.mk
%%ICONS%%www/icons-dist/world2.png
%%ICONS%%@dirrm www/icons-dist/small
%%ICONS%%@dirrm www/icons-dist
+%%ICONS%%@exec [ ! -d %D/www/icons ] && ln -fs %D/www/icons-dist %D/www/icons
%%ERROR%%@dirrm www/error-dist/include
%%ERROR%%@dirrm www/error-dist
%%WWWDATA%%@dirrm www/data-dist
%%CGI%%@dirrm www/cgi-bin-dist
+@dirrm %%EXAMPLESDIR%%
@dirrm share/apache2/build
@dirrm share/apache2
@unexec rmdir %D/libexec/apache2 2> /dev/null || true
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 9e4b8b1b76f5..06ca4fed3835 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -196,6 +196,7 @@ post-patch:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
+ @${RM} -f ${WRKSRC}/docs/conf/highperformance-std.conf
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
@${REINPLACE_CMD} -e 's,freebsd\[2345\],freebsd\[23456\],' \
@@ -209,7 +210,8 @@ post-configure:
@FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
${REINPLACE_CMD} -e "s,%%FTPUSERS%%,$$FTPUSERS, ; \
s,%%WWWOWN%%,${WWWOWN}, ; \
- s,%%WWWGRP%%,${WWWGRP}, " \
+ s,%%WWWGRP%%,${WWWGRP}, ; \
+ s,%%WWWBASEDIR%%,${PREFIX}/www," \
${WRKSRC}/docs/conf/httpd-std.conf
pre-install:
@@ -223,6 +225,7 @@ post-install:
.endif
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup script."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
- @@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} ""
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/apache20/Makefile.doc b/www/apache20/Makefile.doc
index cf8abcb1ccf1..3e029f0d548f 100644
--- a/www/apache20/Makefile.doc
+++ b/www/apache20/Makefile.doc
@@ -90,6 +90,8 @@
##
DOCSDIR= ${PREFIX}/share/doc/apache2
+EXAMPLESDIR= ${PREFIX}/share/examples/apache2
+MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS=yes
diff --git a/www/apache20/files/patch-Makefile.in b/www/apache20/files/patch-Makefile.in
index 59c5532562bd..5af8aa5efa29 100644
--- a/www/apache20/files/patch-Makefile.in
+++ b/www/apache20/files/patch-Makefile.in
@@ -1,11 +1,19 @@
---- Makefile.in.orig Tue Jul 29 15:40:09 2003
-+++ Makefile.in Tue Sep 30 00:31:14 2003
-@@ -37,10 +37,13 @@
+--- Makefile.in.orig Thu Aug 26 15:01:18 2004
++++ Makefile.in Sun Dec 12 12:07:11 2004
+@@ -31,15 +31,21 @@
+ if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
+ $(MKINSTALLDIRS) $(DESTDIR)$(sysconfdir) ; \
+ fi ; \
++ if [ ! -d $(DESTDIR)$(EXAMPLESDIR) ]; then \
++ $(MKINSTALLDIRS) $(DESTDIR)$(EXAMPLESDIR) ; \
++ fi ; \
+ cd $(top_srcdir)/docs/conf; \
+ for i in mime.types magic; do \
if test ! -f $(DESTDIR)$(sysconfdir)/$$i; then \
$(INSTALL_DATA) $$i $(DESTDIR)$(sysconfdir); \
fi; \
+ cp -f $$i $$i-dist; \
-+ $(INSTALL_DATA) $$i-dist $(DESTDIR)$(sysconfdir); \
++ $(INSTALL_DATA) $$i-dist $(DESTDIR)$(EXAMPLESDIR); \
done; \
for j in $(top_srcdir)/docs/conf $(top_builddir)/docs/conf ; do \
cd $$j ; \
@@ -14,7 +22,7 @@
( \
n_lm=`awk 'BEGIN {n=0} /@@LoadModule@@/ {n+=1} END {print n}' < $$i`; \
if test $$n_lm -eq 0 -o "x$(DSO_MODULES)" = "x"; then \
-@@ -58,6 +61,9 @@
+@@ -57,6 +63,9 @@
if test "x$$j" = "xssl"; then \
echo "<IfDefine SSL>"; \
fi; \
@@ -24,7 +32,25 @@
if test $$j != "^EOL^"; then \
echo "LoadModule $${j}_module $(rel_libexecdir)/mod_$${j}.so"; \
fi; \
-@@ -109,45 +115,41 @@
+@@ -70,14 +79,14 @@
+ -e 's#@@Port@@#$(PORT)#g' \
+ < $$i; \
+ fi \
+- ) > $(DESTDIR)$(sysconfdir)/$$i; \
+- chmod 0644 $(DESTDIR)$(sysconfdir)/$$i; \
++ ) > $(DESTDIR)$(EXAMPLESDIR)/$$i; \
++ chmod 0644 $(DESTDIR)$(EXAMPLESDIR)/$$i; \
+ file=`echo $$i|sed s/-std//`; \
+ if [ "$$file" = "httpd.conf" ]; then \
+ file=`echo $$file|sed s/.*.conf/$(PROGRAM_NAME).conf/`; \
+ fi; \
+ if test "$$file" != "$$i" && test ! -f $(DESTDIR)$(sysconfdir)/$$file; then \
+- $(INSTALL_DATA) $(DESTDIR)$(sysconfdir)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
++ $(INSTALL_DATA) $(DESTDIR)$(EXAMPLESDIR)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
+ fi; \
+ done ; \
+ done ; \
+@@ -108,45 +117,41 @@
doxygen $(top_srcdir)/docs/doxygen.conf
install-htdocs:
@@ -99,7 +125,7 @@
install-other:
@test -d $(DESTDIR)$(logfiledir) || $(MKINSTALLDIRS) $(DESTDIR)$(logfiledir)
@test -d $(DESTDIR)$(runtimedir) || $(MKINSTALLDIRS) $(DESTDIR)$(runtimedir)
-@@ -190,11 +192,13 @@
+@@ -188,11 +193,13 @@
@test -d $(DESTDIR)$(mandir) || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)
@test -d $(DESTDIR)$(mandir)/man1 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man1
@test -d $(DESTDIR)$(mandir)/man8 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man8
diff --git a/www/apache20/files/patch-docs:conf:httpd-std.conf.in b/www/apache20/files/patch-docs:conf:httpd-std.conf.in
index 16abb83030ba..7a09e89ea821 100644
--- a/www/apache20/files/patch-docs:conf:httpd-std.conf.in
+++ b/www/apache20/files/patch-docs:conf:httpd-std.conf.in
@@ -1,5 +1,5 @@
---- docs/conf/httpd-std.conf.in.orig Sat Apr 24 20:13:43 2004
-+++ docs/conf/httpd-std.conf.in Tue Aug 17 12:11:17 2004
+--- docs/conf/httpd-std.conf.in.orig Mon Aug 16 01:43:56 2004
++++ docs/conf/httpd-std.conf.in Sun Dec 12 12:34:08 2004
@@ -68,7 +68,7 @@
#
<IfModule !mpm_netware.c>
@@ -34,6 +34,15 @@
</Directory>
#
+@@ -330,7 +331,7 @@
+ #
+ # This should be changed to whatever you set DocumentRoot to.
+ #
+-<Directory "@exp_htdocsdir@">
++<Directory "%%WWWBASEDIR%%">
+
+ #
+ # Possible values for the Options directive are "None", "All",
@@ -365,24 +366,29 @@
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
@@ -110,7 +119,7 @@
#
# ServerTokens
-@@ -1049,3 +1055,5 @@
+@@ -1043,3 +1049,5 @@
# ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
# CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
#</VirtualHost>
diff --git a/www/apache20/pkg-plist b/www/apache20/pkg-plist
index 129f80464599..b541c70585b6 100644
--- a/www/apache20/pkg-plist
+++ b/www/apache20/pkg-plist
@@ -1,19 +1,17 @@
@comment $FreeBSD$
-@unexec if cmp -s %D/etc/apache2/highperformance.conf %D/etc/apache2/highperformance-std.conf; then rm -f %D/etc/apache2/highperformance.conf; fi
-etc/apache2/highperformance-std.conf
-@exec [ -f %B/highperformance.conf ] || cp %B/%f %B/highperformance.conf
-@unexec if cmp -s %D/etc/apache2/httpd.conf %D/etc/apache2/httpd-std.conf; then rm -f %D/etc/apache2/httpd.conf; fi
-etc/apache2/httpd-std.conf
-@exec [ -f %B/httpd.conf ] || cp %B/%f %B/httpd.conf
-@unexec if cmp -s %D/etc/apache2/magic %D/etc/apache2/magic-dist; then rm -f %D/etc/apache2/magic; fi
-etc/apache2/magic-dist
-@exec [ -f %B/magic ] || cp %B/%f %B/magic
-@unexec if cmp -s %D/etc/apache2/mime.types %D/etc/apache2/mime.types-dist; then rm -f %D/etc/apache2/mime.types; fi
-etc/apache2/mime.types-dist
-@exec [ -f %B/mime.types ] || cp %B/%f %B/mime.types
-@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
-etc/apache2/ssl-std.conf
-@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
+@exec mkdir -p %D/etc/apache2 2> /dev/null
+@unexec if cmp -s %D/etc/apache2/httpd.conf %D/%%EXAMPLESDIR%%/httpd-std.conf; then rm -f %D/etc/apache2/httpd.conf; fi
+%%EXAMPLESDIR%%/httpd-std.conf
+@exec [ -f %D/etc/apache2/httpd.conf ] || cp %D/%%EXAMPLESDIR%%/httpd-std.conf %D/etc/apache2/httpd.conf
+@unexec if cmp -s %D/etc/apache2/magic %D/%%EXAMPLESDIR%%/magic-dist; then rm -f %D/etc/apache2/magic; fi
+%%EXAMPLESDIR%%/magic-dist
+@exec [ -f %D/etc/apache2/magic ] || cp %D/%%EXAMPLESDIR%%/magic-dist %D/etc/apache2/magic
+@unexec if cmp -s %D/etc/apache2/mime.types %D/%%EXAMPLESDIR%%/mime.types-dist; then rm -f %D/etc/apache2/mime.types; fi
+%%EXAMPLESDIR%%/mime.types-dist
+@exec [ -f %D/etc/apache2/mime.types ] || cp %D/%%EXAMPLESDIR%%/mime.types-dist %D/etc/apache2/mime.types
+@unexec if cmp -s %D/etc/apache2/ssl.conf %D/%%EXAMPLESDIR%%/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
+%%EXAMPLESDIR%%/ssl-std.conf
+@exec [ -f %D/etc/apache2/ssl.conf ] || cp %D/%%EXAMPLESDIR%%/ssl-std.conf %D/etc/apache2/ssl.conf
etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
@@ -223,11 +221,10 @@ share/apache2/build/program.mk
share/apache2/build/rules.mk
share/apache2/build/special.mk
%%CGI%%@unexec if [ -L %D/www/cgi-bin ]; then rm -f %D/www/cgi-bin; fi
-%%CGI%%@exec [ ! -d %D/www/cgi-bin ] && ln -fs %D/www/cgi-bin-dist %D/www/cgi-bin
%%CGI%%www/cgi-bin-dist/printenv
%%CGI%%www/cgi-bin-dist/test-cgi
+%%CGI%%@exec [ ! -d %D/www/cgi-bin ] && ln -fs %D/www/cgi-bin-dist %D/www/cgi-bin
%%WWWDATA%%@unexec if [ -L %D/www/data ]; then rm -f %D/www/data; fi
-%%WWWDATA%%@exec [ ! -d %D/www/data ] && ln -fs %D/www/data-dist %D/www/data
%%WWWDATA%%www/data-dist/apache_pb.gif
%%WWWDATA%%www/data-dist/apache_pb.png
%%WWWDATA%%www/data-dist/apache_pb2.gif
@@ -264,8 +261,8 @@ share/apache2/build/special.mk
%%WWWDATA%%www/data-dist/index.html.var
%%WWWDATA%%www/data-dist/index.html.zh-cn.gb2312
%%WWWDATA%%www/data-dist/index.html.zh-tw.big5
+%%WWWDATA%%@exec [ ! -d %D/www/data ] && ln -fs %D/www/data-dist %D/www/data
%%ERROR%%@unexec if [ -L %D/www/error ]; then rm -f %D/www/error; fi
-%%ERROR%%@exec [ ! -d %D/www/error ] && ln -fs %D/www/error-dist %D/www/error
%%ERROR%%www/error-dist/HTTP_BAD_GATEWAY.html.var
%%ERROR%%www/error-dist/HTTP_BAD_REQUEST.html.var
%%ERROR%%www/error-dist/HTTP_FORBIDDEN.html.var
@@ -289,8 +286,8 @@ share/apache2/build/special.mk
%%ERROR%%www/error-dist/include/bottom.html
%%ERROR%%www/error-dist/include/spacer.html
%%ERROR%%www/error-dist/include/top.html
+%%ERROR%%@exec [ ! -d %D/www/error ] && ln -fs %D/www/error-dist %D/www/error
%%ICONS%%@unexec if [ -L %D/www/icons ]; then rm -f %D/www/icons; fi
-%%ICONS%%@exec [ ! -d %D/www/icons ] && ln -fs %D/www/icons-dist %D/www/icons
%%ICONS%%www/icons-dist/README
%%ICONS%%www/icons-dist/a.gif
%%ICONS%%www/icons-dist/a.png
@@ -515,10 +512,12 @@ share/apache2/build/special.mk
%%ICONS%%www/icons-dist/world2.png
%%ICONS%%@dirrm www/icons-dist/small
%%ICONS%%@dirrm www/icons-dist
+%%ICONS%%@exec [ ! -d %D/www/icons ] && ln -fs %D/www/icons-dist %D/www/icons
%%ERROR%%@dirrm www/error-dist/include
%%ERROR%%@dirrm www/error-dist
%%WWWDATA%%@dirrm www/data-dist
%%CGI%%@dirrm www/cgi-bin-dist
+@dirrm %%EXAMPLESDIR%%
@dirrm share/apache2/build
@dirrm share/apache2
@unexec rmdir %D/libexec/apache2 2> /dev/null || true