aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-10 01:29:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-10 01:29:13 +0000
commitd4ae43bf69ca4926585b3a8fd28e6795898394cd (patch)
tree336c820474f57c4b339a84d234a977deeecaa0d7 /www
parentca9b65b8114b85f56a5aae31d2678accaa14f52e (diff)
downloadports-d4ae43bf69ca4926585b3a8fd28e6795898394cd.tar.gz
ports-d4ae43bf69ca4926585b3a8fd28e6795898394cd.zip
New port: www/librtcdcpp: Simple WebRTC DataChannels library
Notes
Notes: svn path=/head/; revision=531279
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/librtcdcpp/Makefile30
-rw-r--r--www/librtcdcpp/distinfo3
-rw-r--r--www/librtcdcpp/files/patch-CMakeLists.txt8
-rw-r--r--www/librtcdcpp/files/patch-src_Logging.cpp13
-rw-r--r--www/librtcdcpp/pkg-descr7
-rw-r--r--www/librtcdcpp/pkg-plist11
7 files changed, 73 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9d25c7d5a568..83dfa16481f8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -298,6 +298,7 @@
SUBDIR += libnghttp2
SUBDIR += libnghttp3
SUBDIR += libresonic-standalone
+ SUBDIR += librtcdcpp
SUBDIR += libwpe
SUBDIR += libwww
SUBDIR += lightsquid
diff --git a/www/librtcdcpp/Makefile b/www/librtcdcpp/Makefile
new file mode 100644
index 000000000000..8857968eabe3
--- /dev/null
+++ b/www/librtcdcpp/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= librtcdcpp
+DISTVERSION= g20180627
+CATEGORIES= www devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simple WebRTC DataChannels library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= spdlog>0:devel/spdlog
+LIB_DEPENDS= libnice.so:net-im/libnice \
+ libusrsctp.so:net/libusrsctp
+
+USES= cmake compiler:c++14-lang gnome ssl
+USE_GITHUB= yes
+GH_ACCOUNT= chadnickbok
+GH_TAGNAME= 49ddb949ed5dd2c8e859097b6723347f52e01645
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+CFLAGS+= -DSPDLOG_FMT_EXTERNAL
+
+do-install:
+ cd ${WRKSRC}/include && ${COPYTREE_SHARE} rtcdcpp ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/librtcdcpp.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/www/librtcdcpp/distinfo b/www/librtcdcpp/distinfo
new file mode 100644
index 000000000000..170ef7167009
--- /dev/null
+++ b/www/librtcdcpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1586481933
+SHA256 (chadnickbok-librtcdcpp-g20180627-49ddb949ed5dd2c8e859097b6723347f52e01645_GH0.tar.gz) = 032446b7e12b72b86c9bc42dc7b23fb73d553aaae4de6e27eb33a851b70695b0
+SIZE (chadnickbok-librtcdcpp-g20180627-49ddb949ed5dd2c8e859097b6723347f52e01645_GH0.tar.gz) = 5152018
diff --git a/www/librtcdcpp/files/patch-CMakeLists.txt b/www/librtcdcpp/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..0495794d9273
--- /dev/null
+++ b/www/librtcdcpp/files/patch-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- CMakeLists.txt.orig 2020-04-09 23:40:12 UTC
++++ CMakeLists.txt
+@@ -66,4 +66,4 @@ target_link_libraries(rtcdcpp
+ add_library(LibRtcdcpp::LibRtcdcpp ALIAS rtcdcpp)
+
+ # Build examples
+-add_subdirectory(examples/websocket_client)
++#add_subdirectory(examples/websocket_client)
diff --git a/www/librtcdcpp/files/patch-src_Logging.cpp b/www/librtcdcpp/files/patch-src_Logging.cpp
new file mode 100644
index 000000000000..f40aafa46401
--- /dev/null
+++ b/www/librtcdcpp/files/patch-src_Logging.cpp
@@ -0,0 +1,13 @@
+--- src/Logging.cpp.orig 2020-04-10 01:02:36 UTC
++++ src/Logging.cpp
+@@ -27,6 +27,10 @@
+
+ #include "rtcdcpp/Logging.hpp"
+
++#ifndef SPDLOG_DISABLED
++#include <spdlog/sinks/stdout_color_sinks.h>
++#endif
++
+ namespace rtcdcpp {
+
+ #ifndef SPDLOG_DISABLED
diff --git a/www/librtcdcpp/pkg-descr b/www/librtcdcpp/pkg-descr
new file mode 100644
index 000000000000..f78f33f2c99b
--- /dev/null
+++ b/www/librtcdcpp/pkg-descr
@@ -0,0 +1,7 @@
+librtcdcpp is a simple C++ implementation of the WebRTC DataChannels API.
+It was originally written by Andrew Gault and Nick Chadwick, and was inspired in
+by librtcdc.
+Its goal is to be the easiest way to build native WebRTC DataChannels apps
+across PC/Mac/Linux/iOS/Android.
+
+WWW: https://github.com/chadnickbok/librtcdcpp
diff --git a/www/librtcdcpp/pkg-plist b/www/librtcdcpp/pkg-plist
new file mode 100644
index 000000000000..820431ac4be7
--- /dev/null
+++ b/www/librtcdcpp/pkg-plist
@@ -0,0 +1,11 @@
+include/rtcdcpp/Chunk.hpp
+include/rtcdcpp/ChunkQueue.hpp
+include/rtcdcpp/DTLSWrapper.hpp
+include/rtcdcpp/DataChannel.hpp
+include/rtcdcpp/Logging.hpp
+include/rtcdcpp/NiceWrapper.hpp
+include/rtcdcpp/PeerConnection.hpp
+include/rtcdcpp/RTCCertificate.hpp
+include/rtcdcpp/SCTPWrapper.hpp
+include/rtcdcpp/librtcdcpp.h
+lib/librtcdcpp.so