aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-16 03:34:56 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-16 03:34:56 +0000
commite894c29ad5fd45176ff40a63376707531adddba3 (patch)
treefe6e6f1047f8d67869e24a29bf32f5ba72588a1c /www
parent26b131e57b2e8fdf4e4c77b11417d7b7bd8b9b37 (diff)
downloadports-e894c29ad5fd45176ff40a63376707531adddba3.tar.gz
ports-e894c29ad5fd45176ff40a63376707531adddba3.zip
Add DOCS option to the remaining staged ports where PORTDOCS appears
in the plist.
Notes
Notes: svn path=/head/; revision=362026
Diffstat (limited to 'www')
-rw-r--r--www/analog/Makefile2
-rw-r--r--www/calamaris/Makefile2
-rw-r--r--www/caudium14/Makefile2
-rw-r--r--www/css-mode.el/Makefile2
-rw-r--r--www/drupal7/Makefile2
-rw-r--r--www/flat-frog/Makefile2
-rw-r--r--www/flat-frog/pkg-plist14
-rw-r--r--www/free-sa-devel/Makefile2
-rw-r--r--www/jdresolve/Makefile2
-rw-r--r--www/lynx-current/Makefile2
-rw-r--r--www/middleman/Makefile9
-rw-r--r--www/mod_fcgid/Makefile2
-rw-r--r--www/mod_layout22/Makefile2
-rw-r--r--www/nanoblogger-extra/Makefile2
-rw-r--r--www/nanoblogger/Makefile2
-rw-r--r--www/p5-Apache-Gallery/Makefile2
-rw-r--r--www/p5-CGI_Lite/Makefile2
-rw-r--r--www/p5-CGI_Lite/pkg-plist16
-rw-r--r--www/p5-URI-Sequin/Makefile2
-rw-r--r--www/phpbb/Makefile2
-rw-r--r--www/phproxy/Makefile2
-rw-r--r--www/py-nevow/Makefile2
-rw-r--r--www/pyjamas/Makefile2
-rw-r--r--www/rsstool/Makefile2
-rw-r--r--www/rt40/Makefile2
-rw-r--r--www/rt42/Makefile2
-rw-r--r--www/ruby-amazon/Makefile2
-rw-r--r--www/ruby-aws/Makefile2
-rw-r--r--www/ruby-google/Makefile2
-rw-r--r--www/swiggle/Makefile2
-rw-r--r--www/twill/Makefile2
-rw-r--r--www/vdradmin-am/Makefile2
-rw-r--r--www/waccess/Makefile2
-rw-r--r--www/webcheck/Makefile2
-rw-r--r--www/wikindx/Makefile2
35 files changed, 77 insertions, 26 deletions
diff --git a/www/analog/Makefile b/www/analog/Makefile
index 64355357eb34..d8e9095a9541 100644
--- a/www/analog/Makefile
+++ b/www/analog/Makefile
@@ -31,6 +31,8 @@ LIMGDIR?= www/data/images
IMGDIR= ${PREFIX}/${LIMGDIR}
PLIST_SUB= IMGDIR="${LIMGDIR}"
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
do-install:
diff --git a/www/calamaris/Makefile b/www/calamaris/Makefile
index befc82aa25f5..93d6f75a2869 100644
--- a/www/calamaris/Makefile
+++ b/www/calamaris/Makefile
@@ -14,6 +14,8 @@ USES= shebangfix perl5
NO_BUILD= yes
SHEBANG_FILES= calamaris
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/www/caudium14/Makefile b/www/caudium14/Makefile
index 0389af96a7f5..0393a3a99a75 100644
--- a/www/caudium14/Makefile
+++ b/www/caudium14/Makefile
@@ -29,6 +29,8 @@ INSTALL_TARGET= install_alt
DOCSDIR= ${PREFIX}/share/doc/caudium
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${SED} -e 's:@CAUDIUM_SERVERDIR@:${PREFIX}/caudium/server:' \
-e 's:^#############$$:${ECHO} "$${caudium_enable}" | ${EGREP} -iq "^yes|^true" || exit:' \
diff --git a/www/css-mode.el/Makefile b/www/css-mode.el/Makefile
index 4e2796b9b85e..3bd679b025c8 100644
--- a/www/css-mode.el/Makefile
+++ b/www/css-mode.el/Makefile
@@ -28,6 +28,8 @@ DOCSDIR= ${PREFIX}/share/doc/css-mode
PLIST_SUB= ELISP_SUBDIR=${ELISP_SUBDIR} XELISP_SUBDIR=${XELISP_SUBDIR}
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${ELISP_SUBDIR}
${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/${ELISP_SUBDIR}
diff --git a/www/drupal7/Makefile b/www/drupal7/Makefile
index cf6c63d55c3d..466709acd0d6 100644
--- a/www/drupal7/Makefile
+++ b/www/drupal7/Makefile
@@ -20,7 +20,7 @@ USES= drupal:7
USE_PHP= dom filter gd hash json mbstring pcre pdo session simplexml xml
WANT_PHP_WEB= yes
-OPTIONS_DEFINE= MYSQL SQLITE3 PGSQL
+OPTIONS_DEFINE= MYSQL SQLITE3 PGSQL DOCS
OPTIONS_DEFAULT= MYSQL
NO_BUILD= yes
diff --git a/www/flat-frog/Makefile b/www/flat-frog/Makefile
index 55bf672d7cab..f49473cc4c08 100644
--- a/www/flat-frog/Makefile
+++ b/www/flat-frog/Makefile
@@ -13,6 +13,8 @@ NO_BUILD= yes
USE_PHP= yes
USES= zip
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-install:
${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${DATADIR}/plugins
${INSTALL_DATA} ${WRKSRC}/src/class.* ${STAGEDIR}${DATADIR}
diff --git a/www/flat-frog/pkg-plist b/www/flat-frog/pkg-plist
index 4d851668ba21..fef02e1e1798 100644
--- a/www/flat-frog/pkg-plist
+++ b/www/flat-frog/pkg-plist
@@ -29,11 +29,11 @@
%%DATADIR%%/plugins/modifier.upper.php
%%DATADIR%%/plugins/modifier.urlencode.php
%%DATADIR%%/plugins/modifier.wordwrap.php
-%%EXAMPLESDIR%%/templates/footer.tpl
-%%EXAMPLESDIR%%/templates/header.tpl
-%%EXAMPLESDIR%%/templates/index.tpl
-%%EXAMPLESDIR%%/templates/test.conf
-%%EXAMPLESDIR%%/test.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/footer.tpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/header.tpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/index.tpl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/test.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.php
%%PORTDOCS%%%%DOCSDIR%%/appendix.caching.html
%%PORTDOCS%%%%DOCSDIR%%/appendix.groups.html
%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
@@ -50,8 +50,8 @@
%%PORTDOCS%%%%DOCSDIR%%/programming.methods.html
%%PORTDOCS%%%%DOCSDIR%%/programming.variables.html
%%PORTDOCS%%%%DOCSDIR%%/what.is.html
-@dirrm %%EXAMPLESDIR%%/templates
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/templates
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%/plugins
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/www/free-sa-devel/Makefile b/www/free-sa-devel/Makefile
index dcf537e5d531..8e160affcb8c 100644
--- a/www/free-sa-devel/Makefile
+++ b/www/free-sa-devel/Makefile
@@ -42,7 +42,7 @@ MAKE_ARGS+= PREFIX="${PREFIX}" \
MANDIR="${MANPREFIX}/man" \
STAGEDIR="${STAGEDIR}"
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS SA_DEBUG
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS SA_DEBUG DOCS
OPTIMIZED_CFLAGS_DESC= Build with distribution-recommended CFLAGS
SA_DEBUG_DESC= Enable Free-SA debugging (level 1)
diff --git a/www/jdresolve/Makefile b/www/jdresolve/Makefile
index 6c4e09ec494d..d1d072664c41 100644
--- a/www/jdresolve/Makefile
+++ b/www/jdresolve/Makefile
@@ -20,6 +20,8 @@ NO_BUILD= yes
DOC1= AUTHORS BUGS CHANGELOG COPYING CREDITS INSTALL README TODO
+OPTIONS_DEFINE= DOCS
+
do-install:
.for file in jdresolve rhost
${INSTALL_SCRIPT} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index c93ea318ab41..3ff019fdc8a8 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -43,7 +43,7 @@ L_DOC= ${PREFIX}/share/doc/lynx
L_HELP= ${PREFIX}/share/lynx_help
DOCSDIR= ${L_DOC}
-OPTIONS_DEFINE= IDN NLS
+OPTIONS_DEFINE= IDN NLS DOCS
OPTIONS_DEFAULT=IDN NLS
OPTIONS_SUB= yes
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 553c7185e36e..2a190a59ca39 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -10,12 +10,11 @@ MASTER_SITES= SF/middle-man/Source/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Robust proxy server
-OPTIONS_DEFINE= SYSLOG DEBUG MTIME
-OPTIONS_DEFAULT=
+OPTIONS_DEFINE= SYSLOG DEBUG MTIME DOCS
SYSLOG_DESC= Enable syslog support
-DEBUG_DESC= Enable debugging support
-MTIME_DESC= Enable mtime support
+DEBUG_DESC= Enable debugging support
+MTIME_DESC= Enable mtime support
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
@@ -24,8 +23,6 @@ USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-MAN8= mman.8
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSYSLOG}
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index f0621f97f849..2c7ed6b0956b 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -30,6 +30,8 @@ MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION} -I${LOCALBA
INSTALL_TARGET= install-modules-yes
DOCSDIR= ${PREFIX}/share/doc/apache${APACHE_VERSION}/mod
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/docs/manual/mod/mod_fcgid.html ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_layout22/Makefile b/www/mod_layout22/Makefile
index 1c8a4dc8b997..7d86f83147a2 100644
--- a/www/mod_layout22/Makefile
+++ b/www/mod_layout22/Makefile
@@ -20,6 +20,8 @@ LATEST_LINK= mod_layout22
MAKE_ARGS+= builddir=${WRKSRC}
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
${WRKSRC}/Makefile
diff --git a/www/nanoblogger-extra/Makefile b/www/nanoblogger-extra/Makefile
index a92ccfce2dab..328138f9924f 100644
--- a/www/nanoblogger-extra/Makefile
+++ b/www/nanoblogger-extra/Makefile
@@ -18,6 +18,8 @@ DATADIR= ${PREFIX}/share/nanoblogger
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
.for data in default lang plugins
@( cd ${WRKSRC}/${data} && \
diff --git a/www/nanoblogger/Makefile b/www/nanoblogger/Makefile
index 3e803c5627c7..bfe66aa40887 100644
--- a/www/nanoblogger/Makefile
+++ b/www/nanoblogger/Makefile
@@ -18,6 +18,8 @@ NO_BUILD= yes
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/nb
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/nb
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index 2762a03cf78c..ee6a478f8c95 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -32,6 +32,8 @@ DOC_FILES= INSTALL LICENSE README TODO UPGRADE
SUB_FILES+= pkg-message
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/www/p5-CGI_Lite/Makefile b/www/p5-CGI_Lite/Makefile
index b410dd658a09..e1a436d43442 100644
--- a/www/p5-CGI_Lite/Makefile
+++ b/www/p5-CGI_Lite/Makefile
@@ -16,6 +16,8 @@ USE_PERL5= configure
DOCS= CHANGES README TODO
EXAMPLES= cookies get_post print upload file post reference
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/www/p5-CGI_Lite/pkg-plist b/www/p5-CGI_Lite/pkg-plist
index 7e8f21d5a2ac..174ffb2206da 100644
--- a/www/p5-CGI_Lite/pkg-plist
+++ b/www/p5-CGI_Lite/pkg-plist
@@ -3,15 +3,15 @@
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%EXAMPLESDIR%%/cookies
-%%PORTDOCS%%%%EXAMPLESDIR%%/file
-%%PORTDOCS%%%%EXAMPLESDIR%%/get_post
-%%PORTDOCS%%%%EXAMPLESDIR%%/post
-%%PORTDOCS%%%%EXAMPLESDIR%%/print
-%%PORTDOCS%%%%EXAMPLESDIR%%/reference
-%%PORTDOCS%%%%EXAMPLESDIR%%/upload
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookies
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/get_post
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/post
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/print
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reference
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PERL5_MAN3%%/CGI::Lite.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Lite
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI
diff --git a/www/p5-URI-Sequin/Makefile b/www/p5-URI-Sequin/Makefile
index eb1b57525fc6..e145c1f64ee7 100644
--- a/www/p5-URI-Sequin/Makefile
+++ b/www/p5-URI-Sequin/Makefile
@@ -14,6 +14,8 @@ COMMENT= Extract information from the URLs of Search-Engines
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/URI/Sequin/examples
@${INSTALL_DATA} ${WRKSRC}/example.pl ${WRKSRC}/ref?.log \
diff --git a/www/phpbb/Makefile b/www/phpbb/Makefile
index eca1c4f5aa7c..12f006115621 100644
--- a/www/phpbb/Makefile
+++ b/www/phpbb/Makefile
@@ -46,6 +46,8 @@ EXCEPTFILES= ${STAGEDIR}${PREFIX}/${PHPBBDIR}/install/install.php \
${STAGEDIR}${PREFIX}/${PHPBBDIR}/install/upgrade.php \
${STAGEDIR}${PREFIX}/${PHPBBDIR}/install/update_to_latest.php
+OPTIONS_DEFINE= DOCS
+
options:
@ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
@ ${CAT} ${PKGOPTS}
diff --git a/www/phproxy/Makefile b/www/phproxy/Makefile
index d8bfea1d8811..e3e9566e220f 100644
--- a/www/phproxy/Makefile
+++ b/www/phproxy/Makefile
@@ -19,6 +19,8 @@ EXTRACT_AFTER_ARGS+= -d ${WRKSRC}
DOCFILES= ChangeLog.txt LICENSE.txt README.txt TODO.txt
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCFILES}
diff --git a/www/py-nevow/Makefile b/www/py-nevow/Makefile
index 8701f26746ab..b85ec3bd4948 100644
--- a/www/py-nevow/Makefile
+++ b/www/py-nevow/Makefile
@@ -24,6 +24,8 @@ PKGMESSAGE= ${WRKSRC}/pkg-message
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
diff --git a/www/pyjamas/Makefile b/www/pyjamas/Makefile
index e93bfdfc2430..aabb6b307a74 100644
--- a/www/pyjamas/Makefile
+++ b/www/pyjamas/Makefile
@@ -19,6 +19,8 @@ PYDISTUTILS_AUTOPLIST= yes
REINPLACE_ARGS= -i '' -e 's,../../bin,${PREFIX}/bin,'
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/pyjamas|${DATADIR}|' ${WRKSRC}/setup.py
${FIND} ${WRKSRC}/examples -type f -name "build.sh" -print0 | ${XARGS} -0 ${REINPLACE_CMD}
diff --git a/www/rsstool/Makefile b/www/rsstool/Makefile
index b8a2e4f72783..3bf121cf9df6 100644
--- a/www/rsstool/Makefile
+++ b/www/rsstool/Makefile
@@ -17,6 +17,8 @@ BUILD_WRKSRC= ${WRKSRC}/src
CONFIGURE_WRKSRC= ${WRKSRC}/src
HAS_CONFIGURE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@cd ${BUILD_WRKSRC}/&&${REINPLACE_CMD} -e 's|gcc|${CC}|' Makefile
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index 715b54d083b1..69306779d196 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -33,7 +33,7 @@ NO_ARCH= yes
# mentioned in the docs is currently unsupported in the ports, but see
# http://www.infracaninophile.co.uk/articles/sphinxse.html
-OPTIONS_DEFINE= DEV GD GPG GRAPHVIZ SSL_MAILGATE
+OPTIONS_DEFINE= DEV GD GPG GRAPHVIZ SSL_MAILGATE DOCS
OPTIONS_SINGLE= DB
OPTIONS_SINGLE_DB= MYSQL ORACLE PGSQL SQLITE
OPTIONS_RADIO= WEB
diff --git a/www/rt42/Makefile b/www/rt42/Makefile
index 130440005a96..3d0066c9e98f 100644
--- a/www/rt42/Makefile
+++ b/www/rt42/Makefile
@@ -32,7 +32,7 @@ NO_ARCH= yes
# mentioned in the docs is currently unsupported in the ports, but see
# http://www.infracaninophile.co.uk/articles/sphinxse.html
-OPTIONS_DEFINE= DEVELOPER GD GPG GRAPHVIZ SMIME
+OPTIONS_DEFINE= DEVELOPER GD GPG GRAPHVIZ SMIME DOCS
OPTIONS_SINGLE= DB
OPTIONS_SINGLE_DB= MYSQL ORACLE PGSQL SQLITE
OPTIONS_RADIO= WEB
diff --git a/www/ruby-amazon/Makefile b/www/ruby-amazon/Makefile
index 9471b88bf056..ffda88b239bf 100644
--- a/www/ruby-amazon/Makefile
+++ b/www/ruby-amazon/Makefile
@@ -20,6 +20,8 @@ USE_RUBY_SETUP= yes
DOCS= NEWS README TODO
EXAMPLES= example/*
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
diff --git a/www/ruby-aws/Makefile b/www/ruby-aws/Makefile
index e8252c13318b..65bb2e4e6cdf 100644
--- a/www/ruby-aws/Makefile
+++ b/www/ruby-aws/Makefile
@@ -20,6 +20,8 @@ USE_RUBY_SETUP= yes
DOCS= COPYING INSTALL NEWS README
EXAMPLES= example/*
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.for f in ${EXAMPLES}
diff --git a/www/ruby-google/Makefile b/www/ruby-google/Makefile
index a8512ab9cd2c..a96216f43031 100644
--- a/www/ruby-google/Makefile
+++ b/www/ruby-google/Makefile
@@ -20,6 +20,8 @@ RUBY_SETUP= install.rb
DOCS= CHANGES Changelog README google.html
EXAMPLES= examples/*
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
diff --git a/www/swiggle/Makefile b/www/swiggle/Makefile
index 267a3d2b928b..ea07dc44941a 100644
--- a/www/swiggle/Makefile
+++ b/www/swiggle/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD4CLAUSE
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexif.so:${PORTSDIR}/graphics/libexif
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/Makefile
diff --git a/www/twill/Makefile b/www/twill/Makefile
index 04fa9282402d..019973b5b0cb 100644
--- a/www/twill/Makefile
+++ b/www/twill/Makefile
@@ -14,6 +14,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -R ${WRKSRC}/doc/ ${STAGEDIR}${DOCSDIR}
diff --git a/www/vdradmin-am/Makefile b/www/vdradmin-am/Makefile
index ef17c28ec251..fe402da0acde 100644
--- a/www/vdradmin-am/Makefile
+++ b/www/vdradmin-am/Makefile
@@ -57,6 +57,8 @@ PLIST_SUB= VDR_USER=${VDR_USER}
PLIST_SUB+= VDR_GROUP=${VDR_GROUP}
PLIST_SUB+= PREFIX=${PREFIX}
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 1s-^#!/bin/bash-#!${LOCALBASE}/bin/bash- \
${WRKSRC}/install.sh ${WRKSRC}/make.sh
diff --git a/www/waccess/Makefile b/www/waccess/Makefile
index 1c14a02e7dec..447d91b2729f 100644
--- a/www/waccess/Makefile
+++ b/www/waccess/Makefile
@@ -11,6 +11,8 @@ COMMENT= Quick-N-Dirty Web Access Log Analyzer
USE_PYTHON= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/waccess ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/waccess.1.gz ${STAGEDIR}${PREFIX}/man/man1
diff --git a/www/webcheck/Makefile b/www/webcheck/Makefile
index 000cdb1eef2d..9308d0ea462d 100644
--- a/www/webcheck/Makefile
+++ b/www/webcheck/Makefile
@@ -15,6 +15,8 @@ NO_BUILD= yes
# what about fancytooltips?
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.py ${STAGEDIR}${DATADIR}
diff --git a/www/wikindx/Makefile b/www/wikindx/Makefile
index 6015e49130c7..52e57d2e76ee 100644
--- a/www/wikindx/Makefile
+++ b/www/wikindx/Makefile
@@ -21,6 +21,8 @@ ROOTDIRS= attachments core docs files languages modules \
DOCFILES= CHANGELOG CUSTOMIZATION DISCLAIMER INSTALL \
LICENSE README README_CMS README_RSS UPGRADE
+OPTIONS_DEFINE= DOCS
+
pre-install:
@${ECHO} ${WWWDIR}