aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 12:54:57 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 12:54:57 +0000
commitf725dc8ef5848b5e69ebefdc7c1f1517f26643fb (patch)
tree61e738084a4bfbaac41e371a863552bfb8c6ed2a /www
parent985ad018658ea12b1f67b9a76f8252fac0982438 (diff)
downloadports-f725dc8ef5848b5e69ebefdc7c1f1517f26643fb.tar.gz
ports-f725dc8ef5848b5e69ebefdc7c1f1517f26643fb.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Notes
Notes: svn path=/head/; revision=93885
Diffstat (limited to 'www')
-rw-r--r--www/aolserver/Makefile2
-rw-r--r--www/apache13-fp/Makefile2
-rw-r--r--www/galeon2/Makefile2
-rw-r--r--www/gallery/Makefile2
-rw-r--r--www/gallery2/Makefile2
-rw-r--r--www/gallery3/Makefile2
-rw-r--r--www/jakarta-tomcat3/Makefile2
-rw-r--r--www/jakarta-tomcat4/Makefile2
-rw-r--r--www/jakarta-tomcat41/Makefile2
-rw-r--r--www/jakarta-tomcat5/Makefile2
-rw-r--r--www/jakarta-tomcat55/Makefile2
-rw-r--r--www/linux-mozilla-devel/Makefile4
-rw-r--r--www/linux-mozilla/Makefile4
-rw-r--r--www/mmosaic/Makefile2
-rw-r--r--www/neowebscript/Makefile4
-rw-r--r--www/netscape7/Makefile6
-rw-r--r--www/orion/Makefile2
-rw-r--r--www/tomcat41/Makefile2
-rw-r--r--www/tomcat55/Makefile2
-rw-r--r--www/tomcat6/Makefile2
-rw-r--r--www/tomcat7/Makefile2
-rw-r--r--www/wb0/Makefile2
-rw-r--r--www/webcpp/Makefile2
-rw-r--r--www/zope-guf/Makefile2
-rw-r--r--www/zope-zmysqlda/Makefile2
-rw-r--r--www/zope-zpt/Makefile4
-rw-r--r--www/zope-zwiki/Makefile2
27 files changed, 33 insertions, 33 deletions
diff --git a/www/aolserver/Makefile b/www/aolserver/Makefile
index 92d2fc9f0a80..b773267ef8f1 100644
--- a/www/aolserver/Makefile
+++ b/www/aolserver/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
INSTALL_TARGET= install INST=${PREFIX}/${PORTNAME}
post-extract:
- find ${WRKSRC} -name CVS | xargs ${RM} -rf
+ ${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -rf
post-install:
# Headers
diff --git a/www/apache13-fp/Makefile b/www/apache13-fp/Makefile
index 61e843ed9d15..c940b39294c5 100644
--- a/www/apache13-fp/Makefile
+++ b/www/apache13-fp/Makefile
@@ -120,7 +120,7 @@ PLIST_SUB+= SUEXEC="@comment "
post-patch:
.if !defined(PATCH_DEBUG)
@ cd ${WRKSRC} \
- && find . -type f -name "*.orig" -print | xargs ${RM} -f
+ && ${FIND} . -type f -name "*.orig" -print | ${XARGS} ${RM} -f
.endif
# Create apache user and group
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 3925ef83003b..0762c3adfdf6 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -81,7 +81,7 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}-gtk2|g' \
${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
diff --git a/www/gallery/Makefile b/www/gallery/Makefile
index 09fceaa8b86f..565ce8cce83c 100644
--- a/www/gallery/Makefile
+++ b/www/gallery/Makefile
@@ -49,7 +49,7 @@ post-configure:
do-install:
@ ${MKDIR} -m 0755 ${PREFIX}/${GALLERYDIR}
- @ cd ${WRKSRC} && find * -name \*.bat ${EXCEPTFILES:S/^/-o -name /} \
+ @ cd ${WRKSRC} && ${FIND} * -name \*.bat ${EXCEPTFILES:S/^/-o -name /} \
-o -print | ${CPIO} ${WWWOWN}:${WWWGRP} ${PREFIX}/${GALLERYDIR}
post-install:
diff --git a/www/gallery2/Makefile b/www/gallery2/Makefile
index 09fceaa8b86f..565ce8cce83c 100644
--- a/www/gallery2/Makefile
+++ b/www/gallery2/Makefile
@@ -49,7 +49,7 @@ post-configure:
do-install:
@ ${MKDIR} -m 0755 ${PREFIX}/${GALLERYDIR}
- @ cd ${WRKSRC} && find * -name \*.bat ${EXCEPTFILES:S/^/-o -name /} \
+ @ cd ${WRKSRC} && ${FIND} * -name \*.bat ${EXCEPTFILES:S/^/-o -name /} \
-o -print | ${CPIO} ${WWWOWN}:${WWWGRP} ${PREFIX}/${GALLERYDIR}
post-install:
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index 09fceaa8b86f..565ce8cce83c 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -49,7 +49,7 @@ post-configure:
do-install:
@ ${MKDIR} -m 0755 ${PREFIX}/${GALLERYDIR}
- @ cd ${WRKSRC} && find * -name \*.bat ${EXCEPTFILES:S/^/-o -name /} \
+ @ cd ${WRKSRC} && ${FIND} * -name \*.bat ${EXCEPTFILES:S/^/-o -name /} \
-o -print | ${CPIO} ${WWWOWN}:${WWWGRP} ${PREFIX}/${GALLERYDIR}
post-install:
diff --git a/www/jakarta-tomcat3/Makefile b/www/jakarta-tomcat3/Makefile
index 08aa854cf782..3959bce53a75 100644
--- a/www/jakarta-tomcat3/Makefile
+++ b/www/jakarta-tomcat3/Makefile
@@ -143,7 +143,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/jakarta-tomcat4/Makefile b/www/jakarta-tomcat4/Makefile
index ea8aae5d34cf..722844832b58 100644
--- a/www/jakarta-tomcat4/Makefile
+++ b/www/jakarta-tomcat4/Makefile
@@ -155,7 +155,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/jakarta-tomcat41/Makefile b/www/jakarta-tomcat41/Makefile
index b869d635de3c..e326850ca12d 100644
--- a/www/jakarta-tomcat41/Makefile
+++ b/www/jakarta-tomcat41/Makefile
@@ -156,7 +156,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/jakarta-tomcat5/Makefile b/www/jakarta-tomcat5/Makefile
index 2202a0a1846a..faf5abbd416d 100644
--- a/www/jakarta-tomcat5/Makefile
+++ b/www/jakarta-tomcat5/Makefile
@@ -154,7 +154,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/jakarta-tomcat55/Makefile b/www/jakarta-tomcat55/Makefile
index 2202a0a1846a..faf5abbd416d 100644
--- a/www/jakarta-tomcat55/Makefile
+++ b/www/jakarta-tomcat55/Makefile
@@ -154,7 +154,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/linux-mozilla-devel/Makefile b/www/linux-mozilla-devel/Makefile
index 7a0d5a8c96ef..0f882f07458f 100644
--- a/www/linux-mozilla-devel/Makefile
+++ b/www/linux-mozilla-devel/Makefile
@@ -145,11 +145,11 @@ pre-install:
${ECHO_CMD} bin/${STARTUP_CMD} > ${PLIST}
${ECHO_CMD} "@unexec ${FIND} ${FULL_INSTALL_DIR}/plugins \
-type l -exec ${RM} {} \;" >> ${PLIST}
- cd ${WRKSRC}/bin; for i in `find * \! -type d | sort`; do \
+ cd ${WRKSRC}/bin; for i in `${FIND} * \! -type d | sort`; do \
${ECHO_CMD} lib/${INSTALL_DIR}/$${i} >> ${PLIST}; \
done
cd ${WRKSRC}/bin; \
- for i in `find -d * -type d`; do \
+ for i in `${FIND} -d * -type d`; do \
${ECHO_CMD} @dirrm lib/${INSTALL_DIR}/$${i} >> ${PLIST}; \
done
${ECHO_CMD} lib/${INSTALL_DIR}/linkfarm >> ${PLIST}
diff --git a/www/linux-mozilla/Makefile b/www/linux-mozilla/Makefile
index 26e59c0f8227..4353eb0b9278 100644
--- a/www/linux-mozilla/Makefile
+++ b/www/linux-mozilla/Makefile
@@ -146,11 +146,11 @@ pre-install:
${ECHO_CMD} bin/${STARTUP_CMD} > ${PLIST}
${ECHO_CMD} "@unexec ${FIND} ${PREFIX}/lib/linux-mozilla/plugins -type l \
-exec ${RM} {} \;" >> ${PLIST}
- cd ${WRKSRC}/bin; for i in `find * \! -type d | sort`; do \
+ cd ${WRKSRC}/bin; for i in `${FIND} * \! -type d | sort`; do \
${ECHO_CMD} lib/linux-mozilla/$${i} >> ${PLIST}; \
done
cd ${WRKSRC}/bin; \
- for i in `find -d * -type d`; do \
+ for i in `${FIND} -d * -type d`; do \
${ECHO_CMD} @dirrm lib/linux-mozilla/$${i} >> ${PLIST}; \
done
${ECHO_CMD} lib/linux-mozilla/linkfarm >> ${PLIST}
diff --git a/www/mmosaic/Makefile b/www/mmosaic/Makefile
index 4c5f05c5db4b..dab64c9652cc 100644
--- a/www/mmosaic/Makefile
+++ b/www/mmosaic/Makefile
@@ -36,7 +36,7 @@ post-patch:
pre-install:
${ECHO_CMD} bin/mmosaic > ${PLIST}
- cd ${WRKSRC}/Copyrights; for i in `find * -type f`; do \
+ cd ${WRKSRC}/Copyrights; for i in `${FIND} * -type f`; do \
${ECHO_CMD} share/doc/mmosaic/$${i} >> ${PLIST}; \
done
diff --git a/www/neowebscript/Makefile b/www/neowebscript/Makefile
index 4f1022c0a93c..6e1cdac39249 100644
--- a/www/neowebscript/Makefile
+++ b/www/neowebscript/Makefile
@@ -31,11 +31,11 @@ EXTRACT_AFTER_ARGS:=| ${TAR} -xf - ${SUBDIRS:%=${PORTNAME}-${PORTVERSION}/%}
post-patch:
# Replacing writeGIF with writePNG
${PERL} -pi -e 's/writeGIF/writePNG/g' \
- `find ${WRKSRC}/.. -type f | xargs fgrep -l --mmap writeGIF`
+ `${FIND} ${WRKSRC}/.. -type f|${XARGS} fgrep -l --mmap writeGIF`
pre-install:
# Removing *.orig files and empty directories:
- find ${WRKSRC}/../neowebscript ${WRKSRC}/../htdocs \
+ ${FIND} ${WRKSRC}/../neowebscript ${WRKSRC}/../htdocs \
\( -type f -name \*.orig -o -type d -empty \) -delete
CONFSCRIPT= ${LOCALBASE}/etc/apache/neowebscript.conf
diff --git a/www/netscape7/Makefile b/www/netscape7/Makefile
index de37e237ddf0..4a395ab7b92f 100644
--- a/www/netscape7/Makefile
+++ b/www/netscape7/Makefile
@@ -92,14 +92,14 @@ do-configure:
pre-install:
${ECHO_CMD} bin/${MAJ}${NETSCAPE_LANG} > ${PLIST}
- cd ${WRKSRC}/bin; for ii in `find * \! -type d | sort`; do \
+ cd ${WRKSRC}/bin; for ii in `${FIND} * \! -type d | sort`; do \
${ECHO_CMD} ${INSTALL_DIR}/$${ii} >> ${PLIST}; \
done
- cd ${WRKSRC}/plugins; for ii in `find * \! -type d | sort`; do \
+ cd ${WRKSRC}/plugins; for ii in `${FIND} * \! -type d | sort`; do \
${ECHO_CMD} ${INSTALL_DIR}/plugins/$${ii} >> ${PLIST}; \
done
cd ${WRKSRC}/bin; \
- for ii in `find -d * -type d`; do \
+ for ii in `${FIND} -d * -type d`; do \
${ECHO_CMD} @dirrm ${INSTALL_DIR}/$${ii} >> ${PLIST}; \
done
${ECHO_CMD} @dirrm ${INSTALL_DIR} >> ${PLIST}
diff --git a/www/orion/Makefile b/www/orion/Makefile
index 0c824c90de4a..a0f9b5a6a8d9 100644
--- a/www/orion/Makefile
+++ b/www/orion/Makefile
@@ -158,7 +158,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/tomcat41/Makefile b/www/tomcat41/Makefile
index b869d635de3c..e326850ca12d 100644
--- a/www/tomcat41/Makefile
+++ b/www/tomcat41/Makefile
@@ -156,7 +156,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index 2202a0a1846a..faf5abbd416d 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -154,7 +154,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index 2202a0a1846a..faf5abbd416d 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -154,7 +154,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index 2202a0a1846a..faf5abbd416d 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -154,7 +154,7 @@ do-install:
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Fixing permissions..."
- @${CHMOD} 755 `find ${APP_HOME} -type d`
+ @${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_CMD} " [ DONE ]"
@${ECHO_CMD} -n ">> Creating PID file..."
diff --git a/www/wb0/Makefile b/www/wb0/Makefile
index e6372cc6a621..e619da4a8449 100644
--- a/www/wb0/Makefile
+++ b/www/wb0/Makefile
@@ -40,7 +40,7 @@ pre-install:
${ECHO_CMD} @dirrm ${DOCDIR} >> ${PLIST}
.endif
${ECHO_CMD} etc/wb0.config >> ${PLIST}
- for i in `find ${PREFIX}/share/wb0 -type f`; \
+ for i in `${FIND} ${PREFIX}/share/wb0 -type f`; \
do ${ECHO_CMD} share/wb0/`${BASENAME} $${i}` >> ${PLIST}; \
done
${ECHO_CMD} @dirrm share/wb0 >> ${PLIST}
diff --git a/www/webcpp/Makefile b/www/webcpp/Makefile
index 2e61ff1e48c5..c1889b23664f 100644
--- a/www/webcpp/Makefile
+++ b/www/webcpp/Makefile
@@ -27,7 +27,7 @@ USE_GMAKE= yes
.endif
pre-patch:
- ${FIND} ${WRKSRC} -name '*.h' | xargs ${REINPLACE_CMD} \
+ ${FIND} ${WRKSRC} -name '*.h' | ${XARGS} ${REINPLACE_CMD} \
's|IO->close()|if(IO) IO->close()|g'
post-install:
diff --git a/www/zope-guf/Makefile b/www/zope-guf/Makefile
index 82532ecca252..f9d039b95d6d 100644
--- a/www/zope-guf/Makefile
+++ b/www/zope-guf/Makefile
@@ -38,7 +38,7 @@ do-build:
do-install:
@ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
- @ cd ${WRKSRC} && find * | ${CPIO} ${BINOWN}:${BINGRP} \
+ @ cd ${WRKSRC} && ${FIND} * | ${CPIO} ${BINOWN}:${BINGRP} \
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
post-install:
diff --git a/www/zope-zmysqlda/Makefile b/www/zope-zmysqlda/Makefile
index ec50d8f3401c..ce0547342993 100644
--- a/www/zope-zmysqlda/Makefile
+++ b/www/zope-zmysqlda/Makefile
@@ -40,7 +40,7 @@ do-build:
do-install:
@ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
- @ cd ${WRKSRC} && find * | ${CPIO} ${BINOWN}:${BINGRP} \
+ @ cd ${WRKSRC} && ${FIND} * | ${CPIO} ${BINOWN}:${BINGRP} \
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
post-install:
diff --git a/www/zope-zpt/Makefile b/www/zope-zpt/Makefile
index 5de4f48c487d..3d099a87fb01 100644
--- a/www/zope-zpt/Makefile
+++ b/www/zope-zpt/Makefile
@@ -50,12 +50,12 @@ do-install:
.endfor
.for product in TAL ZTUtils
@ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPYTHONDIR}/${product}
- @ cd ${WRKDIR}/${product} && find * \
+ @ cd ${WRKDIR}/${product} && ${FIND} * \
| ${CPIO} ${BINOWN}:${BINGRP} \
${ZOPEBASEDIR}/${ZOPEPYTHONDIR}/${product}/
.endfor
@ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
- @ cd ${WRKSRC} && find * \( -name examples -a -prune \) -o -print \
+ @ cd ${WRKSRC} && ${FIND} * \( -name examples -a -prune \) -o -print \
| ${CPIO} ${BINOWN}:${BINGRP} \
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
@ ${MKDIR} ${ZOPEBASEDIR}/import
diff --git a/www/zope-zwiki/Makefile b/www/zope-zwiki/Makefile
index 8501009cc71e..d82aa8e22048 100644
--- a/www/zope-zwiki/Makefile
+++ b/www/zope-zwiki/Makefile
@@ -40,7 +40,7 @@ do-build:
do-install:
@ ${CHMOD} -R og+rX ${WRKSRC}/
@ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
- @ cd ${WRKSRC} && find * \! -name \*.zexp \
+ @ cd ${WRKSRC} && ${FIND} * \! -name \*.zexp \
| ${CPIO} ${BINOWN}:${BINGRP} \
${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}