aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-01 22:16:09 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-01 22:19:22 +0000
commitff7e3d70d89e5a4751823ced73504b4f2ee00067 (patch)
tree06424c4b5d0629c89b0a44f1005ed004d8f0f69f /www
parent1c07103e48760c81c7f9a6b59a4ff9f5598bd7d6 (diff)
downloadports-ff7e3d70d89e5a4751823ced73504b4f2ee00067.tar.gz
ports-ff7e3d70d89e5a4751823ced73504b4f2ee00067.zip
www/py-httptools: Update to 0.2.0
Diffstat (limited to 'www')
-rw-r--r--www/py-httptools/Makefile4
-rw-r--r--www/py-httptools/distinfo6
-rw-r--r--www/py-httptools/files/patch-httptools-parser-parser.c11
-rw-r--r--www/py-httptools/files/patch-setup.py15
4 files changed, 8 insertions, 28 deletions
diff --git a/www/py-httptools/Makefile b/www/py-httptools/Makefile
index 7ca770309234..f7ea59d49ce6 100644
--- a/www/py-httptools/Makefile
+++ b/www/py-httptools/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= httptools
-PORTVERSION= 0.1.2
+PORTVERSION= 0.2.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,6 +18,6 @@ USES= localbase python:3.5+
USE_PYTHON= autoplist concurrent distutils
post-patch:
- @${RM} -r ${WRKSRC}/vendor/
+ @${RM} -r ${WRKSRC}/vendor/http-parser/
.include <bsd.port.mk>
diff --git a/www/py-httptools/distinfo b/www/py-httptools/distinfo
index 2c99ce9dc201..3455fcb2a220 100644
--- a/www/py-httptools/distinfo
+++ b/www/py-httptools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619569497
-SHA256 (httptools-0.1.2.tar.gz) = 07659649fe6b3948b6490825f89abe5eb1cec79ebfaaa0b4bf30f3f33f3c2ba8
-SIZE (httptools-0.1.2.tar.gz) = 106716
+TIMESTAMP = 1619725373
+SHA256 (httptools-0.2.0.tar.gz) = 94505026be56652d7a530ab03d89474dc6021019d6b8682281977163b3471ea0
+SIZE (httptools-0.2.0.tar.gz) = 169260
diff --git a/www/py-httptools/files/patch-httptools-parser-parser.c b/www/py-httptools/files/patch-httptools-parser-parser.c
deleted file mode 100644
index c18f747d0409..000000000000
--- a/www/py-httptools/files/patch-httptools-parser-parser.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- httptools/parser/parser.c.orig 2021-04-26 15:52:02 UTC
-+++ httptools/parser/parser.c
-@@ -625,7 +625,7 @@ static CYTHON_INLINE float __PYX_NAN() {
- #include <stdio.h>
- #include "pythread.h"
- #include <stdint.h>
--#include "../../vendor/http-parser/http_parser.h"
-+#include "http_parser.h"
- #ifdef _OPENMP
- #include <omp.h>
- #endif /* _OPENMP */
diff --git a/www/py-httptools/files/patch-setup.py b/www/py-httptools/files/patch-setup.py
index c879a41c7b89..f606f508c4dc 100644
--- a/www/py-httptools/files/patch-setup.py
+++ b/www/py-httptools/files/patch-setup.py
@@ -1,18 +1,9 @@
---- setup.py.orig 2021-04-26 15:51:55 UTC
+--- setup.py.orig 2021-04-23 20:30:51 UTC
+++ setup.py
-@@ -15,7 +15,7 @@ CFLAGS = ['-O2']
-
- ROOT = pathlib.Path(__file__).parent
-
--CYTHON_DEPENDENCY = 'Cython==0.29.22'
-+CYTHON_DEPENDENCY = 'Cython>=0.29.21'
-
-
- class httptools_build_ext(build_ext):
-@@ -44,7 +44,7 @@ class httptools_build_ext(build_ext):
- return
+@@ -48,7 +48,7 @@ class httptools_build_ext(build_ext):
super().initialize_options()
+ self.use_system_llhttp = False
- self.use_system_http_parser = False
+ self.use_system_http_parser = True
self.cython_always = False