aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/mouseclock
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-09-02 13:26:34 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-09-02 13:26:34 +0000
commitf86cad0ce3a80127b2912301315fa7dac042002d (patch)
tree724d013a376d218986fefc586ed681b8c219eeb7 /x11-clocks/mouseclock
parent4e55a9215df0dcffaf32acdc58dfda0cb691838c (diff)
downloadports-f86cad0ce3a80127b2912301315fa7dac042002d.tar.gz
ports-f86cad0ce3a80127b2912301315fa7dac042002d.zip
Two imake related changes:
1) Move -a from XMKMF command variable to a new XMKMF_ARGS variable. For ports that don't need -a introduce USES=imake:notall. This way ports no longer have to redefine XMKMF. 2) xmkmf -a runs imake with the flags in IMAKECPPFLAGS as extra arguments to set CPP, CC and CXX. This creates the top Makefile, and then xmkmf runs make Makefiles. This Makefiles target runs imake for each subdirectory but these imake invocations did not have the flags from IMAKECPPFLAGS so the resulting makefiles used the wrong C preprocessor when clang is used (/usr/bin/cpp instead of /usr/local/bin/tradcpp). Instead of letting xmkmf pass IMAKECPPFLAGS from the environment to imake let imake handle IMAKECPPFLAGS itself just like it handles IMAKEINCLUDE. This exposed configure errors in x11-clocks/mouseclock and x11-wm/fvwm. Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=325992
Diffstat (limited to 'x11-clocks/mouseclock')
-rw-r--r--x11-clocks/mouseclock/Makefile11
-rw-r--r--x11-clocks/mouseclock/files/patch-Imakefile23
2 files changed, 26 insertions, 8 deletions
diff --git a/x11-clocks/mouseclock/Makefile b/x11-clocks/mouseclock/Makefile
index 416880fc84d6..2ddfc1984d19 100644
--- a/x11-clocks/mouseclock/Makefile
+++ b/x11-clocks/mouseclock/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mouseclock
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-clocks
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= X11/clocks
@@ -11,13 +11,8 @@ MASTER_SITE_SUBDIR= X11/clocks
MAINTAINER= ports@FreeBSD.org
COMMENT= Display the current time using the X root cursor
-USES= imake
-USE_GMAKE= yes
-USE_XORG= x11 xext
-NO_INSTALL_MANPAGES= yes
-
-post-configure:
- @${TOUCH} ${WRKSRC}/mouseclock.man
+USES= imake:notall
+USE_XORG= x11
post-install:
.if !defined(NOPORTDOCS)
diff --git a/x11-clocks/mouseclock/files/patch-Imakefile b/x11-clocks/mouseclock/files/patch-Imakefile
new file mode 100644
index 000000000000..f380fd00b7cf
--- /dev/null
+++ b/x11-clocks/mouseclock/files/patch-Imakefile
@@ -0,0 +1,23 @@
+--- Imakefile.orig 1996-05-05 18:51:27.000000000 +0200
++++ Imakefile 2013-09-01 17:04:26.000000000 +0200
+@@ -1,16 +1,10 @@
+
+-#define IHaveSubdirs
+-#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'
++OBJS = mouseclock.o
++SRCS = mouseclock.c
++SYS_LIBRARIES = $(XONLYLIB)
+
+- DEPLIBS = $(DEPXLIB)
+-LOCAL_LIBRARIES = $(XLIB)
+- CDEBUGFLAGS =
+- CCOPTIONS = -O3 -s -pipe -Wall
+
+-AllTarget(mouseclock)
+-
+-MakeMakeSubdirs($(SUBDIRS),install)
+-SimpleProgramTarget(mouseclock)
++ComplexProgramTargetNoMan(mouseclock)
+
+ arc : clean
+ (cd .. ; tar zcvf mouseclock.tar.gz mouseclock)