aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/washerdryer
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 22:40:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 22:40:44 +0000
commit1976795ac93faced9d8c86c9cb80b4f8ffa5e0ac (patch)
treea4be04fe6c86cb0e4354240238f3b579f59f83e5 /x11-clocks/washerdryer
parent251f96dd00b74095787d883272e1de68dd51de68 (diff)
downloadports-1976795ac93faced9d8c86c9cb80b4f8ffa5e0ac.tar.gz
ports-1976795ac93faced9d8c86c9cb80b4f8ffa5e0ac.zip
New port washerdryer version 1.0: A dockapp that keeps track of
the loads in your washer and dryer Submitted by: Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=49902
Diffstat (limited to 'x11-clocks/washerdryer')
-rw-r--r--x11-clocks/washerdryer/Makefile37
-rw-r--r--x11-clocks/washerdryer/distinfo1
-rw-r--r--x11-clocks/washerdryer/files/patch-Makefile24
-rw-r--r--x11-clocks/washerdryer/pkg-comment1
-rw-r--r--x11-clocks/washerdryer/pkg-descr19
-rw-r--r--x11-clocks/washerdryer/pkg-message10
-rw-r--r--x11-clocks/washerdryer/pkg-plist3
7 files changed, 95 insertions, 0 deletions
diff --git a/x11-clocks/washerdryer/Makefile b/x11-clocks/washerdryer/Makefile
new file mode 100644
index 000000000000..bb5a9ee2c25b
--- /dev/null
+++ b/x11-clocks/washerdryer/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: washerdryer
+# Date Created: Thu Nov 8 00:07:24 EST 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= washerdryer
+PORTVERSION= 1.0
+CATEGORIES= x11-clocks windowmaker
+MASTER_SITES= http://ieng9.ucsd.edu/~m1foley/
+DISTNAME= washerDryer-${PORTVERSION}
+
+MAINTAINER= pat@databits.net
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/washerDryer
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_GTK= yes
+USE_XPM= yes
+
+MANCOMPRESSED= yes
+MAN1= washerDryer.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/washerDryer ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/man/washerDryer.1.gz ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/wdryerrc ${DOCSDIR}/wdryerrc.example
+.endif
+
+post-install:
+ @${SED} 's|%%EXAMPLE%%|${DOCSDIR}/wdryerrc.example|' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/washerdryer/distinfo b/x11-clocks/washerdryer/distinfo
new file mode 100644
index 000000000000..42422be142c8
--- /dev/null
+++ b/x11-clocks/washerdryer/distinfo
@@ -0,0 +1 @@
+MD5 (washerDryer-1.0.tar.bz2) = eeaca72249bd7acc6822b395a204a773
diff --git a/x11-clocks/washerdryer/files/patch-Makefile b/x11-clocks/washerdryer/files/patch-Makefile
new file mode 100644
index 000000000000..c317ff298ae2
--- /dev/null
+++ b/x11-clocks/washerdryer/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig Fri Sep 21 19:41:47 2001
++++ Makefile Thu Nov 8 00:16:26 2001
+@@ -1,16 +1,16 @@
+-LIBDIR = -L/usr/X11R6/lib -L/usr/lib -L/opt/gnome/lib
+-LIBS = -lXpm -lXext -lX11 -lm -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl
+-CFLAGS = -I/usr/X11R6/include -I/usr/lib/glib/include -I/opt/gnome/include/gtk-1.2 -I/opt/gnome/include/glib-1.2 -I/opt/gnome/lib/glib/include
++LIBDIR = -L${X11BASE}/lib
++LIBS = `${GTK_CONFIG} --libs` -lXpm
++CFLAGS += `${GTK_CONFIG} --cflags`
+ OBJS = washerDryer.o \
+ ../wmgeneral/wmgeneral.o \
+ ../wmgeneral/misc.o \
+ ../wmgeneral/list.o
+
+ .c.o:
+- cc -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) -c -Wall $< -o $*.o $(CFLAGS)
+
+ washerDryer: $(OBJS)
+- cc -Wall -pedantic -g -o washerDryer $^ $(LIBDIR) $(LIBS)
++ $(CC) -o washerDryer $^ $(LIBDIR) $(LIBS)
+
+ all:: washerDryer
+
diff --git a/x11-clocks/washerdryer/pkg-comment b/x11-clocks/washerdryer/pkg-comment
new file mode 100644
index 000000000000..86a32a066423
--- /dev/null
+++ b/x11-clocks/washerdryer/pkg-comment
@@ -0,0 +1 @@
+A dockapp that keeps track of the loads in your washer and dryer
diff --git a/x11-clocks/washerdryer/pkg-descr b/x11-clocks/washerdryer/pkg-descr
new file mode 100644
index 000000000000..f4ae76bfa86e
--- /dev/null
+++ b/x11-clocks/washerdryer/pkg-descr
@@ -0,0 +1,19 @@
+[from README]
+washerDryer keeps track of the loads in your washer and
+dryer, and alerts you when they are ready.
+
+I'm bad at remembering when to take my clothes out, so I wrote
+this program to help me. Hopefully other people will find it
+useful as well.
+
+Some features are:
+
+ * Keeps track of up to 10 loads at once
+ * Alerts you with system beep, or any command you specify
+ * Fully compatible with WindowMaker as a dockapp
+ * Command line options (-h for help)
+ * Customize the program through config file, command line
+ options, or on the fly
+
+WWW: http://ieng9.ucsd.edu/~m1foley/washerDryer.html
+Author: Michael A. Foley <foley@ucsd.edu>
diff --git a/x11-clocks/washerdryer/pkg-message b/x11-clocks/washerdryer/pkg-message
new file mode 100644
index 000000000000..721f1ce8b8db
--- /dev/null
+++ b/x11-clocks/washerdryer/pkg-message
@@ -0,0 +1,10 @@
+
+
+Check manpage washerDryer(1) for more information.
+
+Example configuration file is located at:
+%%EXAMPLE%%
+
+install the edited version of the config file as ~/.wdryerrc
+
+
diff --git a/x11-clocks/washerdryer/pkg-plist b/x11-clocks/washerdryer/pkg-plist
new file mode 100644
index 000000000000..59665b14396f
--- /dev/null
+++ b/x11-clocks/washerdryer/pkg-plist
@@ -0,0 +1,3 @@
+bin/washerDryer
+%%PORTDOCS%%share/doc/washerdryer/wdryerrc.example
+%%PORTDOCS%%@dirrm share/doc/washerdryer