aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/wmfishtime/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 05:14:11 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 05:14:11 +0000
commitcdd3dcc6de6b3391ca14df1cbc13beac7a7112f4 (patch)
tree4cc19176152f7b61fd19412f043dedf5b74f4e87 /x11-clocks/wmfishtime/Makefile
parente7645e6955cac86b5df1e042ea9f5d174e8cf18e (diff)
downloadports-cdd3dcc6de6b3391ca14df1cbc13beac7a7112f4.tar.gz
ports-cdd3dcc6de6b3391ca14df1cbc13beac7a7112f4.zip
Add wmfishtime 1.1, a time/date applet for WindowMaker with fishes
swimming around. PR: 26245 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=41000
Diffstat (limited to 'x11-clocks/wmfishtime/Makefile')
-rw-r--r--x11-clocks/wmfishtime/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-clocks/wmfishtime/Makefile b/x11-clocks/wmfishtime/Makefile
new file mode 100644
index 000000000000..a371c74a2537
--- /dev/null
+++ b/x11-clocks/wmfishtime/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: wmfishtime
+# Date created: 31 March 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfishtime
+PORTVERSION= 1.1
+CATEGORIES= x11-clocks windowmaker
+MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+USE_GTK= yes
+USE_X_PREFIX= yes
+
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g; s@-O3@${CFLAGS}@g; \
+ s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmfishtime ${PREFIX}/bin
+
+.include <bsd.port.mk>