aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-10-13 10:14:55 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-10-13 10:14:55 +0000
commit1c0c41ebdf0e9f000617bdaf73e3f1ec3b341367 (patch)
tree9193b74f6020c828f8505d79cf191496d8177e9e /x11-clocks
parentae5f2c59ae9946da78f7b83f5b53f538bc8e964e (diff)
downloadports-1c0c41ebdf0e9f000617bdaf73e3f1ec3b341367.tar.gz
ports-1c0c41ebdf0e9f000617bdaf73e3f1ec3b341367.zip
- Convert theme selection menu to use OPTIONS framework
- Fix build of non default themes with clang - Remove unecessary RM PR: 193868 Submitted by: me Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=370761
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/asclock-gtk/Makefile21
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__Freeamp__beats.xpm6
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__Freeamp__hour.xpm9
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__Freeamp__minute.xpm9
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__Freeamp__second.xpm9
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__analog__led.xpm5
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__beats__led.xpm5
-rw-r--r--x11-clocks/asclock-gtk/files/patch-themes__shaped__led.xpm9
8 files changed, 68 insertions, 5 deletions
diff --git a/x11-clocks/asclock-gtk/Makefile b/x11-clocks/asclock-gtk/Makefile
index 07b9e01b579a..5b7d852ac001 100644
--- a/x11-clocks/asclock-gtk/Makefile
+++ b/x11-clocks/asclock-gtk/Makefile
@@ -21,14 +21,25 @@ HAS_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' | ${XARGS} ${RM}
+OPTIONS_SINGLE= DEFTHEME
+OPTIONS_SINGLE_DEFTHEME=FREEAMP_THEME NEWSTONE_THEME ORB_THEME \
+ STONE_THEME ANALOG_THEME BEATS_THEME CLASSIC_THEME \
+ PENGUIN_THEME SHAPED_THEME
+OPTIONS_DEFAULT= CLASSIC_THEME
+
+FREEAMP_THEME_DESC= Freeamp theme
+NEWSTONE_THEME_DESC= Newstone theme
+ORB_THEME_DESC= Orb theme
+STONE_THEME_DESC= Stone theme
+ANALOG_THEME_DESC= Analog theme
+BEATS_THEME_DESC= Beats theme
+CLASSIC_THEME_DESC= Classic theme
+PENGUIN_THEME_DESC= Penguin theme
+SHAPED_THEME_DESC= Shaped theme
-.if defined(BATCH)
do-configure:
@(cd ${WRKSRC}; \
${RM} -rf default_theme; \
- ${LN} -s themes/classic default_theme)
-.endif
+ ${LN} -s themes/${PORT_OPTIONS:M*_THEME:S/_THEME//:tl} default_theme)
.include <bsd.port.mk>
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__beats.xpm b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__beats.xpm
new file mode 100644
index 000000000000..026035a4431a
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__beats.xpm
@@ -0,0 +1,6 @@
+--- themes/Freeamp/beats.xpm.orig 1999-03-26 07:06:51 UTC
++++ themes/Freeamp/beats.xpm
+@@ -1,2 +1,2 @@
+-static char *beats_xpm[] = { NULL };
++char *beats_xpm[] = { NULL };
+
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__hour.xpm b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__hour.xpm
new file mode 100644
index 000000000000..15b838b440d4
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__hour.xpm
@@ -0,0 +1,9 @@
+--- themes/Freeamp/hour.xpm.orig 1999-03-26 07:06:57 UTC
++++ themes/Freeamp/hour.xpm
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char * hour_xpm[] = {
++char * hour_xpm[] = {
+ "5 11 3 1",
+ " c None ",
+ ". c #596b5e",
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__minute.xpm b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__minute.xpm
new file mode 100644
index 000000000000..ada2a3745948
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__minute.xpm
@@ -0,0 +1,9 @@
+--- themes/Freeamp/minute.xpm.orig 1999-03-26 07:06:58 UTC
++++ themes/Freeamp/minute.xpm
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char * minute_xpm[] = {
++char * minute_xpm[] = {
+ "5 15 3 1",
+ " c None ",
+ "+ c #596b5e",
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__second.xpm b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__second.xpm
new file mode 100644
index 000000000000..1f8e254db1c5
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__Freeamp__second.xpm
@@ -0,0 +1,9 @@
+--- themes/Freeamp/second.xpm.orig 1999-03-26 07:07:00 UTC
++++ themes/Freeamp/second.xpm
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char * second_xpm[] = {
++char * second_xpm[] = {
+ "5 20 2 1",
+ " c None ",
+ "+ c #0C110D",
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__analog__led.xpm b/x11-clocks/asclock-gtk/files/patch-themes__analog__led.xpm
new file mode 100644
index 000000000000..142993ba87f5
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__analog__led.xpm
@@ -0,0 +1,5 @@
+--- themes/analog/led.xpm.orig 2014-09-22 20:38:11 UTC
++++ themes/analog/led.xpm
+@@ -1 +1 @@
+-char *led_xpm[];
++static char *led_xpm[];
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__beats__led.xpm b/x11-clocks/asclock-gtk/files/patch-themes__beats__led.xpm
new file mode 100644
index 000000000000..64adab23d668
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__beats__led.xpm
@@ -0,0 +1,5 @@
+--- themes/beats/led.xpm.orig 1999-02-20 22:54:43 UTC
++++ themes/beats/led.xpm
+@@ -1 +1 @@
+-char *led_xpm[];
++static char *led_xpm[];
diff --git a/x11-clocks/asclock-gtk/files/patch-themes__shaped__led.xpm b/x11-clocks/asclock-gtk/files/patch-themes__shaped__led.xpm
new file mode 100644
index 000000000000..66adf9a76228
--- /dev/null
+++ b/x11-clocks/asclock-gtk/files/patch-themes__shaped__led.xpm
@@ -0,0 +1,9 @@
+--- themes/shaped/led.xpm.orig 1999-02-20 08:49:20 UTC
++++ themes/shaped/led.xpm
+@@ -1,5 +1,5 @@
+ /* XPM */
+-char * led_xpm[] = {
++static char * led_xpm[] = {
+ "135 11 3 1",
+ " c #282828",
+ "O c #00df00",