aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-keyboard
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
commitd4f0d0048a8755106a4b0445221a19761e746984 (patch)
treec87184c5bfeaf942c827c5f706186ce9786a2588 /x11-drivers/xf86-input-keyboard
parente82affd309fc2d8e5ea19b2e003f1296920bd825 (diff)
downloadports-d4f0d0048a8755106a4b0445221a19761e746984.tar.gz
ports-d4f0d0048a8755106a4b0445221a19761e746984.zip
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}. - Bump PORTREVISION for ports intalling files in ${X11BASE}.
Notes
Notes: svn path=/head/; revision=191544
Diffstat (limited to 'x11-drivers/xf86-input-keyboard')
-rw-r--r--x11-drivers/xf86-input-keyboard/Makefile19
-rw-r--r--x11-drivers/xf86-input-keyboard/distinfo3
-rw-r--r--x11-drivers/xf86-input-keyboard/files/patch-kbd.c18
-rw-r--r--x11-drivers/xf86-input-keyboard/pkg-descr4
-rw-r--r--x11-drivers/xf86-input-keyboard/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-keyboard/Makefile b/x11-drivers/xf86-input-keyboard/Makefile
new file mode 100644
index 000000000000..7c2f223e4759
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: xf86-input-keyboard
+# Date Created: 17 Feb 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf86-input-keyboard
+PORTVERSION= 1.1.1
+CATEGORIES= x11-drivers
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org keyboard input driver
+
+XORG_CAT= driver
+USE_XORG= kbproto
+MAN4= kbd.4x keyboard.4x
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-keyboard/distinfo b/x11-drivers/xf86-input-keyboard/distinfo
new file mode 100644
index 000000000000..87ec2cfc238b
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/distinfo
@@ -0,0 +1,3 @@
+MD5 (xorg/driver/xf86-input-keyboard-1.1.1.tar.bz2) = babf094e37bdfc08076d4adb4c69c1d9
+SHA256 (xorg/driver/xf86-input-keyboard-1.1.1.tar.bz2) = b7e7377d75f3a10cceb5df18019b8e4498fbed0100478edd4af75bf8cd45d6fd
+SIZE (xorg/driver/xf86-input-keyboard-1.1.1.tar.bz2) = 235022
diff --git a/x11-drivers/xf86-input-keyboard/files/patch-kbd.c b/x11-drivers/xf86-input-keyboard/files/patch-kbd.c
new file mode 100644
index 000000000000..d43b9056148b
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/files/patch-kbd.c
@@ -0,0 +1,18 @@
+--- src/kbd.c.orig Wed Nov 9 22:31:23 2005
++++ src/kbd.c Sat Oct 7 21:09:40 2006
+@@ -635,7 +635,6 @@
+ return;
+ }
+
+-#ifndef __sparc64__
+ /*
+ * PC keyboards generate separate key codes for
+ * Alt+Print and Control+Pause but in the X keyboard model
+@@ -648,7 +647,6 @@
+ else if (scanCode == KEY_Break)
+ scanCode = KEY_Pause;
+ }
+-#endif
+
+ sunKeyboards:
+ /*
diff --git a/x11-drivers/xf86-input-keyboard/pkg-descr b/x11-drivers/xf86-input-keyboard/pkg-descr
new file mode 100644
index 000000000000..032961e5144a
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/pkg-descr
@@ -0,0 +1,4 @@
+This package contains the X.Org xf86-input-keyboard driver.
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/x11-drivers/xf86-input-keyboard/pkg-plist b/x11-drivers/xf86-input-keyboard/pkg-plist
new file mode 100644
index 000000000000..32d077162789
--- /dev/null
+++ b/x11-drivers/xf86-input-keyboard/pkg-plist
@@ -0,0 +1,7 @@
+lib/xorg/modules/input/kbd_drv.la
+lib/xorg/modules/input/kbd_drv.so
+lib/xorg/modules/input/keyboard_drv.la
+lib/xorg/modules/input/keyboard_drv.so
+@dirrmtry lib/xorg/modules/input
+@dirrmtry lib/xorg/modules
+@dirrmtry lib/xorg