aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-vmmouse
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-01-23 16:28:36 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2009-01-23 16:28:36 +0000
commit340b57f8beb786be8990652b17d2e45f182346e6 (patch)
treec3e6d8718763fb6c4df9ddb40d2544e7ceccaccd /x11-drivers/xf86-input-vmmouse
parent66a81c62b92aa3373e54dc3b68238b43561f244f (diff)
downloadports-340b57f8beb786be8990652b17d2e45f182346e6.tar.gz
ports-340b57f8beb786be8990652b17d2e45f182346e6.zip
- Update X.org ports to 7.4+ (few ports are more recent than the katamari).
- Bump PORTREVISION for all ports depending on libglut since the shlib version number went from 4 to 3. - Bump PORTREVISION for all ports depending on libXaw as libXaw.so.8 isn't installed anymore. - Couple of ports fixes (mostly missing xorg components added to USE_XORG).
Notes
Notes: svn path=/head/; revision=226727
Diffstat (limited to 'x11-drivers/xf86-input-vmmouse')
-rw-r--r--x11-drivers/xf86-input-vmmouse/Makefile6
-rw-r--r--x11-drivers/xf86-input-vmmouse/distinfo6
-rw-r--r--x11-drivers/xf86-input-vmmouse/files/patch-src_vmmouse.c28
-rw-r--r--x11-drivers/xf86-input-vmmouse/pkg-plist3
4 files changed, 10 insertions, 33 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/Makefile b/x11-drivers/xf86-input-vmmouse/Makefile
index 9889986d8eb2..6a02f58a174e 100644
--- a/x11-drivers/xf86-input-vmmouse/Makefile
+++ b/x11-drivers/xf86-input-vmmouse/Makefile
@@ -6,14 +6,16 @@
#
PORTNAME= xf86-input-vmmouse
-PORTVERSION= 12.4.3
-PORTREVISION= 2
+PORTVERSION= 12.6.3
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org vmmouse input driver
XORG_CAT= driver
+CONFIGURE_ARGS= --with-hal-callouts-dir=${PREFIX}/libexec/hal/scripts
+
+MAN1= vmmouse_detect.1
MAN4= vmmouse.4x
ONLY_FOR_ARCHS= i386 amd64
diff --git a/x11-drivers/xf86-input-vmmouse/distinfo b/x11-drivers/xf86-input-vmmouse/distinfo
index 64f21f5552ff..f7fa6a5e46aa 100644
--- a/x11-drivers/xf86-input-vmmouse/distinfo
+++ b/x11-drivers/xf86-input-vmmouse/distinfo
@@ -1,3 +1,3 @@
-MD5 (xorg/driver/xf86-input-vmmouse-12.4.3.tar.bz2) = 44730af795616ed4d4a0cd9a3a07935d
-SHA256 (xorg/driver/xf86-input-vmmouse-12.4.3.tar.bz2) = d668c4cacd4be6d56608fbdf7779d60120f38f3315e6385a7cc87339124e77ab
-SIZE (xorg/driver/xf86-input-vmmouse-12.4.3.tar.bz2) = 248239
+MD5 (xorg/driver/xf86-input-vmmouse-12.6.3.tar.bz2) = f5933143d7789557983ecb527092d14e
+SHA256 (xorg/driver/xf86-input-vmmouse-12.6.3.tar.bz2) = c39fe6f2a17c8c609421ed17447221209dd416ca142d6f3d0b1052808ef7d604
+SIZE (xorg/driver/xf86-input-vmmouse-12.6.3.tar.bz2) = 252631
diff --git a/x11-drivers/xf86-input-vmmouse/files/patch-src_vmmouse.c b/x11-drivers/xf86-input-vmmouse/files/patch-src_vmmouse.c
deleted file mode 100644
index 94d61e4e9c0d..000000000000
--- a/x11-drivers/xf86-input-vmmouse/files/patch-src_vmmouse.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/vmmouse.c.orig Wed Sep 26 08:11:47 2007
-+++ src/vmmouse.c Sun Jan 20 17:10:54 2008
-@@ -964,8 +964,11 @@
- VMMOUSE_INPUT_DATA vmmouseInput;
- int ps2Buttons = 0;
- int numPackets;
-+ VMMousePrivPtr mPriv;
-+ double factorX, factorY;
-
- pMse = pInfo->private;
-+ mPriv = pMse->mousePriv;
- while((numPackets = VMMouseClient_GetInput(&vmmouseInput))){
- if (numPackets == VMMOUSE_ERROR) {
- VMMouseClient_Disable();
-@@ -990,6 +993,13 @@
- dy = vmmouseInput.Y;
- dz = (char)vmmouseInput.Z;
- dw = 0;
-+
-+ /* X server 1.4.0 does not call VMMouseConvertProc() so we scale coordinates here */
-+ factorX = ((double) screenInfo.screens[mPriv->screenNum]->width) / (double) 65535;
-+ factorY = ((double) screenInfo.screens[mPriv->screenNum]->height) / (double) 65535;
-+ dx = dx * factorX + 0.5;
-+ dy = dy * factorY + 0.5;
-+
- /* post an event */
- pMse->PostEvent(pInfo, buttons, dx, dy, dz, dw);
- }
diff --git a/x11-drivers/xf86-input-vmmouse/pkg-plist b/x11-drivers/xf86-input-vmmouse/pkg-plist
index 2a9d937472a8..d5ba6a3115a6 100644
--- a/x11-drivers/xf86-input-vmmouse/pkg-plist
+++ b/x11-drivers/xf86-input-vmmouse/pkg-plist
@@ -1,5 +1,8 @@
+bin/vmmouse_detect
+libexec/hal/scripts/hal-probe-vmmouse
lib/xorg/modules/input/vmmouse_drv.la
lib/xorg/modules/input/vmmouse_drv.so
+share/hal/fdi/policy/20thirdparty/11-x11-vmmouse.fdi
@dirrmtry lib/xorg/modules/input
@dirrmtry lib/xorg/modules
@dirrmtry lib/xorg