aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-ati
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-03-27 08:07:35 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-03-27 08:07:35 +0000
commitbb7ff0d6804cb7bf970cb0debbfc70491285029a (patch)
treeac82af8daaf0ad397707e1e6eb78da8c9bb4f1a3 /x11-drivers/xf86-video-ati
parent79bad2c31edc68c1370eff4609693eff3ec15510 (diff)
downloadports-bb7ff0d6804cb7bf970cb0debbfc70491285029a.tar.gz
ports-bb7ff0d6804cb7bf970cb0debbfc70491285029a.zip
Add a patch to UMS support
Thanks to jkim@ for pointing the patch out. Obtained from: xf86-video-ati git
Notes
Notes: svn path=/head/; revision=271831
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile1
-rw-r--r--x11-drivers/xf86-video-ati/files/patch-ums42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index b73774247f8b..9ee72e21e6e7 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xf86-video-ati
PORTVERSION= 6.14.1
+PORTREVISION= 1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-ati/files/patch-ums b/x11-drivers/xf86-video-ati/files/patch-ums
new file mode 100644
index 000000000000..854c4eb2218c
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/patch-ums
@@ -0,0 +1,42 @@
+From fe2e0ad3ffa58f40311319c950b842e2928a5740 Mon Sep 17 00:00:00 2001
+From: matthew green <mrg@eterna.com.au>
+Date: Mon, 21 Mar 2011 16:17:58 +0000
+Subject: bug fix for r6xx/r7xx UMS
+
+Signed-off-by: Alex Deucher <alexdeucher@gmail.com>
+---
+diff --git a/src/r600_exa.c b/src/r600_exa.c
+index 0ed0ced..7736d24 100644
+--- src/r600_exa.c
++++ src/r600_exa.c
+@@ -621,8 +621,12 @@ R600PrepareCopy(PixmapPtr pSrc, PixmapPtr pDst,
+ return FALSE;
+
+ if (accel_state->same_surface == TRUE) {
++#if defined(XF86DRM_MODE)
+ unsigned height = RADEON_ALIGN(pDst->drawable.height,
+ drmmode_get_height_align(pScrn, accel_state->dst_obj.tiling_flags));
++#else
++ unsigned height = pDst->drawable.height;
++#endif
+ unsigned long size = height * accel_state->dst_obj.pitch * pDst->drawable.bitsPerPixel/8;
+
+ #if defined(XF86DRM_MODE)
+diff --git a/src/radeon_textured_video.c b/src/radeon_textured_video.c
+index c886ed0..d247db6 100644
+--- src/radeon_textured_video.c
++++ src/radeon_textured_video.c
+@@ -248,7 +248,11 @@ RADEONPutImageTextured(ScrnInfoPtr pScrn,
+ BoxRec dstBox;
+ int dst_width = width, dst_height = height;
+ int aligned_height;
++#ifdef XF86DRM_MODE
+ int h_align = drmmode_get_height_align(pScrn, 0);
++#else
++ int h_align = 1;
++#endif
+ /* make the compiler happy */
+ s2offset = s3offset = srcPitch2 = 0;
+
+--
+cgit v0.8.3-6-g21f6