aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /x11-drivers
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
downloadports-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.gz
ports-4a4ec28d37b64039d4eff0f34ad66b543767d758.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Notes
Notes: svn path=/head/; revision=352986
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xorg-drivers/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11-drivers/xorg-drivers/Makefile b/x11-drivers/xorg-drivers/Makefile
index 47c291072612..be7537191b95 100644
--- a/x11-drivers/xorg-drivers/Makefile
+++ b/x11-drivers/xorg-drivers/Makefile
@@ -10,8 +10,6 @@ EXTRACT_ONLY= # none
MAINTAINER= x11@FreeBSD.org
COMMENT= X.org drivers meta-port
-.MAKE.FreeBSD_UL= yes
-
VIDEODIR= ${PREFIX}/lib/xorg/modules/drivers
INPUTDIR= ${PREFIX}/lib/xorg/modules/input
@@ -69,9 +67,9 @@ OPTIONS_DEFAULT= MOUSE \
VESA
.for type in input video
-. for a in ${${type:U}_DRIVERS}
-OPTIONS_DEFINE+= ${a:U}
-${a:U}_DESC= Install ${a} ${type} driver
+. for a in ${${type:tu}_DRIVERS}
+OPTIONS_DEFINE+= ${a:tu}
+${a:tu}_DESC= Install ${a} ${type} driver
. endfor
.endfor
@@ -106,12 +104,12 @@ VIDEO_DRIVERS+= sunffb
.endif
.for type in input video
-. for i in ${${type:U}_DRIVERS}
-. if ${PORT_OPTIONS:M${i:U}} != ""
+. for i in ${${type:tu}_DRIVERS}
+. if ${PORT_OPTIONS:M${i:tu}} != ""
. if ${QUIRKS:M${i}\:*:C/.*://} != ""
-RUN_DEPENDS+= ${${type:U}DIR}/${QUIRKS:M${i}\:*:C/.*://}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
+RUN_DEPENDS+= ${${type:tu}DIR}/${QUIRKS:M${i}\:*:C/.*://}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
. else
-RUN_DEPENDS+= ${${type:U}DIR}/${i}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
+RUN_DEPENDS+= ${${type:tu}DIR}/${i}_drv.so:${PORTSDIR}/x11-drivers/xf86-${type}-${i}
. endif
. endif
. endfor