aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-12-06 14:07:53 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-12-06 14:07:53 +0000
commit5570f85834cf808b757e3f54c9a93a60fbfaede7 (patch)
treef60d99e5bddf377d17a38e3f66acde9a28f0e18a /x11-drivers
parent4446ace568618a987531d4c764dfd3719fae6db9 (diff)
downloadports-5570f85834cf808b757e3f54c9a93a60fbfaede7.tar.gz
ports-5570f85834cf808b757e3f54c9a93a60fbfaede7.zip
Update to upstream version 0.27.0
PR: 195370 Submitted by: jbeich@vfemail.net (maintainer)
Notes
Notes: svn path=/head/; revision=374109
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile2
-rw-r--r--x11-drivers/xf86-input-wacom/distinfo4
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-tools-isdv4-serial-inputattach.c4
3 files changed, 5 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index ea1294904110..340742aaa465 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-wacom
-PORTVERSION= 0.26.1
+PORTVERSION= 0.27.0
CATEGORIES= x11-drivers
MASTER_SITES= SF/linuxwacom/${PORTNAME}
diff --git a/x11-drivers/xf86-input-wacom/distinfo b/x11-drivers/xf86-input-wacom/distinfo
index cfb92c6747a5..f49723c85921 100644
--- a/x11-drivers/xf86-input-wacom/distinfo
+++ b/x11-drivers/xf86-input-wacom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-wacom-0.26.1.tar.bz2) = 08e261185eb85ea60aa237c73fdb65360cda985198d3c252972f8230c3d194e2
-SIZE (xorg/driver/xf86-input-wacom-0.26.1.tar.bz2) = 589576
+SHA256 (xorg/driver/xf86-input-wacom-0.27.0.tar.bz2) = d1280361595f28c273d237cb234c28ca77617f875207ee0424a385a41407ec42
+SIZE (xorg/driver/xf86-input-wacom-0.27.0.tar.bz2) = 594818
diff --git a/x11-drivers/xf86-input-wacom/files/patch-tools-isdv4-serial-inputattach.c b/x11-drivers/xf86-input-wacom/files/patch-tools-isdv4-serial-inputattach.c
index 4e0deaefe6c3..d8be073bad74 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-tools-isdv4-serial-inputattach.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-tools-isdv4-serial-inputattach.c
@@ -31,13 +31,13 @@
static int bind_kernel_driver(int fd)
{
unsigned long devt;
-@@ -77,9 +85,11 @@ static int bind_kernel_driver(int fd)
+@@ -77,9 +84,11 @@ static int bind_kernel_driver(int fd)
return 0;
}
+#endif
- int get_baud_rate(int fd)
+ static int get_baud_rate(int fd)
{
+#ifdef __linux__
struct stat st;