aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2020-03-12 06:51:11 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2020-03-12 06:51:11 +0000
commit70c654f4123596d5c4e62603b3f46a870400e54e (patch)
tree78f0e2bf6ce88c46b947886ab31cde20e93d76b1 /x11-drivers
parenta680b208af9fc0a796f0313c12dfe377051c1484 (diff)
downloadports-70c654f4123596d5c4e62603b3f46a870400e54e.tar.gz
ports-70c654f4123596d5c4e62603b3f46a870400e54e.zip
x11-drivers/xorgxrdp: disable DRI3 option by default again
I tried to compile DRI3 support by default and disable by config by default [1] However, actually it cannot be disabled completely by config. Hardware acceleration in xrdp is still bleeding-edge and it sometimes causes hang-up like below. [drm] GPU HANG: ecode 7:0:0x97f4ffff, in Xorg [100659], reason: Hang on rcs0, action: reset drmn0: Resetting chip after gpu hang drmn0: Resetting chip after gpu hang drmn0: i915_reset_device timed out, cancelling all in-flight rendering. Bleeding-edge features should be opt-in and the default setup should be stable, disabling again. [1] https://gitter.im/neutrinolabs/xrdp?at=5e5e48163ca0375cb399cdfa
Notes
Notes: svn path=/head/; revision=528271
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xorgxrdp/Makefile4
-rw-r--r--x11-drivers/xorgxrdp/files/patch-xrdpdev_xorg.conf17
2 files changed, 2 insertions, 19 deletions
diff --git a/x11-drivers/xorgxrdp/Makefile b/x11-drivers/xorgxrdp/Makefile
index 6aef0763159a..870f6a2a1572 100644
--- a/x11-drivers/xorgxrdp/Makefile
+++ b/x11-drivers/xorgxrdp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xorgxrdp
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.13
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11-drivers
DIST_SUBDIR= xrdp
@@ -31,7 +31,7 @@ LIBS= -L${LOCALBASE}/lib
CONFIGURE_ENV= XRDP_CFLAGS=-I${WRKSRC_xrdp}/common
OPTIONS_DEFINE= DEBUG DRI3
-OPTIONS_DEFAULT= DRI3
+OPTIONS_DEFAULT=
DRI3_DESC= DRI3/Glamor OpenGL Support
DRI3_CONFIGURE_ENABLE= glamor
diff --git a/x11-drivers/xorgxrdp/files/patch-xrdpdev_xorg.conf b/x11-drivers/xorgxrdp/files/patch-xrdpdev_xorg.conf
deleted file mode 100644
index 53c918c041ca..000000000000
--- a/x11-drivers/xorgxrdp/files/patch-xrdpdev_xorg.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git xrdpdev/xorg.conf xrdpdev/xorg.conf
-index 8079ea8..f0d44fb 100644
---- xrdpdev/xorg.conf
-+++ xrdpdev/xorg.conf
-@@ -47,8 +47,11 @@ EndSection
- Section "Device"
- Identifier "Video Card (xrdpdev)"
- Driver "xrdpdev"
-+ # Change this to your actual path
- Option "DRMDevice" "/dev/dri/renderD128"
-- Option "DRI3" "1"
-+ # Change the below "0" to "1" to enable hardware acceleration
-+ Option "DRI3" "0"
-+ Option "DRI2" "0"
- EndSection
-
- Section "Screen"