aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-09-10 10:42:46 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-09-10 10:42:46 +0000
commit770a1c064bb48211cd84e4d9d29e8dfd5c826a55 (patch)
treea51774f40f727a3e50ab732a74db47c7625a59d1 /x11-drivers
parent8852cc12606737ee1e6a79da7afcb850658d900d (diff)
downloadports-770a1c064bb48211cd84e4d9d29e8dfd5c826a55.tar.gz
ports-770a1c064bb48211cd84e4d9d29e8dfd5c826a55.zip
Rework checks to select between UMS and KMS versions of the ati driver.
Developed with: dumbbell@ Obtained from: xorg-dev repo
Notes
Notes: svn path=/head/; revision=367808
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 017beb636ae6..94c2ad810b2b 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -14,8 +14,31 @@ USE_XORG= xf86driproto xineramaproto xf86miscproto glproto
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000051 || !defined(WITH_NEW_XORG) || \
- (${ARCH} != i386 && ${ARCH} != amd64)
+.if (${OSVERSION} >= 902508 && ${OSVERSION} < 1000000) || ${OSVERSION} >= 1000051
+# 902508: Radeon kernel driver imported in FreeBSD 9.x
+# 1000051: Radeon kernel driver imported in FreeBSD 10.x
+. if defined(WITH_NEW_XORG)
+NEW_ATI_DRIVER= yes
+. else
+NEW_ATI_DRIVER= no
+. endif
+.else
+# FreeBSD < 902508 doesn't have the Radeon kernel driver. No need to
+# check for WITH_NEW_XORG. But we do support a flag to force the usage
+# of the KMS-only DDX: this is used by the build cluster only.
+. if defined(FORCE_KMS_ONLY_DDX)
+NEW_ATI_DRIVER= yes
+. else
+NEW_ATI_DRIVER= no
+. endif
+.endif
+
+.if (${ARCH} != i386 && ${ARCH} != amd64)
+# No Radeon kernel driver on non-x86 and PC98.
+NEW_ATI_DRIVER= no
+.endif
+
+.if ${NEW_ATI_DRIVER} == no
ATI_VERSION= 6.14.6
ATI_REVISION= 3
CONFIGURE_ARGS+=--disable-kms