aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-03-27 08:33:27 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-03-27 08:33:27 +0000
commitc3af233527fff97c96882ae6f58274838f267a98 (patch)
tree878850ee542b37e6d435b88e94bc6be95c9a096d /x11-drivers
parentbaab8cbbbb111faf3688e29cc97b6a47c9796784 (diff)
downloadports-c3af233527fff97c96882ae6f58274838f267a98.tar.gz
ports-c3af233527fff97c96882ae6f58274838f267a98.zip
x11-drivers/drm-kmod: Port for the DRM kernel drivers for FreeBSD 9.3
This port allows us to provide updated DRM kernel drivers on FreeBSD 9.3. Kernel modules are suffixed with "_port" compared to the vanilla drivers (eg. i915kms.ko becomes i915kms_port.ko). The device-independent module, renamed as drm2_port.ko, is also included. However, Radeon firmwares are not: the vanilla ones are still being used. xf86-video-ati and xf86-video-intel depends on drm-kmod on FreeBSD 9.3. These ports are modified to automatically load the *_port kernel module. This initial version brings hardware context support to the i915 driver. This feature is required by Mesa 9.2+, which itself is required by xserver 1.15+. Differential Revision: https://reviews.freebsd.org/D2149 Reviewed by: kwm Approved by: kwm Tested by: Florian Degner <f.degner@gmx.de>
Notes
Notes: svn path=/head/; revision=382375
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/drm-kmod/Makefile32
-rw-r--r--x11-drivers/drm-kmod/distinfo2
-rw-r--r--x11-drivers/drm-kmod/pkg-descr3
-rw-r--r--x11-drivers/xf86-video-ati/Makefile12
-rw-r--r--x11-drivers/xf86-video-intel/Makefile12
6 files changed, 60 insertions, 2 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index 780ec9b2cbd7..05deb8690bff 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -3,6 +3,7 @@
COMMENT = X11 drivers
+ SUBDIR += drm-kmod
SUBDIR += xf86-input-acecad
SUBDIR += xf86-input-egalax
SUBDIR += xf86-input-elographics
diff --git a/x11-drivers/drm-kmod/Makefile b/x11-drivers/drm-kmod/Makefile
new file mode 100644
index 000000000000..b7975426eb0b
--- /dev/null
+++ b/x11-drivers/drm-kmod/Makefile
@@ -0,0 +1,32 @@
+# Created by: Jean-Sebastien Pedron <dumbbell@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= drm-kmod
+DISTVERSION= 9.280208
+CATEGORIES= x11-drivers
+MASTER_SITES= LOCAL/dumbbell
+DISTNAME= drm-${DISTVERSION}
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= FreeBSD 9.3 Kernel DRM driver
+
+LICENSE= MIT
+
+USES= tar:xz kmod
+ONLY_FOR_ARCHS= i386 amd64
+
+PLIST_FILES= ${KMODDIR}/drm2_port.ko \
+ ${KMODDIR}/i915kms_port.ko \
+ ${KMODDIR}/radeonkms_port.ko \
+
+.include <bsd.port.options.mk>
+
+.if (${OSVERSION} < 903000 || ${OSVERSION} > 1000000)
+IGNORE= this port is only for 9.3 systems
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
+MAKE_ARGS+=" HAVE_DEBUG=YES"
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/drm-kmod/distinfo b/x11-drivers/drm-kmod/distinfo
new file mode 100644
index 000000000000..1607aec41cfa
--- /dev/null
+++ b/x11-drivers/drm-kmod/distinfo
@@ -0,0 +1,2 @@
+SHA256 (drm-9.280208.tar.xz) = 27586b92a14b4a7596e838eaeb596ae82b53cb7807179a456bb4e5cad0c8c8b0
+SIZE (drm-9.280208.tar.xz) = 902972
diff --git a/x11-drivers/drm-kmod/pkg-descr b/x11-drivers/drm-kmod/pkg-descr
new file mode 100644
index 000000000000..31ac0d6b159a
--- /dev/null
+++ b/x11-drivers/drm-kmod/pkg-descr
@@ -0,0 +1,3 @@
+The DRM kernel driver supports Intel and Radeon GPUs.
+
+WWW: http://www.freebsd.org/
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index eee705aa4716..3f7cb4341fb5 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-video-ati
PORTVERSION= 7.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -22,4 +22,14 @@ ONLY_FOR_ARCHS= i386 amd64
CONFIGURE_ARGS+=--disable-udev
CONFIGURE_ARGS+=--disable-glamor
+.include <bsd.port.options.mk>
+
+.if (${OSVERSION} >= 903000 && ${OSVERSION} < 1000000)
+RUN_DEPENDS+= drm-kmod>=9:${PORTSDIR}/x11-drivers/drm-kmod
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"radeonkms"|"radeonkms_port"|g' \
+ ${WRKSRC}/src/radeon_kms.c
+.endif
+
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-intel/Makefile b/x11-drivers/xf86-video-intel/Makefile
index 8dcb9eb29063..06b792b22981 100644
--- a/x11-drivers/xf86-video-intel/Makefile
+++ b/x11-drivers/xf86-video-intel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xf86-video-intel
PORTVERSION= 2.21.15
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -33,4 +33,14 @@ CONFIGURE_ARGS+= --enable-sna
CONFIGURE_ARGS+= --disable-glamor
INSTALL_TARGET= install-strip
+.include <bsd.port.options.mk>
+
+.if (${OSVERSION} >= 903000 && ${OSVERSION} < 1000000)
+RUN_DEPENDS+= drm-kmod>=9:${PORTSDIR}/x11-drivers/drm-kmod
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"i915kms"|"i915kms_port"|g' \
+ ${WRKSRC}/src/intel_device.c
+.endif
+
.include <bsd.port.mk>