aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/qtfm
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-14 16:40:46 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-14 16:40:46 +0000
commit285bb643e4ff97a2f231c329776c367eed1f49c7 (patch)
treee0dff39dae6b11479782f37764d222606f7bb5d8 /x11-fm/qtfm
parent2af0a31eb614acbd04021c12d6b5cedcb25492a4 (diff)
downloadports-285bb643e4ff97a2f231c329776c367eed1f49c7.tar.gz
ports-285bb643e4ff97a2f231c329776c367eed1f49c7.zip
x11-fm/qtfm: unbreak
While here, drop maintainer per request. PR: 229959 Submitted by: fluffy
Notes
Notes: svn path=/head/; revision=477170
Diffstat (limited to 'x11-fm/qtfm')
-rw-r--r--x11-fm/qtfm/Makefile5
-rw-r--r--x11-fm/qtfm/files/patch-qtfm.pro15
-rw-r--r--x11-fm/qtfm/files/patch-src_mymodel.h28
3 files changed, 15 insertions, 33 deletions
diff --git a/x11-fm/qtfm/Makefile b/x11-fm/qtfm/Makefile
index 7be919f2bcfa..89abde08c3ec 100644
--- a/x11-fm/qtfm/Makefile
+++ b/x11-fm/qtfm/Makefile
@@ -3,16 +3,17 @@
PORTNAME= qtfm
DISTVERSION= 5.5
+PORTREEVISION= 1
CATEGORIES= x11-fm
MASTER_SITES= http://www.qtfm.org/
-MAINTAINER= lichray@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Small, lightweight file manager based on pure Qt
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build
+LIB_DEPENDS= libinotify.so:devel/libinotify
USES= dos2unix qmake qt:4
DOS2UNIX_REGEX= .*\.(h|cpp)
diff --git a/x11-fm/qtfm/files/patch-qtfm.pro b/x11-fm/qtfm/files/patch-qtfm.pro
index 9ee311ef569c..2f6e85887ff1 100644
--- a/x11-fm/qtfm/files/patch-qtfm.pro
+++ b/x11-fm/qtfm/files/patch-qtfm.pro
@@ -1,6 +1,15 @@
---- qtfm.pro.orig 2012-04-30 17:08:07.093692960 -0500
-+++ qtfm.pro 2012-04-30 17:48:49.433021364 -0500
-@@ -55,7 +55,7 @@ trans.files += translations/qtfm_da.qm \
+--- qtfm.pro.orig 2012-06-04 19:48:11.000000000 +0800
++++ qtfm.pro 2018-07-22 18:29:04.602178000 +0800
+@@ -31,7 +31,7 @@
+ CONFIG += release warn_off thread
+ RESOURCES += resources.qrc
+ QT+= network
+-LIBS += -lmagic
++LIBS += -lmagic -linotify
+
+ TARGET = qtfm
+ target.path = /usr/bin
+@@ -56,7 +56,7 @@
translations/qtfm_zh.qm \
translations/qtfm_zh_TW.qm
diff --git a/x11-fm/qtfm/files/patch-src_mymodel.h b/x11-fm/qtfm/files/patch-src_mymodel.h
deleted file mode 100644
index d5b5fd1a5baa..000000000000
--- a/x11-fm/qtfm/files/patch-src_mymodel.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/mymodel.h.orig 2012-07-11 19:01:59.919235618 -0500
-+++ src/mymodel.h 2012-07-11 19:03:41.246365243 -0500
-@@ -84,10 +84,8 @@ public:
- bool realMimeTypes;
-
- public slots:
-- void notifyChange();
-- void notifyProcess(int eventID);
-- void eventTimeout();
-- void addWatcher(myModelItem* path);
-+ void notifyChange(QString const& path);
-+ void addToWatcher(myModelItem* path);
-
- signals:
- void dragDropPaste(const QMimeData * data, QString newPath, QStringList cutList);
-@@ -116,11 +114,7 @@ private:
- QString currentRootPath;
- QFileIconProvider* iconFactory;
-
-- int inotifyFD;
-- QSocketNotifier *notifier;
-- QHash<int, QString> watchers;
-- QTimer eventTimer;
-- int lastEventID;
-+ QFileSystemWatcher *watcher;
- };
-
- #endif // MYMODEL_H