aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/tdfsb
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-10-26 11:03:27 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-10-26 11:03:27 +0000
commit9d7d426f023f81c027884c538940d0253b02f552 (patch)
tree1de9da1c74730bb693586868cb4eed803f9bb27b /x11-fm/tdfsb
parent4de77cefe0cfb3db0201a23d112448d725ff5913 (diff)
downloadports-9d7d426f023f81c027884c538940d0253b02f552.tar.gz
ports-9d7d426f023f81c027884c538940d0253b02f552.zip
Add tdfsb 0.0.9, a 3D filesystem browser.
PR: ports/84414 Submitted by: Alejandro Pulver <alejandro(at)varnet.biz>
Notes
Notes: svn path=/head/; revision=146382
Diffstat (limited to 'x11-fm/tdfsb')
-rw-r--r--x11-fm/tdfsb/Makefile52
-rw-r--r--x11-fm/tdfsb/distinfo2
-rw-r--r--x11-fm/tdfsb/pkg-descr9
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-fm/tdfsb/Makefile b/x11-fm/tdfsb/Makefile
new file mode 100644
index 000000000000..bfb6bf37eff1
--- /dev/null
+++ b/x11-fm/tdfsb/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: TDFSB
+# Date created: 31 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tdfsb
+PORTVERSION= 0.0.9
+CATEGORIES= x11-fm
+MASTER_SITES= http://www.determinate.net/webdata/data/
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= A 3D filesystem browser
+
+LIB_DEPENDS= smpeg.1:${PORTSDIR}/multimedia/smpeg
+
+USE_GL= yes
+USE_REINPLACE= yes
+USE_SDL= image sdl
+USE_X_PREFIX= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+COMPILE_SCRIPT= compile.sh
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SH} ${COMPILE_SCRIPT})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+# Dirty hack below (ripping -lm) is needed in order to build the port on
+# NVidia-infected system. Without it, it may complain on conflicting
+# libm.so versions (x11/nvidia-driver gets one via misc/compat5x port).
+# However, since libGLU.so already depends on it, we should be fine.
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
+ s|gcc|${CC}| ; s| -lm|| ; \
+ s|/usr/local|${LOCALBASE}|g ; \
+ s|/usr/X11R6|${X11BASE}|g ; \
+ s|-O2|${CFLAGS}|g' \
+ ${WRKSRC}/${COMPILE_SCRIPT}
+
+.include <bsd.port.post.mk>
diff --git a/x11-fm/tdfsb/distinfo b/x11-fm/tdfsb/distinfo
new file mode 100644
index 000000000000..b96682b6b0e5
--- /dev/null
+++ b/x11-fm/tdfsb/distinfo
@@ -0,0 +1,2 @@
+MD5 (tdfsb-0.0.9.tar.gz) = 96bf14973affe065bdb5cb7301cc7402
+SIZE (tdfsb-0.0.9.tar.gz) = 35336
diff --git a/x11-fm/tdfsb/pkg-descr b/x11-fm/tdfsb/pkg-descr
new file mode 100644
index 000000000000..09bb862524b0
--- /dev/null
+++ b/x11-fm/tdfsb/pkg-descr
@@ -0,0 +1,9 @@
+TDFSB is a "3D - Filesystem Browser". It reads directory information and
+displays them as a 3D world, so you can take a walk through your file
+system. It also reads images, MPEG and MP3 files as well as some other
+formats.
+
+It is highly recommended that you have decent (hardware-accelerated) gfx
+card, otherwise it may run very slow.
+
+WWW: http://www.determinate.net/webdata/seg/tdfsb.html