aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-10-06 13:39:36 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-10-06 13:39:36 +0000
commitfd8a932d11bdd8f99700ce2f4c91f4f4af8c6ccc (patch)
tree10c5c10ff85cfd4a171b5293199d7c312093b9d9 /x11-fm
parentb388b0890733986bd42661a2331666dd39355352 (diff)
downloadports-fd8a932d11bdd8f99700ce2f4c91f4f4af8c6ccc.tar.gz
ports-fd8a932d11bdd8f99700ce2f4c91f4f4af8c6ccc.zip
- Always enable FAM and pcre, so add them in the list of dependency.
- Fix the installation of error like this below by add graphics/netpbm in the BUILD_DEPENDS. pnmtopng: not found pngtopnm: not found pnmscale: not found [...repeat...] - Fix the ability of disable/enable xine, so you don't have to depend on xine when the xine thumbnail plugin is disable (aka WITHOUT_XINE). - Fix all of plugins/thumbnails build by add @LDFLAGS@ in each of Makefile.in's LDFLAGS. That also make xine, music stuff and etc actually work to create the thumbnails or/and do something. - A few other fixes that make it builds better. - Do not extract the CVS, now our filesystem and plist look prettier. - Add new knobs: WITH_DEBUG WITH_ECORE_MAINLOOP WITHOUT_EXTRACTOR WITHOUT_ID3 WITHOUT_VORBIS WITHOUT_XINE Didn't add knobs for dbus, gnomevfs, avi and etc because they either doesn't build or cause it crashes. As for KDE stuff like dcop and kio, I am lacking to test them so someone will have to check and test it. - Fix the plist. - Bump the PORTREVISION. Reported by: tmclaugh (can't build with plugins/thumbnails) Approved by: Anders Troback <freebsd@troback.com> (maintainer)
Notes
Notes: svn path=/head/; revision=144401
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/evidence/Makefile110
-rw-r--r--x11-fm/evidence/files/patch-src_thumbnailer_Makefile.in14
-rw-r--r--x11-fm/evidence/pkg-plist89
3 files changed, 145 insertions, 68 deletions
diff --git a/x11-fm/evidence/Makefile b/x11-fm/evidence/Makefile
index 54bd6dbc7cb1..fc3d18fc8146 100644
--- a/x11-fm/evidence/Makefile
+++ b/x11-fm/evidence/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evidence
PORTVERSION= 0.9.8
+PORTREVISION= 1
CATEGORIES= x11-fm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,32 +15,133 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= freebsd@troback.com
COMMENT= Enlightened file-manager
+BUILD_DEPENDS= pngtopnm:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
evas.1:${PORTSDIR}/graphics/evas \
edje.5:${PORTSDIR}/graphics/edje \
ecore.1:${PORTSDIR}/x11/ecore \
embryo.9:${PORTSDIR}/lang/embryo \
eet.9:${PORTSDIR}/devel/eet \
- xine.14:${PORTSDIR}/multimedia/libxine
+ pcre.0:${PORTSDIR}/devel/pcre
+USE_FAM= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
USE_GETTEXT= yes
+USE_REINPLACE= yes
USE_LIBTOOL_VER=15
-CONFIGURE_ARGS= --disable-thumbnailer-xine \
- --disable-plugin-vorbis \
- --disable-plugin-id3
+CONFIGURE_ARGS= --disable-dbus \
+ --disable-dcop \
+ --enable-ecore-ipc \
+ --enable-canvas-evas2 \
+ --disable-canvas-gnomecanvas \
+ --disable-backend-gnomevfs2 \
+ --disable-backend-kio \
+ --disable-attrs \
+ --disable-acls \
+ --enable-magic \
+ --disable-sharedmime \
+ --disable-thumbnailer-avi \
+ --disable-thumbnailer-mpeg3 \
+ --enable-plugin-ttf
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/*
+
MAN1= evidence.1
INFO= evidence
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.else
+CONFIGURE_ARGS+=--disable-debug
+.endif
+
+# WARNING: Encore main-loop is slow comparing to glib main-loop, it is one
+# of reason to use glib by default. Even though it's default in
+# the configure.
+.if defined(WITH_ECORE_MAINLOOP)
+CONFIGURE_ARGS+=--enable-ecore
+.else
+CONFIGURE_ARGS+=--disable-ecore
+.endif
+
+.if defined(WITHOUT_EXTRACTOR)
+CONFIGURE_ARGS+=--disable-plugin-extractor
+PLIST_SUB+= EXTRACTOR:="@comment "
+.else
+LIB_DEPENDS+= extractor.1:${PORTSDIR}/textproc/libextractor
+CONFIGURE_ARGS+=--enable-plugin-extractor
+PLIST_SUB+= EXTRACTOR:=""
+.endif
+
+.if defined(WITHOUT_ID3)
+CONFIGURE_ARGS+=--disable-plugin-id3
+PLIST_SUB+= ID3:="@comment "
+.else
+LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
+CONFIGURE_ARGS+=--enable-plugin-id3
+PLIST_SUB+= ID3:=""
+.endif
+
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+=--disable-plugin-vorbis
+PLIST_SUB+= VORBIS:="@comment "
+.else
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+CONFIGURE_ARGS+=--enable-plugin-vorbis
+PLIST_SUB+= VORBIS:=""
+.endif
+
+.if defined(WITHOUT_XINE)
+CONFIGURE_ARGS+=--disable-thumbnailer-xine
+PLIST_SUB+= XINE:="@comment "
+.else
+LIB_DEPENDS+= xine.14:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+=--enable-thumbnailer-xine
+PLIST_SUB+= XINE:=""
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= "Broken dependencies."
.endif
+pre-everything::
+ @${ECHO_MSG} "*****************************************************************************"
+.if !defined(WITH_DEBUG) || !defined(WITH_ECORE_MAINLOOP) || !defined(WITHOUT_EXTRACTOR) || !defined(WITHOUT_ID3) || !defined(WITHOUT_VORBIS) || !defined(WITHOUT_XINE)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+.endif
+.if !defined(WITH_DEBUG)
+ @${ECHO_MSG} "WITH_DEBUG=yes, enable debugging."
+.endif
+.if !defined(WITH_ECORE_MAINLOOP)
+ @${ECHO_MSG} "WITH_ECORE_MAINLOOP=yes, use eCore as main-loop, GLib is default and faster."
+.endif
+.if !defined(WITHOUT_EXTRACTOR)
+ @${ECHO_MSG} "WITHOUT_EXTRACTOR=yes, disable the file keywords plugin."
+.endif
+.if !defined(WITHOUT_ID3)
+ @${ECHO_MSG} "WITHOUT_ID3=yes, disable the file info plugin for mp3 files."
+.endif
+.if !defined(WITHOUT_VORBIS)
+ @${ECHO_MSG} "WITHOUT_VORBIS=yes, disable the file info plugin for vorbis (ogg) files."
+.endif
+.if !defined(WITHOUT_XINE)
+ @${ECHO_MSG} "WITHOUT_XINE=yes, disable the thumbnailer for video files."
+.endif
+ @${ECHO_MSG} "*****************************************************************************"
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|LDFLAGS = |LDFLAGS = @LDFLAGS@ |g'
+ @${REINPLACE_CMD} -e 's|-lmagic|-lmagic -lz|g ; s|"loop"|"$$loop"|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|@ecore_cflags@|$$(ECORE_CFLAGS)|g ; \
+ s|@ecore_libs@|$$(ECORE_LIBS)|g' ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.post.mk>
diff --git a/x11-fm/evidence/files/patch-src_thumbnailer_Makefile.in b/x11-fm/evidence/files/patch-src_thumbnailer_Makefile.in
new file mode 100644
index 000000000000..8c72f797d4e6
--- /dev/null
+++ b/x11-fm/evidence/files/patch-src_thumbnailer_Makefile.in
@@ -0,0 +1,14 @@
+--- src/thumbnailer/Makefile.in.orig Thu Oct 6 00:05:24 2005
++++ src/thumbnailer/Makefile.in Thu Oct 6 00:06:55 2005
+@@ -295,8 +295,10 @@
+ @BUILD_THUMBNAILER_MPEG3_TRUE@MPEG3_DIR = mpeg3
+ @BUILD_THUMBNAILER_AVIFILE_TRUE@AVIFILE_DIR = avifile
+ @BUILD_THUMBNAILER_ID3_TRUE@ID3_DIR = id3
++@BUILD_THUMBNAILER_XINE_TRUE@XINE_DIR = xine
+
+-SUBDIRS = epeg imlib_loaders ttf $(AVIFILE_DIR) $(ID3_DIR) $(MPEG3_DIR) xine
++SUBDIRS = epeg imlib_loaders ttf $(AVIFILE_DIR) $(ID3_DIR) $(MPEG3_DIR) \
++ $(XINE_DIR)
+
+ AUTOMAKE_OPTIONS = 1.4 foreign
+
diff --git a/x11-fm/evidence/pkg-plist b/x11-fm/evidence/pkg-plist
index af5ec28bc708..193b253aa440 100644
--- a/x11-fm/evidence/pkg-plist
+++ b/x11-fm/evidence/pkg-plist
@@ -51,15 +51,16 @@ lib/evidence/gui/efl/engines/tt_wholewindow.so
lib/evidence/ipc/ipc_ecore.so
lib/evidence/metadata/ape.so
lib/evidence/metadata/exif.so
+%%EXTRACTOR:%%lib/evidence/metadata/extractor.so
lib/evidence/metadata/image.so
+%%ID3:%%lib/evidence/metadata/mp3.so
lib/evidence/metadata/ttf.so
+%%VORBIS:%%lib/evidence/metadata/vorbis.so
lib/evidence/thumbnailer/epeg.so
+%%ID3:%%lib/evidence/thumbnailer/id3.so
lib/evidence/thumbnailer/imlib.so
lib/evidence/thumbnailer/ttf.so
-lib/evidence/thumbnailer/xine.so
-%%DATADIR%%/CVS/Entries
-%%DATADIR%%/CVS/Repository
-%%DATADIR%%/CVS/Root
+%%XINE:%%lib/evidence/thumbnailer/xine.so
%%DATADIR%%/README
%%DATADIR%%/azundris.png
%%DATADIR%%/evidence.handlers
@@ -94,24 +95,6 @@ lib/evidence/thumbnailer/xine.so
%%DATADIR%%/icons/LCARS/video_any.png
%%DATADIR%%/icons/Makefile
%%DATADIR%%/icons/README
-%%DATADIR%%/icons/default/README
-%%DATADIR%%/icons/default/app-executable.png
-%%DATADIR%%/icons/default/audio-default.png
-%%DATADIR%%/icons/default/base.png
-%%DATADIR%%/icons/default/cdrom-open.png
-%%DATADIR%%/icons/default/config.png
-%%DATADIR%%/icons/default/cvs.png
-%%DATADIR%%/icons/default/doc-unknown.png
-%%DATADIR%%/icons/default/floppy.png
-%%DATADIR%%/icons/default/folder.png
-%%DATADIR%%/icons/default/folder.xcf
-%%DATADIR%%/icons/default/font-default.png
-%%DATADIR%%/icons/default/img-default.png
-%%DATADIR%%/icons/default/mime.icons
-%%DATADIR%%/icons/default/package.png
-%%DATADIR%%/icons/default/parent.png
-%%DATADIR%%/icons/default/text-default.png
-%%DATADIR%%/icons/default/video-default.png
%%DATADIR%%/icons/default
%%DATADIR%%/icons/efm/.cvsignore
%%DATADIR%%/icons/efm/.icons/.0.db
@@ -220,48 +203,51 @@ lib/evidence/thumbnailer/xine.so
%%DATADIR%%/icons/tosh_128/sys_ql.png
%%DATADIR%%/icons/tosh_128/video_any.png
%%DATADIR%%/icons/tosh_64/README.64
+%%DATADIR%%/icons/tosh_64/Readme.png
%%DATADIR%%/icons/tosh_64/_doc_html.png
%%DATADIR%%/icons/tosh_64/_doc_unknown.png
%%DATADIR%%/icons/tosh_64/_folder.png
%%DATADIR%%/icons/tosh_64/_parent-folder.png
%%DATADIR%%/icons/tosh_64/_selection.png
+%%DATADIR%%/icons/tosh_64/app_c_header.png
+%%DATADIR%%/icons/tosh_64/app_c_source.png
+%%DATADIR%%/icons/tosh_64/app_cc_source.png
+%%DATADIR%%/icons/tosh_64/app_executable.png
+%%DATADIR%%/icons/tosh_64/app_package.png
%%DATADIR%%/icons/tosh_64/create
+%%DATADIR%%/icons/tosh_64/dev.png
+%%DATADIR%%/icons/tosh_64/doc_any.png
+%%DATADIR%%/icons/tosh_64/doc_audio.png
+%%DATADIR%%/icons/tosh_64/doc_core.png
%%DATADIR%%/icons/tosh_64/doc_html.png
+%%DATADIR%%/icons/tosh_64/doc_image.png
+%%DATADIR%%/icons/tosh_64/doc_playlist.png
+%%DATADIR%%/icons/tosh_64/doc_text.png
%%DATADIR%%/icons/tosh_64/doc_unknown.png
%%DATADIR%%/icons/tosh_64/folder.png
+%%DATADIR%%/icons/tosh_64/font_any.png
+%%DATADIR%%/icons/tosh_64/home_azundris.png
+%%DATADIR%%/icons/tosh_64/mail.png
%%DATADIR%%/icons/tosh_64/mime.icons
%%DATADIR%%/icons/tosh_64/parent-folder.png
%%DATADIR%%/icons/tosh_64/selection.png
+%%DATADIR%%/icons/tosh_64/sys_enterprise.png
+%%DATADIR%%/icons/tosh_64/sys_pc.png
+%%DATADIR%%/icons/tosh_64/sys_ql.png
+%%DATADIR%%/icons/tosh_64/video_any.png
%%DATADIR%%/mime.alii
%%DATADIR%%/mime.handlers
%%DATADIR%%/mime.icons
%%DATADIR%%/mime.types
%%DATADIR%%/parent-folder.png
-%%DATADIR%%/themes/LCARS/CVS/Entries
-%%DATADIR%%/themes/LCARS/CVS/Repository
-%%DATADIR%%/themes/LCARS/CVS/Root
%%DATADIR%%/themes/LCARS/background.jpg
%%DATADIR%%/themes/LCARS/background_.jpg
%%DATADIR%%/themes/LCARS/evidence.theme
-%%DATADIR%%/themes/default/CVS/Entries
-%%DATADIR%%/themes/default/CVS/Repository
-%%DATADIR%%/themes/default/CVS/Root
-%%DATADIR%%/themes/default/Phusion9_purple.jpg
-%%DATADIR%%/themes/default/Phusion9_purple_orig.jpg
-%%DATADIR%%/themes/default/README
-%%DATADIR%%/themes/default/about.jpg
-%%DATADIR%%/themes/default/evidence.theme
%%DATADIR%%/themes/default
-%%DATADIR%%/themes/efm/CVS/Entries
-%%DATADIR%%/themes/efm/CVS/Repository
-%%DATADIR%%/themes/efm/CVS/Root
%%DATADIR%%/themes/efm/about.png
%%DATADIR%%/themes/efm/desk.png
%%DATADIR%%/themes/efm/efm.png
%%DATADIR%%/themes/efm/evidence.theme
-%%DATADIR%%/themes/fishtank/CVS/Entries
-%%DATADIR%%/themes/fishtank/CVS/Repository
-%%DATADIR%%/themes/fishtank/CVS/Root
%%DATADIR%%/themes/fishtank/README
%%DATADIR%%/themes/fishtank/about.png
%%DATADIR%%/themes/fishtank/bubble1.png
@@ -276,9 +262,6 @@ lib/evidence/thumbnailer/xine.so
%%DATADIR%%/themes/fishtank/work/bubble3.png
%%DATADIR%%/themes/fishtank/work/bubble4.png
%%DATADIR%%/themes/fonts/COPYRIGHT.Vera
-%%DATADIR%%/themes/fonts/CVS/Entries
-%%DATADIR%%/themes/fonts/CVS/Repository
-%%DATADIR%%/themes/fonts/CVS/Root
%%DATADIR%%/themes/fonts/Federation_Crille.ttf
%%DATADIR%%/themes/fonts/Federation_classic_movie.ttf
%%DATADIR%%/themes/fonts/LICENSE.Vera
@@ -291,54 +274,33 @@ lib/evidence/thumbnailer/xine.so
%%DATADIR%%/themes/fonts/veramono.ttf
%%DATADIR%%/themes/fonts/verase.ttf
%%DATADIR%%/themes/fonts/xfiles.ttf
-%%DATADIR%%/themes/metallo/CVS/Entries
-%%DATADIR%%/themes/metallo/CVS/Repository
-%%DATADIR%%/themes/metallo/CVS/Root
%%DATADIR%%/themes/metallo/README
%%DATADIR%%/themes/metallo/about.jpg
%%DATADIR%%/themes/metallo/evidence.theme
%%DATADIR%%/themes/metallo/metallo.bg.db
%%DATADIR%%/themes/metallo/metallo.png
-%%DATADIR%%/themes/nautilus/CVS/Entries
-%%DATADIR%%/themes/nautilus/CVS/Repository
-%%DATADIR%%/themes/nautilus/CVS/Root
%%DATADIR%%/themes/nautilus/about.png
%%DATADIR%%/themes/nautilus/beige.png
%%DATADIR%%/themes/nautilus/evidence.theme
-%%DATADIR%%/themes/rephormed/CVS/Entries
-%%DATADIR%%/themes/rephormed/CVS/Repository
-%%DATADIR%%/themes/rephormed/CVS/Root
%%DATADIR%%/themes/rephormed/about.jpg
%%DATADIR%%/themes/rephormed/evidence.theme
%%DATADIR%%/themes/rephormed/grey.png
%%DATADIR%%/themes/rephormed/plain.png
%%DATADIR%%/themes/rephormed/red.png
%%DATADIR%%/themes/rephormed/white.png
-%%DATADIR%%/themes/tosh/CVS/Entries
-%%DATADIR%%/themes/tosh/CVS/Repository
-%%DATADIR%%/themes/tosh/CVS/Root
%%DATADIR%%/themes/tosh/Phusion9_purple.jpg
%%DATADIR%%/themes/tosh/Phusion9_purple_orig.jpg
%%DATADIR%%/themes/tosh/README
%%DATADIR%%/themes/tosh/about.jpg
%%DATADIR%%/themes/tosh/evidence.theme
-@dirrm %%DATADIR%%/themes/tosh/CVS
@dirrm %%DATADIR%%/themes/tosh
-@dirrm %%DATADIR%%/themes/rephormed/CVS
@dirrm %%DATADIR%%/themes/rephormed
-@dirrm %%DATADIR%%/themes/nautilus/CVS
@dirrm %%DATADIR%%/themes/nautilus
-@dirrm %%DATADIR%%/themes/metallo/CVS
@dirrm %%DATADIR%%/themes/metallo
-@dirrm %%DATADIR%%/themes/fonts/CVS
@dirrm %%DATADIR%%/themes/fonts
@dirrm %%DATADIR%%/themes/fishtank/work
-@dirrm %%DATADIR%%/themes/fishtank/CVS
@dirrm %%DATADIR%%/themes/fishtank
-@dirrm %%DATADIR%%/themes/efm/CVS
@dirrm %%DATADIR%%/themes/efm
-@dirrm %%DATADIR%%/themes/default/CVS
-@dirrm %%DATADIR%%/themes/LCARS/CVS
@dirrm %%DATADIR%%/themes/LCARS
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/icons/tosh_64
@@ -351,7 +313,6 @@ lib/evidence/thumbnailer/xine.so
@dirrm %%DATADIR%%/icons/efm
@dirrm %%DATADIR%%/icons/LCARS
@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%/CVS
@dirrm %%DATADIR%%
@dirrm lib/evidence/thumbnailer
@dirrm lib/evidence/metadata