aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fcft
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-20 16:54:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-20 16:54:11 +0000
commite0c0a5636d4827c7b680fc6eb46360c7652aad21 (patch)
treebbe4477d32981d276d26513c5df5b3328477eca5 /x11-fonts/fcft
parent9b3950b82cf39acafeef2b780c74a83351ed3697 (diff)
downloadports-e0c0a5636d4827c7b680fc6eb46360c7652aad21.tar.gz
ports-e0c0a5636d4827c7b680fc6eb46360c7652aad21.zip
x11/fuzzel: add new port
Fuzzel is a Wayland-native application launcher, similar to rofi's 'drun' mode. Features: - Wayland native - Rofi drun-like mode of operation - dmenu mode where newline separated entries are read from stdin - Emacs key bindings - Icons! - Remembers frequently launched applications https://codeberg.org/dnkl/fuzzel
Notes
Notes: svn path=/head/; revision=558757
Diffstat (limited to 'x11-fonts/fcft')
-rw-r--r--x11-fonts/fcft/Makefile31
-rw-r--r--x11-fonts/fcft/distinfo3
-rw-r--r--x11-fonts/fcft/pkg-descr14
-rw-r--r--x11-fonts/fcft/pkg-plist16
4 files changed, 64 insertions, 0 deletions
diff --git a/x11-fonts/fcft/Makefile b/x11-fonts/fcft/Makefile
new file mode 100644
index 000000000000..bac263796d8f
--- /dev/null
+++ b/x11-fonts/fcft/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= fcft
+DISTVERSION= 2.3.2
+CATEGORIES= x11-fonts
+MASTER_SITES= https://codeberg.org/dnkl/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Simple library for font loading and glyph rasterization
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= tllist>=1.0.1:devel/tllist \
+ scdoc:textproc/scdoc
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= compiler:c11 meson pkgconfig xorg
+USE_LDCONFIG= yes
+USE_XORG= pixman
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS_DEFINE= HARFBUZZ
+OPTIONS_DEFAULT=HARFBUZZ
+
+HARFBUZZ_DESC= HarfBuzz for text shaping
+HARFBUZZ_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
+HARFBUZZ_MESON_ENABLED= text-shaping
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/fcft/distinfo b/x11-fonts/fcft/distinfo
new file mode 100644
index 000000000000..862608255a98
--- /dev/null
+++ b/x11-fonts/fcft/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608296676
+SHA256 (fcft-2.3.2.tar.gz) = 726fdebb1d29bc40c665015666fd9037981c0b4d0ba3ecafa1994053091e7fa8
+SIZE (fcft-2.3.2.tar.gz) = 313133
diff --git a/x11-fonts/fcft/pkg-descr b/x11-fonts/fcft/pkg-descr
new file mode 100644
index 000000000000..dde1831fbd9c
--- /dev/null
+++ b/x11-fonts/fcft/pkg-descr
@@ -0,0 +1,14 @@
+fcft is a small font loading and glyph rasterization library built
+on-top of FontConfig, FreeType2 and pixman.
+
+It can load and cache fonts from a fontconfig-formatted name string,
+e.g. "Monospace:size=12", optionally with user configured fallback fonts.
+
+After a font has been loaded, you can rasterize glyphs. When doing so,
+the primary font is first considered. If it does not have the
+requested glyph, the user configured fallback fonts (if any) are
+considered. If none of the user configured fallback fonts has the
+requested glyph, the FontConfig generated list of fallback fonts are
+checked.
+
+WWW: https://codeberg.org/dnkl/fcft
diff --git a/x11-fonts/fcft/pkg-plist b/x11-fonts/fcft/pkg-plist
new file mode 100644
index 000000000000..be171b0ed80f
--- /dev/null
+++ b/x11-fonts/fcft/pkg-plist
@@ -0,0 +1,16 @@
+include/fcft/fcft.h
+include/fcft/stride.h
+lib/libfcft.so
+lib/libfcft.so.3
+lib/libfcft.so.3.3.1
+libdata/pkgconfig/fcft.pc
+man/man3/fcft_capabilities.3.gz
+man/man3/fcft_clone.3.gz
+man/man3/fcft_destroy.3.gz
+man/man3/fcft_from_name.3.gz
+man/man3/fcft_glyph_rasterize.3.gz
+man/man3/fcft_grapheme_rasterize.3.gz
+man/man3/fcft_kerning.3.gz
+man/man3/fcft_precompose.3.gz
+man/man3/fcft_set_scaling_filter.3.gz
+man/man3/fcft_size_adjust.3.gz