aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fira
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-20 20:21:50 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-20 20:21:50 +0000
commitc8e1c36fe7d1905c22808c2e703f189404492df2 (patch)
tree4705eba4320cd7376bb0b2c0af7154d7a5751679 /x11-fonts/fira
parent201ac52da018b315e82b6ff929cd2cb8b2dcef23 (diff)
downloadports-c8e1c36fe7d1905c22808c2e703f189404492df2.tar.gz
ports-c8e1c36fe7d1905c22808c2e703f189404492df2.zip
The Fira font family was designed to cover the legibility needs for a
large range of handsets varying in screen quality and rendering. It comes in a Sans Serif with 4 weights (light, regular, medium and bold) all accompanied by italic styles. The package also includes a Mono Spaced variant with 2 weights (regular and bold). Available formats: Open Type, True Type WWW: http://mozilla.github.io/Fira/ PR: ports/182414 Submitted by: horia
Notes
Notes: svn path=/head/; revision=340463
Diffstat (limited to 'x11-fonts/fira')
-rw-r--r--x11-fonts/fira/Makefile49
-rw-r--r--x11-fonts/fira/distinfo2
-rw-r--r--x11-fonts/fira/files/pkg-message.in18
-rw-r--r--x11-fonts/fira/fonts.scale1
-rw-r--r--x11-fonts/fira/pkg-descr9
-rw-r--r--x11-fonts/fira/pkg-plist29
6 files changed, 108 insertions, 0 deletions
diff --git a/x11-fonts/fira/Makefile b/x11-fonts/fira/Makefile
new file mode 100644
index 000000000000..edf1d24a4b3b
--- /dev/null
+++ b/x11-fonts/fira/Makefile
@@ -0,0 +1,49 @@
+# Created by: Horia Racoviceanu <horia@racoviceanu.com>
+# $FreeBSD$
+
+PORTNAME= fira
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+
+MAINTAINER= horia@racoviceanu.com
+COMMENT= Sans-serif and monospaced typeface for small screens
+
+LICENSE= OFL
+LICENSE_NAME= SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GITHUB= yes
+GH_ACCOUNT= mozilla
+GH_PROJECT= Fira
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 705ffff
+
+USE_XORG= x11
+FONTLIBPATH= lib/X11/fonts
+FONTROOTDIR= ${PREFIX}/${FONTLIBPATH}
+FONTDIR= ${FONTROOTDIR}/${PORTNAME}
+NO_BUILD= yes
+
+SUB_LIST= FONTDIR="${FONTDIR}"
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ttf/${GH_PROJECT}*.ttf ${STAGEDIR}${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/otf/${GH_PROJECT}*.otf ${STAGEDIR}${FONTDIR}
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/fira/distinfo b/x11-fonts/fira/distinfo
new file mode 100644
index 000000000000..0a0c7df79646
--- /dev/null
+++ b/x11-fonts/fira/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fira-1.0.tar.gz) = f87bd7d1380e5a93a3743edd3d038b44c7460ea14c204b152b750f5551fd2531
+SIZE (fira-1.0.tar.gz) = 3973356
diff --git a/x11-fonts/fira/files/pkg-message.in b/x11-fonts/fira/files/pkg-message.in
new file mode 100644
index 000000000000..818944d500ec
--- /dev/null
+++ b/x11-fonts/fira/files/pkg-message.in
@@ -0,0 +1,18 @@
+===============================================================================
+
+Fira has been installed.
+
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of your X Windows configuration file:
+
+ Load "freetype"
+
+Add the following line to the "Files" section of X Windows configuration file:
+
+ FontPath "%%FONTDIR%%/"
+
+Note: your X Windows configuration file is typically /etc/X11/xorg.conf
+
+For Web Font please use www/fira-webfont port.
+
+===============================================================================
diff --git a/x11-fonts/fira/fonts.scale b/x11-fonts/fira/fonts.scale
new file mode 100644
index 000000000000..573541ac9702
--- /dev/null
+++ b/x11-fonts/fira/fonts.scale
@@ -0,0 +1 @@
+0
diff --git a/x11-fonts/fira/pkg-descr b/x11-fonts/fira/pkg-descr
new file mode 100644
index 000000000000..36ca448fe5eb
--- /dev/null
+++ b/x11-fonts/fira/pkg-descr
@@ -0,0 +1,9 @@
+The Fira font family was designed to cover the legibility needs for a
+large range of handsets varying in screen quality and rendering. It
+comes in a Sans Serif with 4 weights (light, regular, medium and bold)
+all accompanied by italic styles. The package also includes a Mono
+Spaced variant with 2 weights (regular and bold).
+
+Available formats: Open Type, True Type
+
+WWW: http://mozilla.github.io/Fira/
diff --git a/x11-fonts/fira/pkg-plist b/x11-fonts/fira/pkg-plist
new file mode 100644
index 000000000000..de426a6147f1
--- /dev/null
+++ b/x11-fonts/fira/pkg-plist
@@ -0,0 +1,29 @@
+%%FONTDIR%%/FiraMono-Bold.ttf
+%%FONTDIR%%/FiraMono-Regular.ttf
+%%FONTDIR%%/FiraMonoOT-Bold.otf
+%%FONTDIR%%/FiraMonoOT-Regular.otf
+%%FONTDIR%%/FiraSans-Bold.ttf
+%%FONTDIR%%/FiraSans-BoldItalic.ttf
+%%FONTDIR%%/FiraSans-Light.ttf
+%%FONTDIR%%/FiraSans-LightItalic.ttf
+%%FONTDIR%%/FiraSans-Medium.ttf
+%%FONTDIR%%/FiraSans-MediumItalic.ttf
+%%FONTDIR%%/FiraSans-Regular.ttf
+%%FONTDIR%%/FiraSans-RegularItalic.ttf
+%%FONTDIR%%/FiraSansOT-Bold.otf
+%%FONTDIR%%/FiraSansOT-BoldItalic.otf
+%%FONTDIR%%/FiraSansOT-Light.otf
+%%FONTDIR%%/FiraSansOT-LightItalic.otf
+%%FONTDIR%%/FiraSansOT-Medium.otf
+%%FONTDIR%%/FiraSansOT-MediumItalic.otf
+%%FONTDIR%%/FiraSansOT-Regular.otf
+%%FONTDIR%%/FiraSansOT-RegularItalic.otf
+@exec fc-cache -s -v %D/%%FONTDIR%% 2>/dev/null || true
+@exec mkfontscale %D/%%FONTDIR%% 2>/dev/null || true
+@unexec mkfontscale %D/%%FONTDIR%% 2>/dev/null || true
+@unexec if [ -e %D/%%FONTDIR%%/fonts.scale -a "`stat -f '%%z' %D/%%FONTDIR%%/fonts.scale 2>/dev/null`" = '2' ]; then rm %D/%%FONTDIR%%/fonts.scale; fi
+@exec mkfontdir %D/%%FONTDIR%% 2>/dev/null || true
+@unexec mkfontdir %D/%%FONTDIR%% 2>/dev/null || true
+@unexec if [ -e %D/%%FONTDIR%%/fonts.dir -a "`stat -f '%%z' %D/%%FONTDIR%%/fonts.dir 2>/dev/null`" = '2' ]; then rm %D/%%FONTDIR%%/fonts.dir; fi
+@dirrm %%FONTDIR%%
+@unexec fc-cache -s -v %D/%%FONTDIR%% 2>/dev/null || true