aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/font-manager/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-16 09:37:21 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-16 09:37:21 +0000
commit7d7ec9f4e1777775cd882b1ba1f40ed5cb8673ee (patch)
tree491d3dccce06c078625ebacaf2ce1eefc49117fa /x11-fonts/font-manager/Makefile
parentb9261db97e4f62e5fbcc6b3ac9c9f3a80e67f3b6 (diff)
downloadports-7d7ec9f4e1777775cd882b1ba1f40ed5cb8673ee.tar.gz
ports-7d7ec9f4e1777775cd882b1ba1f40ed5cb8673ee.zip
- Stage support
- New LIB_DEPENDS syntax - Use OPTIONS helpers - Remove reference to deprecated NOPORTDATA
Notes
Notes: svn path=/head/; revision=344509
Diffstat (limited to 'x11-fonts/font-manager/Makefile')
-rw-r--r--x11-fonts/font-manager/Makefile33
1 files changed, 11 insertions, 22 deletions
diff --git a/x11-fonts/font-manager/Makefile b/x11-fonts/font-manager/Makefile
index 0a048444651f..00396993f96c 100644
--- a/x11-fonts/font-manager/Makefile
+++ b/x11-fonts/font-manager/Makefile
@@ -8,9 +8,12 @@ CATEGORIES= x11-fonts gnome
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= lichray@gmail.com
-COMMENT= A font management application for the GNOME desktop
+COMMENT= Font management application for the GNOME desktop
-LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
@@ -20,30 +23,16 @@ USE_GNOME= pygtk2
GNU_CONFIGURE= yes
USES= gmake pkgconfig
-LICENSE_FILE= ${WRKSRC}/COPYING
PORTDATA= *
OPTIONS_DEFINE= REPORTLAB NLS
REPORTLAB_DESC= Enable font-sampler (PDF sample sheet)
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if defined(NOPORTDATA)
-IGNORE= port data is source code, undefine NOPORTDATA
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MREPORTLAB}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/reportlab/:${PORTSDIR}/print/py-reportlab2
-.endif
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+REPORTLAB_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/reportlab/:${PORTSDIR}/print/py-reportlab2
.include <bsd.port.mk>