aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/victor-mono-ttf/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-12 16:09:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-12 16:09:17 +0000
commit24f33c198452cdcf56b73287e5289560708aafc1 (patch)
tree896fa42f7a2a28a4737983455d79bc92ec80853a /x11-fonts/victor-mono-ttf/Makefile
parentf537976e184e7c469883551d026f2e49fa61109b (diff)
downloadports-24f33c198452cdcf56b73287e5289560708aafc1.tar.gz
ports-24f33c198452cdcf56b73287e5289560708aafc1.zip
Add victor-mono-ttf 1.3.0
Victor Mono is a free programming font with optional semi-connected cursive italics, symbol ligatures (!=, ->>, =>, ===, <=, >=, ++) and Latin, Cyrillic and Greek characters. The typeface is clean, crisp and narrow, with a large x-height and clear punctuation, making it legible and ideal for code. It comes in seven weights, and is available in Roman, Italic and Oblique. WWW: https://rubjo.github.io/victor-mono/ PR: 242776 Submitted by: Lewis Cook <vulcan@wired.sh>
Notes
Notes: svn path=/head/; revision=522818
Diffstat (limited to 'x11-fonts/victor-mono-ttf/Makefile')
-rw-r--r--x11-fonts/victor-mono-ttf/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-fonts/victor-mono-ttf/Makefile b/x11-fonts/victor-mono-ttf/Makefile
new file mode 100644
index 000000000000..ce8137e820ca
--- /dev/null
+++ b/x11-fonts/victor-mono-ttf/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= victor-mono
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0
+CATEGORIES= x11-fonts
+MASTER_SITES= https://rubjo.github.io/${PORTNAME}/
+PKGNAMESUFFIX= -ttf
+DISTNAME= VictorMonoAll
+
+MAINTAINER= vulcan@wired.sh
+COMMENT= Programming font with cursive italics and ligatures
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= fonts zip
+FONTNAME= VictorMono
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TTF/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>