aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/webfonts/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 12:14:18 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 12:14:18 +0000
commita80f0bd0dd7d4db692d81c1f2fe73f117828db0d (patch)
treee1ba2085cc7146328f30ef47d6e9941c2e1d05c3 /x11-fonts/webfonts/Makefile
parent4adc5a8a717b83cd9a139cd4c92ea01102d602e2 (diff)
downloadports-a80f0bd0dd7d4db692d81c1f2fe73f117828db0d.tar.gz
ports-a80f0bd0dd7d4db692d81c1f2fe73f117828db0d.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Notes
Notes: svn path=/head/; revision=53961
Diffstat (limited to 'x11-fonts/webfonts/Makefile')
-rw-r--r--x11-fonts/webfonts/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-fonts/webfonts/Makefile b/x11-fonts/webfonts/Makefile
index cf509a852666..87719d3e8efe 100644
--- a/x11-fonts/webfonts/Makefile
+++ b/x11-fonts/webfonts/Makefile
@@ -153,11 +153,11 @@ make-fonts.alias:
[ -t 0 ] && tty=/dev/tty || tty=/dev/null; \
${TAIL} +2 ${WRKSRC}/fonts.scale | ${CUT} -f 2- -d" " | \
while read font; do \
- ${ECHO} \"$${font}\" \"$${font}\"; \
+ ${ECHO_CMD} \"$${font}\" \"$${font}\"; \
for nsize in ${FONTSIZES}; do \
tsize=$${nsize}; \
[ $${tsize} -lt ${FONTLIMIT} ] && tsize=${FONTLIMIT}; \
- ${ECHO} \"$${font}\" \"$${font}\" | \
+ ${ECHO_CMD} \"$${font}\" \"$${font}\" | \
${SED} -e "s,--0-0-0-0-,--$${nsize}-$${nsize}0-0-0-," \
-e "s,--0-0-0-0-,--$${tsize}-$${tsize}0-75-75-," \
-e "s,^\"-${FONTNAME},\"-netscape,"; \