aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-11-02 12:52:55 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-11-02 12:52:55 +0000
commit8fcb4ae626f3b710012bf7f7a2f03adc19ed54e7 (patch)
tree456aa427b3c66b2650ad276f064024238209fadd /x11-fonts
parent9f58a4666d6b8da4fe811f48611bc13cf029cb46 (diff)
downloadports-8fcb4ae626f3b710012bf7f7a2f03adc19ed54e7.tar.gz
ports-8fcb4ae626f3b710012bf7f7a2f03adc19ed54e7.zip
x11-fonts/xorg-fonts-*: Simplify RUN_DEPENDS
It's better to require packages instead of files here. Also, this allows us to remove the local variable which is no longer used (FONTDIR). Reported by: mat Reviewed by: bapt Approved by: x11 (bapt) Differential Revision: https://reviews.freebsd.org/D27053
Notes
Notes: svn path=/head/; revision=553901
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/xorg-fonts-100dpi/Makefile14
-rw-r--r--x11-fonts/xorg-fonts-75dpi/Makefile14
-rw-r--r--x11-fonts/xorg-fonts-cyrillic/Makefile12
-rw-r--r--x11-fonts/xorg-fonts-miscbitmaps/Makefile28
-rw-r--r--x11-fonts/xorg-fonts-truetype/Makefile12
-rw-r--r--x11-fonts/xorg-fonts-type1/Makefile14
6 files changed, 41 insertions, 53 deletions
diff --git a/x11-fonts/xorg-fonts-100dpi/Makefile b/x11-fonts/xorg-fonts-100dpi/Makefile
index a79433c4ffd1..f6f554bc74d0 100644
--- a/x11-fonts/xorg-fonts-100dpi/Makefile
+++ b/x11-fonts/xorg-fonts-100dpi/Makefile
@@ -8,15 +8,13 @@ CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org 100dpi bitmap fonts
-RUN_DEPENDS= ${FONTDIR}/100dpi/courB08.pcf.gz:x11-fonts/font-adobe-100dpi \
- ${FONTDIR}/100dpi/UTBI__10.pcf.gz:x11-fonts/font-adobe-utopia-100dpi \
- ${FONTDIR}/100dpi/luBIS08.pcf.gz:x11-fonts/font-bh-100dpi \
- ${FONTDIR}/100dpi/lutBS08.pcf.gz:x11-fonts/font-bh-lucidatypewriter-100dpi \
- ${FONTDIR}/100dpi/charB08.pcf.gz:x11-fonts/font-bitstream-100dpi \
- ${FONTDIR}/encodings/encodings.dir:x11-fonts/encodings
+RUN_DEPENDS= font-adobe-100dpi>0:x11-fonts/font-adobe-100dpi \
+ font-adobe-utopia-100dpi>0:x11-fonts/font-adobe-utopia-100dpi \
+ font-bh-100dpi>0:x11-fonts/font-bh-100dpi \
+ font-bh-lucidatypewriter-100dpi>0:x11-fonts/font-bh-lucidatypewriter-100dpi \
+ font-bitstream-100dpi>0:x11-fonts/font-bitstream-100dpi \
+ encodings>0:x11-fonts/encodings
USES= metaport
-FONTDIR= ${LOCALBASE}/share/fonts
-
.include <bsd.port.mk>
diff --git a/x11-fonts/xorg-fonts-75dpi/Makefile b/x11-fonts/xorg-fonts-75dpi/Makefile
index 626643eb3fd6..4293eaba2763 100644
--- a/x11-fonts/xorg-fonts-75dpi/Makefile
+++ b/x11-fonts/xorg-fonts-75dpi/Makefile
@@ -8,15 +8,13 @@ CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org 75dpi bitmap fonts
-RUN_DEPENDS= ${FONTDIR}/75dpi/courB08.pcf.gz:x11-fonts/font-adobe-75dpi \
- ${FONTDIR}/75dpi/UTBI__10.pcf.gz:x11-fonts/font-adobe-utopia-75dpi \
- ${FONTDIR}/75dpi/luBIS08.pcf.gz:x11-fonts/font-bh-75dpi \
- ${FONTDIR}/75dpi/lutBS08.pcf.gz:x11-fonts/font-bh-lucidatypewriter-75dpi \
- ${FONTDIR}/75dpi/charB08.pcf.gz:x11-fonts/font-bitstream-75dpi \
- ${FONTDIR}/encodings/encodings.dir:x11-fonts/encodings
+RUN_DEPENDS= font-adobe-75dpi>0:x11-fonts/font-adobe-75dpi \
+ font-adobe-utopia-75dpi>0:x11-fonts/font-adobe-utopia-75dpi \
+ font-bh-75dpi>0:x11-fonts/font-bh-75dpi \
+ font-bh-lucidatypewriter-75dpi>0:x11-fonts/font-bh-lucidatypewriter-75dpi \
+ font-bitstream-75dpi>0:x11-fonts/font-bitstream-75dpi \
+ encodings>0:x11-fonts/encodings
USES= metaport
-FONTDIR= ${LOCALBASE}/share/fonts
-
.include <bsd.port.mk>
diff --git a/x11-fonts/xorg-fonts-cyrillic/Makefile b/x11-fonts/xorg-fonts-cyrillic/Makefile
index 4f6f67cf5c06..dd4b598781a8 100644
--- a/x11-fonts/xorg-fonts-cyrillic/Makefile
+++ b/x11-fonts/xorg-fonts-cyrillic/Makefile
@@ -8,14 +8,12 @@ CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org Cyrillic bitmap fonts
-RUN_DEPENDS= ${FONTDIR}/cyrillic/crox1c.pcf.gz:x11-fonts/font-cronyx-cyrillic \
- ${FONTDIR}/cyrillic/koi12x24.pcf.gz:x11-fonts/font-misc-cyrillic \
- ${FONTDIR}/cyrillic/screen8x16.pcf.gz:x11-fonts/font-screen-cyrillic \
- ${FONTDIR}/cyrillic/proof9x16.pcf.gz:x11-fonts/font-winitzki-cyrillic \
- ${FONTDIR}/encodings/encodings.dir:x11-fonts/encodings
+RUN_DEPENDS= font-cronyx-cyrillic>0:x11-fonts/font-cronyx-cyrillic \
+ font-misc-cyrillic>0:x11-fonts/font-misc-cyrillic \
+ font-screen-cyrillic>0:x11-fonts/font-screen-cyrillic \
+ font-winitzki-cyrillic>0:x11-fonts/font-winitzki-cyrillic \
+ encodings>0:x11-fonts/encodings
USES= metaport
-FONTDIR= ${LOCALBASE}/share/fonts
-
.include <bsd.port.mk>
diff --git a/x11-fonts/xorg-fonts-miscbitmaps/Makefile b/x11-fonts/xorg-fonts-miscbitmaps/Makefile
index be68f7ecd7e2..6a404712c16e 100644
--- a/x11-fonts/xorg-fonts-miscbitmaps/Makefile
+++ b/x11-fonts/xorg-fonts-miscbitmaps/Makefile
@@ -8,22 +8,20 @@ CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org miscellaneous bitmap fonts
-RUN_DEPENDS= ${FONTDIR}/misc/arabic24.pcf.gz:x11-fonts/font-arabic-misc \
- ${FONTDIR}/misc/cursor.pcf.gz:x11-fonts/font-cursor-misc \
- ${FONTDIR}/misc/hanglg16.pcf.gz:x11-fonts/font-daewoo-misc \
- ${FONTDIR}/misc/deccurs.pcf.gz:x11-fonts/font-dec-misc \
- ${FONTDIR}/misc/gb16fs.pcf.gz:x11-fonts/font-isas-misc \
- ${FONTDIR}/misc/jiskan16.pcf.gz:x11-fonts/font-jis-misc \
- ${FONTDIR}/misc/micro.pcf.gz:x11-fonts/font-micro-misc \
- ${FONTDIR}/misc/10x20-ISO8859-1.pcf.gz:x11-fonts/font-misc-misc \
- ${FONTDIR}/misc/cu-alt12.pcf.gz:x11-fonts/font-mutt-misc \
- ${FONTDIR}/misc/clB6x10.pcf.gz:x11-fonts/font-schumacher-misc \
- ${FONTDIR}/misc/12x24.pcf.gz:x11-fonts/font-sony-misc \
- ${FONTDIR}/misc/olcursor.pcf.gz:x11-fonts/font-sun-misc \
- ${FONTDIR}/encodings/encodings.dir:x11-fonts/encodings
+RUN_DEPENDS= font-arabic-misc>0:x11-fonts/font-arabic-misc \
+ font-cursor-misc>0:x11-fonts/font-cursor-misc \
+ font-daewoo-misc>0:x11-fonts/font-daewoo-misc \
+ font-dec-misc>0:x11-fonts/font-dec-misc \
+ font-isas-misc>0:x11-fonts/font-isas-misc \
+ font-jis-misc>0:x11-fonts/font-jis-misc \
+ font-micro-misc>0:x11-fonts/font-micro-misc \
+ font-misc-misc>0:x11-fonts/font-misc-misc \
+ font-mutt-misc>0:x11-fonts/font-mutt-misc \
+ font-schumacher-misc>0:x11-fonts/font-schumacher-misc \
+ font-sony-misc>0:x11-fonts/font-sony-misc \
+ font-sun-misc>0:x11-fonts/font-sun-misc \
+ encodings>0:x11-fonts/encodings
USES= metaport
-FONTDIR= ${LOCALBASE}/share/fonts
-
.include <bsd.port.mk>
diff --git a/x11-fonts/xorg-fonts-truetype/Makefile b/x11-fonts/xorg-fonts-truetype/Makefile
index 705df18e5853..b6aa88386e9a 100644
--- a/x11-fonts/xorg-fonts-truetype/Makefile
+++ b/x11-fonts/xorg-fonts-truetype/Makefile
@@ -9,14 +9,12 @@ CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org TrueType fonts
-RUN_DEPENDS= ${FONTDIR}/TTF/luximb.ttf:x11-fonts/font-bh-ttf \
- ${FONTDIR}/OTF/SyrCOMAdiabene.otf:x11-fonts/font-misc-meltho \
- ${FONTDIR}/TTF/GohaTibebZemen.ttf:x11-fonts/font-misc-ethiopic \
- ${FONTDIR}/encodings/encodings.dir:x11-fonts/encodings \
- ${FONTDIR}/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
+RUN_DEPENDS= font-bh-ttf>0:x11-fonts/font-bh-ttf \
+ font-misc-meltho>0:x11-fonts/font-misc-meltho \
+ font-misc-ethiopic>0:x11-fonts/font-misc-ethiopic \
+ encodings>0:x11-fonts/encodings \
+ dejavu>0:x11-fonts/dejavu
USES= metaport
-FONTDIR= ${LOCALBASE}/share/fonts
-
.include <bsd.port.mk>
diff --git a/x11-fonts/xorg-fonts-type1/Makefile b/x11-fonts/xorg-fonts-type1/Makefile
index 5a7e6552102f..fa3e59ecda68 100644
--- a/x11-fonts/xorg-fonts-type1/Makefile
+++ b/x11-fonts/xorg-fonts-type1/Makefile
@@ -8,15 +8,13 @@ CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org Type1 fonts
-RUN_DEPENDS= ${FONTDIR}/Type1/UTBI____.afm:x11-fonts/font-adobe-utopia-type1 \
- ${FONTDIR}/Type1/l047013t.afm:x11-fonts/font-bh-type1 \
- ${FONTDIR}/Type1/c0419bt_.afm:x11-fonts/font-bitstream-type1 \
- ${FONTDIR}/Type1/cour.afm:x11-fonts/font-ibm-type1 \
- ${FONTDIR}/Type1/cursor.pfa:x11-fonts/font-xfree86-type1 \
- ${FONTDIR}/encodings/encodings.dir:x11-fonts/encodings
+RUN_DEPENDS= font-adobe-utopia-type1>0:x11-fonts/font-adobe-utopia-type1 \
+ font-bh-type1>0:x11-fonts/font-bh-type1 \
+ font-bitstream-type1>0:x11-fonts/font-bitstream-type1 \
+ font-ibm-type1>0:x11-fonts/font-ibm-type1 \
+ font-xfree86-type1>0:x11-fonts/font-xfree86-type1 \
+ encodings>0:x11-fonts/encodings
USES= metaport
-FONTDIR= ${LOCALBASE}/share/fonts
-
.include <bsd.port.mk>