aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/XFree86-4-NestServer
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2002-07-18 20:30:22 +0000
committerEric Anholt <anholt@FreeBSD.org>2002-07-18 20:30:22 +0000
commita5596482c6ab677399ec6caa872847fb08a36bcd (patch)
treeb964abf535bc03854ad6684d05872c74c936bf8f /x11-servers/XFree86-4-NestServer
parentb4b23fe6b8b83e2f81e86d26fc88d98f022f98da (diff)
downloadports-a5596482c6ab677399ec6caa872847fb08a36bcd.tar.gz
ports-a5596482c6ab677399ec6caa872847fb08a36bcd.zip
Make XFree86-4 miniports use imake-4's HasXdmAuth setting (default is YES).
Clean up Wraphelp.c inclusion in the ports that need it. Add USE_PERL5 to imake-4. Approved by: des
Notes
Notes: svn path=/head/; revision=63216
Diffstat (limited to 'x11-servers/XFree86-4-NestServer')
-rw-r--r--x11-servers/XFree86-4-NestServer/Makefile4
-rw-r--r--x11-servers/XFree86-4-NestServer/scripts/configure41
2 files changed, 9 insertions, 36 deletions
diff --git a/x11-servers/XFree86-4-NestServer/Makefile b/x11-servers/XFree86-4-NestServer/Makefile
index 8b116a74298f..44961e635d8d 100644
--- a/x11-servers/XFree86-4-NestServer/Makefile
+++ b/x11-servers/XFree86-4-NestServer/Makefile
@@ -25,14 +25,14 @@ USE_IMAKE= YES
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
PATCHDIR= ${.CURDIR}/../../x11/XFree86-4-libraries/files
-SCRIPTS_ENV= HasXdmAuth=${HasXdmAuth}
MAKE_ENV= MAN_INSTALL_TARGET=installXnest.man
ALL_TARGET= FreeBSDPortsBuild
INSTALL_TARGET= installXnest installXserver.man
MANCOMPRESSED= yes
MAN1= Xnest.1 Xserver.1
-HasXdmAuth?= YES
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.c ${WRKSRC}/lib/Xdmcp/
do-configure:
cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure
diff --git a/x11-servers/XFree86-4-NestServer/scripts/configure b/x11-servers/XFree86-4-NestServer/scripts/configure
index 4f644af47812..a7ac5359f3be 100644
--- a/x11-servers/XFree86-4-NestServer/scripts/configure
+++ b/x11-servers/XFree86-4-NestServer/scripts/configure
@@ -1,14 +1,14 @@
#!/bin/sh
-# This scripts work as following:
-# (1) cp current xf86site.def (it may be created by imake-4 ports)
+# This script does the following:
+# (1) cp current xf86site.def (it is created by the imake-4 port)
# to ${WRKDIR}/xc/config/cf.
-# this means this ports use imake-4's config defaultly.
+# this means this port uses imake-4's config for defaults.
# (2) Generate temporal config for compiling.
# Some configs, such as `ForceNormalLib', `FreeBSDBuildXprog', are
-# used for compiling this ports localy. so these configs will be generated
-# this scripts. these configs will be stored to `host.def' file.
-# but this host.def will never install. use local only.
+# used locally for compiling this port, so these configs will be generated
+# by this script. These configs will be stored to the `host.def' file,
+# but this host.def will never be installed.
ORIGDEF=$PREFIX/lib/X11/config/xf86site.def
DESTDEF=$WRKDIR/xc/config/cf/xf86site.def
@@ -49,36 +49,9 @@ configure () {
echo "#define XnestServer YES" >> $LOCALDEF
echo "#define BuildServersOnly YES" >> $LOCALDEF
- # Check Wraphelp.c
- if [ $HasXdmAuth = DEFAULT ]; then
- HasXdmAuth=$(awk '/^#define.*HasXdmAuth/ {print $3}' $ORIGDEF|tail -1)
- fi
-
- cpwh=NO
- if [ $HasXdmAuth = YES ]; then
- WH=$WRKDIR/xc/lib/Xdmcp/Wraphelp.c
- if [ -f $WH ] ; then
- cpwh=SOURCE
- elif [ -f $DISTDIR/xc/Wraphelp.c ] ; then
- cpwh=$DISTDIR/xc/Wraphelp.c
- else
- echo "==> You must fetch USA-legal Wraphelp.c manually"
- echo "==> and put it to ${DISTDIR}/xc/."
- exit 1
- fi
- if [ X$cpwh != XNO -a X$cpwh != XSOURCE ]; then
- tr -d '\r' < $cpwh > $WH
- fi
- fi
-
# Copy ORIGDEF to DESTDEF
rm -f $DESTDEF
- grep -v '#define.*HasXdmAuth' $ORIGDEF >> $DESTDEF
- if [ $cpwh = NO ] ; then
- echo "#define HasXdmAuth NO" >> $DESTDEF
- else
- echo "#define HasXdmAuth YES" >> $DESTDEF
- fi
+ cp -f $ORIGDEF $DESTDEF
# copy generated config to host.def
cp -f $LOCALDEF $HOSTDEF