aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/xorg-server
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-09-29 23:46:47 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-09-29 23:46:47 +0000
commit6456a7904571af67721ee5010fc2799efb5cceb4 (patch)
tree7a16c96ebdce5be5bce30715b596fca9d205bdb1 /x11-servers/xorg-server
parentb4231ba027dd3b7c69fbc70e46a7e89959324dae (diff)
downloadports-6456a7904571af67721ee5010fc2799efb5cceb4.tar.gz
ports-6456a7904571af67721ee5010fc2799efb5cceb4.zip
Fix patches. Remove two unneeded ones, and add new patches to fix sparc64.
This was missed in the mesa update. This syncs x11-server/xorg-server with the xorg development repo Bump portrevision again in case. Apologies for the churn! Obtained from: xorg development repo
Notes
Notes: svn path=/head/; revision=328762
Diffstat (limited to 'x11-servers/xorg-server')
-rw-r--r--x11-servers/xorg-server/Makefile11
-rw-r--r--x11-servers/xorg-server/files/extra-new-arch-sparc6412
-rw-r--r--x11-servers/xorg-server/files/extra-old-arch-sparc64 (renamed from x11-servers/xorg-server/files/extra-Xserver-hw-xfree86-os-support-bsd-sparc64_video.c)0
-rw-r--r--x11-servers/xorg-server/files/extra-servermd.h11
4 files changed, 19 insertions, 15 deletions
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index dc0d15ce4f0f..635e7d873779 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -35,20 +35,18 @@ OPTIONS_EXCLUDE_sparc64= HAL
.if defined(WITH_NEW_XORG)
XORG_VERSION= 1.12.4
-XORG_REVISION= 2
+XORG_REVISION= 3
PLIST_SUB+= OLD="@comment " NEW=""
EXTRA_PATCHES+= ${FILESDIR}/extra-clang \
${FILESDIR}/extra-configure
.else
XORG_VERSION= 1.7.7
-XORG_REVISION= 9
+XORG_REVISION= 10
PLIST_SUB+= OLD="" NEW="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extra-Xext-xace.c \
- ${FILESDIR}/extra-Xserver-hw-xfree86-os-support-bsd-sparc64_video.c \
${FILESDIR}/extra-Xserver-os-xprintf.c \
${FILESDIR}/extra-include_eventstr.h \
${FILESDIR}/extra-os-utils.c \
- ${FILESDIR}/extra-servermd.h \
${FILESDIR}/extra-dix_events.c \
${FILESDIR}/extra-Xserver-hw-xfree86-common-xf86Config.c
.endif
@@ -153,6 +151,11 @@ PLIST_SUB+= PPC_NA=""
.if ${ARCH} == sparc64
PLIST_SUB+= SPARC64=""
PLIST_SUB+= SPARC64_NA="@comment "
+.if defined(WITH_NEW_XORG)
+EXTRA_PATCHES+= ${FILESDIR}/extra-new-arch-sparc64
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-old-arch-sparc64
+.endif
.else
PLIST_SUB+= SPARC64="@comment "
PLIST_SUB+= SPARC64_NA=""
diff --git a/x11-servers/xorg-server/files/extra-new-arch-sparc64 b/x11-servers/xorg-server/files/extra-new-arch-sparc64
new file mode 100644
index 000000000000..45d40053ece6
--- /dev/null
+++ b/x11-servers/xorg-server/files/extra-new-arch-sparc64
@@ -0,0 +1,12 @@
+--- hw/xfree86/os-support/bsd/bsd_init.c.orig 2012-05-17 19:09:03.000000000 +0200
++++ hw/xfree86/os-support/bsd/bsd_init.c 2013-09-01 20:45:36.000000000 +0200
+@@ -230,6 +230,9 @@
+ * Add cases for other *BSD that behave the same.
+ */
+ #if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
++#if defined(__sparc64__)
++ pci_system_init_dev_mem(fd);
++#endif
+ uname(&uts);
+ i = atof(uts.release) * 100;
+ if (i >= 310)
diff --git a/x11-servers/xorg-server/files/extra-Xserver-hw-xfree86-os-support-bsd-sparc64_video.c b/x11-servers/xorg-server/files/extra-old-arch-sparc64
index 651be80114fe..651be80114fe 100644
--- a/x11-servers/xorg-server/files/extra-Xserver-hw-xfree86-os-support-bsd-sparc64_video.c
+++ b/x11-servers/xorg-server/files/extra-old-arch-sparc64
diff --git a/x11-servers/xorg-server/files/extra-servermd.h b/x11-servers/xorg-server/files/extra-servermd.h
deleted file mode 100644
index 5bbb1e4d8ab5..000000000000
--- a/x11-servers/xorg-server/files/extra-servermd.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/servermd.h.orig Sun Jan 8 14:05:55 2006
-+++ include/servermd.h Sun Jan 8 14:06:22 2006
-@@ -216,7 +216,7 @@
- defined(__sparc__) || defined(__mc68000__)
-
- #if defined(__sparc) || defined(__sparc__)
--# if !defined(sparc)
-+# if !defined(sparc) && !defined(__FreeBSD__)
- # define sparc 1
- # endif
- #endif