aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/xwayland/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-02-11 18:31:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-02-11 18:31:47 +0000
commitd70b127b51503450f202881c246ddc680840ba88 (patch)
tree87ac16ae0ef38dd22d3149b9896a7627d6e7860b /x11-servers/xwayland/Makefile
parentbe5779eecc0b8c402fd4a31738394a8c88ef9c3a (diff)
downloadports-d70b127b51503450f202881c246ddc680840ba88.tar.gz
ports-d70b127b51503450f202881c246ddc680840ba88.zip
XWayland is an X Server running as a Wayland client, thus capable of displaying
native X11 client applications in a Wayland compositor environment. WWW: https://wayland.freedesktop.org/xserver.html
Notes
Notes: svn path=/head/; revision=433900
Diffstat (limited to 'x11-servers/xwayland/Makefile')
-rw-r--r--x11-servers/xwayland/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-servers/xwayland/Makefile b/x11-servers/xwayland/Makefile
new file mode 100644
index 000000000000..5a83d704dba0
--- /dev/null
+++ b/x11-servers/xwayland/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= xwayland
+PORTVERSION= 1.19.1
+
+COMMENT= X Clients under Wayland
+
+LICENSE= MIT
+
+BUILD_DEPENDS= /usr/local/libdata/pkgconfig/wayland-protocols.pc:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libinput.so:x11/libinput
+
+MASTERDIR= ${.CURDIR}/../xorg-server
+DESCR= ${.CURDIR}/pkg-descr
+DISTINFO_FILE= ${.CURDIR}/distinfo
+PATCHDIR= ${.CURDIR}/files
+
+SLAVE_PORT= yes
+OPTIONS_EXCLUDE=DEVD HAL SUID
+
+USE_XORG= x11 xext xfont2
+USE_GL+= egl gbm
+
+CONFIGURE_ARGS+= --disable-docs --disable-devel-docs \
+ --enable-xwayland --disable-xorg --disable-xvfb --disable-xnest \
+ --disable-xquartz --disable-xwin
+
+PLIST_FILES= bin/Xwayland
+
+do-install:
+ cd ${WRKSRC}/hw/xwayland; DESTDIR=${STAGEDIR} ${MAKE_CMD} install
+
+.include "${MASTERDIR}/Makefile"