aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2002-09-19 07:55:42 +0000
committerEric Anholt <anholt@FreeBSD.org>2002-09-19 07:55:42 +0000
commit23bd3ea704d92fa80b7d4db152abda4a97fc6811 (patch)
treeaee118abbbbe1800546891861977907482cf056f /x11-servers
parenta6fd0ce91b054a3846d29b2ee40b0d8b413046ef (diff)
downloadports-23bd3ea704d92fa80b7d4db152abda4a97fc6811.tar.gz
ports-23bd3ea704d92fa80b7d4db152abda4a97fc6811.zip
Fix Matrox G550 cursor in the non-WITH_MATROX_GXX_DRIVER case.
PR: 37542 Submitted by: Peter Johnson <freebsd@bilogic.org>
Notes
Notes: svn path=/head/; revision=66687
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/XFree86-4-Server-snap/Makefile8
-rw-r--r--x11-servers/XFree86-4-Server-snap/files/patch-mga_driver.c10
-rw-r--r--x11-servers/XFree86-4-Server/Makefile8
-rw-r--r--x11-servers/XFree86-4-Server/files/patch-mga_driver.c10
4 files changed, 32 insertions, 4 deletions
diff --git a/x11-servers/XFree86-4-Server-snap/Makefile b/x11-servers/XFree86-4-Server-snap/Makefile
index 7a81fe31d4f1..1111676b7784 100644
--- a/x11-servers/XFree86-4-Server-snap/Makefile
+++ b/x11-servers/XFree86-4-Server-snap/Makefile
@@ -167,7 +167,7 @@ pre-everything::
@${ECHO_MSG} "4.2.0! ENABLE AT YOUR OWN RISK!"
@${ECHO_MSG} "********************************************************"
-.if ${BuildXF86DRI} == YES
+.if ${ARCH} == i386
.if !defined(WITH_MATROX_GXX_DRIVER)
HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
@@ -180,7 +180,7 @@ pre-fetch::
@${ECHO_MSG} "This has been tested on a G400 AGP card."
@${ECHO_MSG} "********************************************************"
.else
-NO_PACKAGE= "Matrox drivers may not be distributed."
+NO_PACKAGE= "Matrox drivers may not be distributed"
RESTRICTED= "Matrox drivers may not be distributed."
HaveMatroxHal= YES
MGA_DRIVER_VERSION= 2.0
@@ -202,6 +202,10 @@ HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
.endif
+.if ${HaveMatroxHal} == NO
+EXTRA_PATCHES+= ${.CURDIR}/files/patch-mga_driver.c
+.endif
+
post-extract::
${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.gz > \
${WRKSRC}/lib/Xdmcp/Wraphelp.c
diff --git a/x11-servers/XFree86-4-Server-snap/files/patch-mga_driver.c b/x11-servers/XFree86-4-Server-snap/files/patch-mga_driver.c
new file mode 100644
index 000000000000..b33035d4ffef
--- /dev/null
+++ b/x11-servers/XFree86-4-Server-snap/files/patch-mga_driver.c
@@ -0,0 +1,10 @@
+--- programs/Xserver/hw/xfree86/drivers/mga/mga_driver.c.orig Thu Sep 19 00:12:42 2002
++++ programs/Xserver/hw/xfree86/drivers/mga/mga_driver.c Thu Sep 19 00:13:56 2002
+@@ -2745,6 +2745,7 @@
+ case PCI_CHIP_MGAG200:
+ case PCI_CHIP_MGAG200_PCI:
+ case PCI_CHIP_MGAG400:
++ case PCI_CHIP_MGAG550:
+ if(pMga->SecondCrtc == FALSE && pMga->HWCursor == TRUE) {
+ outMGAdac(MGA1064_CURSOR_BASE_ADR_LOW,
+ pMga->FbCursorOffset >> 10);
diff --git a/x11-servers/XFree86-4-Server/Makefile b/x11-servers/XFree86-4-Server/Makefile
index 7a81fe31d4f1..1111676b7784 100644
--- a/x11-servers/XFree86-4-Server/Makefile
+++ b/x11-servers/XFree86-4-Server/Makefile
@@ -167,7 +167,7 @@ pre-everything::
@${ECHO_MSG} "4.2.0! ENABLE AT YOUR OWN RISK!"
@${ECHO_MSG} "********************************************************"
-.if ${BuildXF86DRI} == YES
+.if ${ARCH} == i386
.if !defined(WITH_MATROX_GXX_DRIVER)
HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
@@ -180,7 +180,7 @@ pre-fetch::
@${ECHO_MSG} "This has been tested on a G400 AGP card."
@${ECHO_MSG} "********************************************************"
.else
-NO_PACKAGE= "Matrox drivers may not be distributed."
+NO_PACKAGE= "Matrox drivers may not be distributed"
RESTRICTED= "Matrox drivers may not be distributed."
HaveMatroxHal= YES
MGA_DRIVER_VERSION= 2.0
@@ -202,6 +202,10 @@ HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
.endif
+.if ${HaveMatroxHal} == NO
+EXTRA_PATCHES+= ${.CURDIR}/files/patch-mga_driver.c
+.endif
+
post-extract::
${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.gz > \
${WRKSRC}/lib/Xdmcp/Wraphelp.c
diff --git a/x11-servers/XFree86-4-Server/files/patch-mga_driver.c b/x11-servers/XFree86-4-Server/files/patch-mga_driver.c
new file mode 100644
index 000000000000..b33035d4ffef
--- /dev/null
+++ b/x11-servers/XFree86-4-Server/files/patch-mga_driver.c
@@ -0,0 +1,10 @@
+--- programs/Xserver/hw/xfree86/drivers/mga/mga_driver.c.orig Thu Sep 19 00:12:42 2002
++++ programs/Xserver/hw/xfree86/drivers/mga/mga_driver.c Thu Sep 19 00:13:56 2002
+@@ -2745,6 +2745,7 @@
+ case PCI_CHIP_MGAG200:
+ case PCI_CHIP_MGAG200_PCI:
+ case PCI_CHIP_MGAG400:
++ case PCI_CHIP_MGAG550:
+ if(pMga->SecondCrtc == FALSE && pMga->HWCursor == TRUE) {
+ outMGAdac(MGA1064_CURSOR_BASE_ADR_LOW,
+ pMga->FbCursorOffset >> 10);