aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-arc-themes/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-03-04 16:16:25 +0000
committerSteve Wills <swills@FreeBSD.org>2019-03-04 16:16:25 +0000
commit82a2c0f0112794cd3dd1cd8b1b0fe628e5e73cf3 (patch)
treed7ec29628f8efe108891d8573023447b9dfce7ad /x11-themes/gtk-arc-themes/Makefile
parent6873795c6922686b0a86faffb52ba97f5201728c (diff)
downloadports-82a2c0f0112794cd3dd1cd8b1b0fe628e5e73cf3.tar.gz
ports-82a2c0f0112794cd3dd1cd8b1b0fe628e5e73cf3.zip
x11-themes/gtk-arc-themes: New upstream and update to 20190213
PR: 235755 Submitted by: Hiroki Tagato <tagattie@yandex.com> Approved by: maintainer timeout (mail_me@riseup.net, >2 weeks)
Notes
Notes: svn path=/head/; revision=494605
Diffstat (limited to 'x11-themes/gtk-arc-themes/Makefile')
-rw-r--r--x11-themes/gtk-arc-themes/Makefile46
1 files changed, 39 insertions, 7 deletions
diff --git a/x11-themes/gtk-arc-themes/Makefile b/x11-themes/gtk-arc-themes/Makefile
index b399952c1e7b..ed54b2126b37 100644
--- a/x11-themes/gtk-arc-themes/Makefile
+++ b/x11-themes/gtk-arc-themes/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gtk-arc-themes
-PORTVERSION= 20170302
-PORTREVISION= 2
+PORTVERSION= 20190213
CATEGORIES= x11-themes
MAINTAINER= mail_me@riseup.net
@@ -12,19 +11,52 @@ COMMENT= Arc-themes for GTK-2.0 and GTK-3.0 based desktop environments
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= gtk-murrine-engine>0:x11-themes/gtk-murrine-engine \
- gnome-themes-extra>0:x11-themes/gnome-themes-extra
+BUILD_DEPENDS= inkscape:graphics/inkscape \
+ optipng:graphics/optipng \
+ sassc:textproc/sassc
RUN_DEPENDS= gtk-murrine-engine>0:x11-themes/gtk-murrine-engine \
gnome-themes-extra>0:x11-themes/gnome-themes-extra
+USES= autoreconf gmake gnome pkgconfig
+
USE_GITHUB= yes
-GH_ACCOUNT= horst3180
+GH_ACCOUNT= NicoHood
GH_PROJECT= arc-theme
-USES= autoreconf gnome pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20 gtk30
NO_ARCH= yes
-CONFIGURE_ARGS= --with-gnome=3.22
+
+OPTIONS_DEFINE= CINNAMON GNOMESHELL METACITY OPENBOX PLANK UNITY XFCE
+OPTIONS_DEFAULT= CINNAMON GNOMESHELL METACITY OPENBOX PLANK UNITY XFCE
+OPTIONS_SUB= yes
+
+CINNAMON_DESC= Support for Cinnamon desktop environment
+CINNAMON_IMPLIES= METACITY
+CINNAMON_CONFIGURE_ENABLE= cinnamon
+
+GNOMESHELL_DESC= Support for Gnome Shell
+GNOMESHELL_CONFIGURE_ENABLE= gnome-shell
+GNOMESHELL_BUILD_DEPENDS= gnome-shell:x11/gnome-shell
+
+METACITY_DESC= Support for Metacity window manager
+METACITY_CONFIGURE_ENABLE= metacity
+
+OPENBOX_DESC= Support for Openbox window manager
+OPENBOX_CONFIGURE_ENABLE= openbox
+
+PLANK_DESC= Support for Plank dock
+PLANK_CONFIGURE_ENABLE= plank
+
+UNITY_DESC= Support for Unity desktop environment
+UNITY_CONFIGURE_ENABLE= unity
+
+XFCE_DESC= Support for Xfce desktop environment
+XFCE_CONFIGURE_ENABLE= xfwm
+
+post-patch:
+ ${REINPLACE_CMD} -E 's|^(IconTheme=).*|\1Adwaita|; \
+ s|^(CursorTheme=).*|\1Adwaita|' \
+ ${WRKSRC}/common/index/*/index.theme
.include <bsd.port.mk>