aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-16 22:01:12 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-16 22:01:12 +0000
commit360f6304193bad95b470be129f624e452d1a1506 (patch)
tree34a1decf1b4016425c296377da57c0bd22951b0e /x11-themes
parent53bf026dbe92d21652938500b572abccceebf505 (diff)
downloadports-360f6304193bad95b470be129f624e452d1a1506.tar.gz
ports-360f6304193bad95b470be129f624e452d1a1506.zip
Add a patch to prevent the Industrial theme from crashing if handed a NULL
widget.
Notes
Notes: svn path=/head/; revision=104213
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-themes-extras/Makefile2
-rw-r--r--x11-themes/gnome-themes-extras/files/patch-Industrial_industrial_style.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-extras/Makefile b/x11-themes/gnome-themes-extras/Makefile
index 76cfbb684f31..b8a1699ab1a0 100644
--- a/x11-themes/gnome-themes-extras/Makefile
+++ b/x11-themes/gnome-themes-extras/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-themes-extras
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/x11-themes/gnome-themes-extras/files/patch-Industrial_industrial_style.c b/x11-themes/gnome-themes-extras/files/patch-Industrial_industrial_style.c
new file mode 100644
index 000000000000..a95963569336
--- /dev/null
+++ b/x11-themes/gnome-themes-extras/files/patch-Industrial_industrial_style.c
@@ -0,0 +1,10 @@
+--- Industrial/industrial_style.c.orig Tue Mar 16 16:55:11 2004
++++ Industrial/industrial_style.c Tue Mar 16 16:58:23 2004
+@@ -1801,6 +1801,7 @@
+ gint width,
+ gint height)
+ {
++ g_return_if_fail (widget != NULL);
+ #if DEBUG
+ printf ("draw_shadow: %p %p %s %i %i %i %i\n", widget, window, detail, x, y,
+ width, height);