aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-21 03:40:54 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-21 03:40:54 +0000
commita3da9e447302ecb5ae4bd0d2706912f0ea7c4991 (patch)
tree3b31fe09b64b52c519d77eedbcb949e63ac15982 /x11-themes
parent17353f1000171a5c5b38c047c15dee38964c9b8a (diff)
downloadports-a3da9e447302ecb5ae4bd0d2706912f0ea7c4991.tar.gz
ports-a3da9e447302ecb5ae4bd0d2706912f0ea7c4991.zip
Use REINPLACE_CMD instead of Perl.
Notes
Notes: svn path=/head/; revision=94600
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/sapphire-themes/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-themes/sapphire-themes/Makefile b/x11-themes/sapphire-themes/Makefile
index 9a014c84a0b8..fd84247c75d2 100644
--- a/x11-themes/sapphire-themes/Makefile
+++ b/x11-themes/sapphire-themes/Makefile
@@ -19,17 +19,18 @@ RUN_DEPENDS= xli:${PORTSDIR}/graphics/xli \
xloadimage:${PORTSDIR}/x11/xloadimage \
sapphire:${PORTSDIR}/x11-wm/sapphire
-USE_PERL5_BUILD=yes
+REINPLACE_ARGS= -i '' -E
+USE_REINPLACE= yes
USE_X_PREFIX= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
do-patch:
- ${PERL} -pi -e 's:~/\.:${X11BASE}/share/:g' \
+ ${REINPLACE_CMD} 's:~/\.:${X11BASE}/share/:g' \
${WRKDIR}/menu/default \
${WRKDIR}/themes/*.theme
- ${PERL} -pi -e 's:-15-:-12-:g' ${WRKDIR}/themes/*.theme
+ ${REINPLACE_CMD} 's:-15-:-12-:g' ${WRKDIR}/themes/*.theme
do-install:
${MKDIR} ${X11BASE}/share/sapphire/themes/backgrounds/