aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
commitddae4e92d8313a1461145e3b4f0232fe463feaee (patch)
treee84ab3fcfdf00dbf560f8ef9ae031d0c2ed252f5 /x11-themes
parent51a360b7fe98be99d21134e5fe624ba12d596dd9 (diff)
downloadports-ddae4e92d8313a1461145e3b4f0232fe463feaee.tar.gz
ports-ddae4e92d8313a1461145e3b4f0232fe463feaee.zip
Mk/Uses: always use colon for build/run suffix
Most USES use a colon for build/run(/test) suffixes. Change kde.mk, qt.mk and pyqt.mk to do the same, and update all ports using that. Document in CHANGES. PR: 266034 Exp-run by: antoine Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36349
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/Kvantum/Makefile2
-rw-r--r--x11-themes/adwaita-qt5/Makefile2
-rw-r--r--x11-themes/kf5-breeze-icons/Makefile4
-rw-r--r--x11-themes/kf5-kemoticons/Makefile4
-rw-r--r--x11-themes/kf5-kiconthemes/Makefile6
-rw-r--r--x11-themes/kf5-oxygen-icons5/Makefile4
-rw-r--r--x11-themes/kf5-qqc2-desktop-style/Makefile4
-rw-r--r--x11-themes/lumina-themes/Makefile2
-rw-r--r--x11-themes/plasma5-breeze-gtk/Makefile2
-rw-r--r--x11-themes/plasma5-breeze/Makefile2
-rw-r--r--x11-themes/plasma5-kde-gtk-config/Makefile4
-rw-r--r--x11-themes/plasma5-oxygen/Makefile2
-rw-r--r--x11-themes/plasma5-plasma-workspace-wallpapers/Makefile4
-rw-r--r--x11-themes/qgnomeplatform/Makefile2
-rw-r--r--x11-themes/qt5-style-plugins/Makefile2
-rw-r--r--x11-themes/qtcurve/Makefile16
16 files changed, 31 insertions, 31 deletions
diff --git a/x11-themes/Kvantum/Makefile b/x11-themes/Kvantum/Makefile
index 49bab19a024f..6cfad4f90e27 100644
--- a/x11-themes/Kvantum/Makefile
+++ b/x11-themes/Kvantum/Makefile
@@ -20,7 +20,7 @@ USE_GL= gl
USE_LDCONFIG= yes
USE_KDE= windowsystem
USE_QT= core gui svg widgets x11extras \
- buildtools_build linguisttools_build
+ buildtools:build linguisttools:build
USE_XORG= x11 xext
WRKSRC_SUBDIR= ${PORTNAME}
diff --git a/x11-themes/adwaita-qt5/Makefile b/x11-themes/adwaita-qt5/Makefile
index 3bef3e475924..02ba18b5badf 100644
--- a/x11-themes/adwaita-qt5/Makefile
+++ b/x11-themes/adwaita-qt5/Makefile
@@ -26,7 +26,7 @@ _qt_version?= 5
_qt5_qt6_on= OFF
_qt6_qt6_on= ON
_qt5_use= core dbus gui widgets x11extras \
- buildtools_build qmake_build
+ buildtools:build qmake:build
_qt6_use= base
_qt5_plist_sub= QT_VERSION_SUFFIX=
_qt6_plist_sub= QT_VERSION_SUFFIX=6
diff --git a/x11-themes/kf5-breeze-icons/Makefile b/x11-themes/kf5-breeze-icons/Makefile
index 1bb965f0a51b..1037eb872110 100644
--- a/x11-themes/kf5-breeze-icons/Makefile
+++ b/x11-themes/kf5-breeze-icons/Makefile
@@ -12,8 +12,8 @@ BUILD_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
USES= compiler:c++11-lang cmake kde:5 python:3.5+,build qt:5 shebangfix tar:xz
-USE_KDE= ecm_build
-USE_QT= buildtools_build qmake_build testlib_build
+USE_KDE= ecm:build
+USE_QT= buildtools:build qmake:build testlib:build
SHEBANG_FILES= svg-xml-script-template.py generate-24px-versions.py
diff --git a/x11-themes/kf5-kemoticons/Makefile b/x11-themes/kf5-kemoticons/Makefile
index 95cbf2a4b197..f563bf243853 100644
--- a/x11-themes/kf5-kemoticons/Makefile
+++ b/x11-themes/kf5-kemoticons/Makefile
@@ -7,8 +7,8 @@ COMMENT= KF5 library to convert emoticons
USES= cmake compiler:c++11-lib kde:5 qt:5 tar:xz
USE_KDE= archive config coreaddons service \
- ecm_build
+ ecm:build
USE_QT= core dbus gui widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11-themes/kf5-kiconthemes/Makefile b/x11-themes/kf5-kiconthemes/Makefile
index 1263f6ba30a6..e90554eccc65 100644
--- a/x11-themes/kf5-kiconthemes/Makefile
+++ b/x11-themes/kf5-kiconthemes/Makefile
@@ -8,13 +8,13 @@ COMMENT= KF5 library for handling icons in applications
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth codecs config configwidgets coreaddons \
i18n itemviews widgetsaddons \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus gui script svg widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
OPTIONS_DEFINE= ICONS
OPTIONS_DEFAULT= ICONS
ICONS_DESC= Install Breeze Icons
-ICONS_USE= KDE=breeze-icons_run
+ICONS_USE= KDE=breeze-icons:run
.include <bsd.port.mk>
diff --git a/x11-themes/kf5-oxygen-icons5/Makefile b/x11-themes/kf5-oxygen-icons5/Makefile
index 9ce25a792792..9b4a0d27bad8 100644
--- a/x11-themes/kf5-oxygen-icons5/Makefile
+++ b/x11-themes/kf5-oxygen-icons5/Makefile
@@ -6,14 +6,14 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= The Oxygen icon theme for KDE
USES= cmake kde:5 qt:5 tar:xz
-USE_KDE= ecm_build # We only install icons.
+USE_KDE= ecm:build # We only install icons.
# The qmake dependency is only needed so that kf5-e-c-m can query qmake for
# some installation directories.
# We explicitly prevent it from looking for qt5-core and specify qmake's path
# to avoid needlessly depending on qt5-core; we're just installing a ton of
# icon files and do not even use the paths queried from qmake.
-USE_QT= buildtools_build qmake_build
+USE_QT= buildtools:build qmake:build
NO_ARCH= yes
diff --git a/x11-themes/kf5-qqc2-desktop-style/Makefile b/x11-themes/kf5-qqc2-desktop-style/Makefile
index 0c8557c533b0..e3057651f7fb 100644
--- a/x11-themes/kf5-qqc2-desktop-style/Makefile
+++ b/x11-themes/kf5-qqc2-desktop-style/Makefile
@@ -9,8 +9,8 @@ COMMENT= Qt QuickControl2 style for KDE
USES= cmake compiler:c++11-lang kde:5 pkgconfig qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons iconthemes \
kirigami2 widgetsaddons \
- ecm_build
+ ecm:build
USE_QT= core dbus declarative gui network widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11-themes/lumina-themes/Makefile b/x11-themes/lumina-themes/Makefile
index 24c639bbd243..d940eb35e7d2 100644
--- a/x11-themes/lumina-themes/Makefile
+++ b/x11-themes/lumina-themes/Makefile
@@ -11,7 +11,7 @@ LICENSE= BSD2CLAUSE CC0-1.0
LICENSE_COMB= multi
USES= qmake qt:5
-USE_QT= qmake_build
+USE_QT= qmake:build
USE_GITHUB= yes
GH_ACCOUNT= trueos
diff --git a/x11-themes/plasma5-breeze-gtk/Makefile b/x11-themes/plasma5-breeze-gtk/Makefile
index a7c4581e627f..3c75ad8c8f13 100644
--- a/x11-themes/plasma5-breeze-gtk/Makefile
+++ b/x11-themes/plasma5-breeze-gtk/Makefile
@@ -16,7 +16,7 @@ USES= cmake compiler:c++11-lang gnome kde:5 pkgconfig python:3.4+ \
USE_GNOME= gdkpixbuf2
USE_KDE= breeze ecm
USE_QT= core \
- buildtools_build qmake_build
+ buildtools:build qmake:build
CMAKE_ARGS= -DPython3_EXECUTABLE:PATH=${PYTHON_CMD}
BINARY_ALIAS= python3=${PYTHON_CMD}
diff --git a/x11-themes/plasma5-breeze/Makefile b/x11-themes/plasma5-breeze/Makefile
index d800612010cb..5f74fb8a8a57 100644
--- a/x11-themes/plasma5-breeze/Makefile
+++ b/x11-themes/plasma5-breeze/Makefile
@@ -18,7 +18,7 @@ USE_KDE= auth breeze-icons codecs config configwidgets coreaddons \
kcmutils plasma-framework service wayland widgetsaddons \
windowsystem
USE_QT= core dbus declarative gui network widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11 xcb
.include <bsd.port.mk>
diff --git a/x11-themes/plasma5-kde-gtk-config/Makefile b/x11-themes/plasma5-kde-gtk-config/Makefile
index 2276dc46d5db..6f8217ec6ca7 100644
--- a/x11-themes/plasma5-kde-gtk-config/Makefile
+++ b/x11-themes/plasma5-kde-gtk-config/Makefile
@@ -20,9 +20,9 @@ USE_GNOME= cairo gdkpixbuf2 glib20 gtk20 gtk30
USE_KDE= archive attica auth codecs completion config configwidgets \
coreaddons dbusaddons decoration guiaddons i18n iconthemes \
jobwidgets kcmutils kio newstuff service widgetsaddons xmlgui \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus gui network svg widgets xml \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
USE_XORG= x11 xcursor
.include <bsd.port.mk>
diff --git a/x11-themes/plasma5-oxygen/Makefile b/x11-themes/plasma5-oxygen/Makefile
index 7221147fcd84..a33b5ba0ea5f 100644
--- a/x11-themes/plasma5-oxygen/Makefile
+++ b/x11-themes/plasma5-oxygen/Makefile
@@ -17,7 +17,7 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
decoration ecm frameworkintegration guiaddons i18n kcmutils \
service wayland widgetsaddons windowsystem
USE_QT= core dbus declarative gui network widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11 xcb
.include <bsd.port.mk>
diff --git a/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile b/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
index 19ba57ce6d92..fa94ec36109d 100644
--- a/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
+++ b/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
@@ -13,8 +13,8 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LGPL3
USES= cmake kde:5 qt:5 tar:xz
USE_KDE= ecm
-USE_QT= buildtools_build \
- qmake_build
+USE_QT= buildtools:build \
+ qmake:build
NO_ARCH= yes
diff --git a/x11-themes/qgnomeplatform/Makefile b/x11-themes/qgnomeplatform/Makefile
index 63080f955900..1bcd1b576e61 100644
--- a/x11-themes/qgnomeplatform/Makefile
+++ b/x11-themes/qgnomeplatform/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland \
USES= compiler:c++11-lang gl gnome pkgconfig qmake:outsource qt:5 xorg
USE_GL= gl
USE_GNOME= gtk30 cairo gdkpixbuf2
-USE_QT= buildtools_build core gui widgets dbus wayland
+USE_QT= buildtools:build core gui widgets dbus wayland
USE_XORG= x11
USE_GITHUB= yes
diff --git a/x11-themes/qt5-style-plugins/Makefile b/x11-themes/qt5-style-plugins/Makefile
index 06a499b5dec7..03e6df4ec9c8 100644
--- a/x11-themes/qt5-style-plugins/Makefile
+++ b/x11-themes/qt5-style-plugins/Makefile
@@ -21,7 +21,7 @@ USE_GITHUB= yes
GH_ACCOUNT= qt
GH_PROJECT= qtstyleplugins
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USE_QT= core dbus gui widgets buildtools_build
+USE_QT= core dbus gui widgets buildtools:build
USE_GL= gl
USE_XORG= x11 xext
diff --git a/x11-themes/qtcurve/Makefile b/x11-themes/qtcurve/Makefile
index 5a7708fb02e9..654d8df9a410 100644
--- a/x11-themes/qtcurve/Makefile
+++ b/x11-themes/qtcurve/Makefile
@@ -54,8 +54,8 @@ PLIST= ${PKGDIR}/pkg-plist.${QTCURVE_SLAVE}
.if ${QTCURVE_SLAVE} == "utils"
PKGNAMESUFFIX= -utils
USES+= gettext-runtime kde:5 qt:5
-USE_KDE+= i18n_build
-USE_QT+= buildtools_build qmake_build
+USE_KDE+= i18n:build
+USE_QT+= buildtools:build qmake:build
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}
.else
@@ -66,8 +66,8 @@ LIB_DEPENDS+= libqtcurve-utils.so:x11-themes/qtcurve-utils
PKGNAMEPREFIX= gtk2-
PKGNAMESUFFIX= -theme
USES+= gettext-runtime gnome kde:5 qt:5
-USE_KDE= i18n_build
-USE_QT+= buildtools_build qmake_build
+USE_KDE= i18n:build
+USE_QT+= buildtools:build qmake:build
USE_GNOME= cairo gdkpixbuf2 gtk20 pango
USE_LDCONFIG= yes
@@ -84,9 +84,9 @@ USES+= kde:5 qt:5
USE_KDE= archive completion config configwidgets coreaddons \
frameworkintegration guiaddons i18n iconthemes \
init kdelibs4support kio widgetsaddons windowsystem xmlgui \
- doctools_build ecm_build
+ doctools:build ecm:build
USE_QT= core dbus gui printsupport svg widgets x11extras \
- buildtools_build qmake_build
+ buildtools:build qmake:build
BUILD_WRKSRC= ${WRKSRC}/qt5
.endif
@@ -94,9 +94,9 @@ BUILD_WRKSRC= ${WRKSRC}/qt5
CONFLICTS_INSTALL= kf5-style-qtcurve
PKGNAMEPREFIX= qt5-style-
USES+= kde:5 qt:5
-USE_KDE= i18n_build
+USE_KDE= i18n:build
USE_QT= core dbus gui svg widgets x11extras \
- buildtools_build qmake_build
+ buildtools:build qmake:build
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
.endif