aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox17/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-24 09:01:15 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-24 09:01:15 +0000
commitf6cff08d224cf98870fc44f2ea941349779fa0ae (patch)
tree9c827ccdde72df2999357d5e5a4a875836fd6eea /x11-toolkits/fox17/Makefile
parentbd8f6f8c354ba97acba4677cf0071026a60362af (diff)
downloadports-f6cff08d224cf98870fc44f2ea941349779fa0ae.tar.gz
ports-f6cff08d224cf98870fc44f2ea941349779fa0ae.zip
- Update to 1.7.46
Changes: * FXIconSource now can use icon/image contents to detect file format type [the stream must be seekable]. * A default FXIconSource implementation in FOX will be used to load icons if not overloaded by a user-extended one explicitly. * Replaced FXIconDict with FXIconCache. * Replaced FXFileDict with FXFileAssociations. The new implementation uses FXDictionary, and the new FXIconCache. * Fixed problem in FXDictionary: object pointed to by data is itself not const. This affects const-accessors. * Fixed bug in Adie: dumping core when started with unknown commandline parameter. * Expunged FXDict and its subclasses. Now replaced with new implementations, see above. * FXFileList now has explicit pointer to FXIconSource, for image preview purposes. * Changed things around for FXFileAssociations to be more easily subclassable. * In FXIconCache, don't add to the hash table until loading was successful. * PathFinder icon previewing improved, more options for sizing. * PathFinder custom iconpath wasn't being saved. * In FXFileAssociations, don't add extension-association unless associated extension data from registry is fully and properly parsed. * Fixed compile problem in FXPipe.
Notes
Notes: svn path=/head/; revision=345786
Diffstat (limited to 'x11-toolkits/fox17/Makefile')
-rw-r--r--x11-toolkits/fox17/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index d04f572f5405..6697f0326882 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.7.45
+PORTVERSION= 1.7.46
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
@@ -75,4 +75,8 @@ post-patch:
${REINPLACE_CMD} -e '/^SUBDIRS/s/ doc//' ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libFOX-${MAJORVER}.so \
+ ${STAGEDIR}${PREFIX}/lib/libCHART-${MAJORVER}.so
+
.include <bsd.port.mk>