aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/girara/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-10-21 09:11:51 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-10-21 09:11:51 +0000
commit72594d6241ee8b312042bf14d70cc90e3f4005b7 (patch)
tree33184dd90bd40d46b69fbfbb7c0b790af7165101 /x11-toolkits/girara/Makefile
parent9486b299e2c9ba0739f567b327d9712ae3728d59 (diff)
downloadports-72594d6241ee8b312042bf14d70cc90e3f4005b7.tar.gz
ports-72594d6241ee8b312042bf14d70cc90e3f4005b7.zip
Add patch to disable optimizations on a keyboard input function
when using the clang compiler. This allows removing the requirement on gcc. Patch based on suggestion from Ivan <bsd@abinet.ru>. Bug has been reported upstream. PR: 213595 Submitted by: Michael Danilov <mike.d.ft402@gmail.com> MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=424401
Diffstat (limited to 'x11-toolkits/girara/Makefile')
-rw-r--r--x11-toolkits/girara/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/x11-toolkits/girara/Makefile b/x11-toolkits/girara/Makefile
index b13a04b98a09..353ce66b8de6 100644
--- a/x11-toolkits/girara/Makefile
+++ b/x11-toolkits/girara/Makefile
@@ -3,7 +3,7 @@
PORTNAME= girara
PORTVERSION= 0.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits graphics
MASTER_SITES= http://pwmt.org/projects/girara/download/
@@ -18,14 +18,10 @@ LIBDIR= ${PREFIX}/lib
MAKE_ENV+= SFLAGS=${STRIP} \
VERBOSE=1
-OPTIONS_DEFINE= GCC NLS
-# Force GCC by default due to problems in dependent port zathura with keyboard
-# input when compiled using clang.
-OPTIONS_DEFAULT=GCC
+OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext
-GCC_USE= GCC=yes
post-patch: .SILENT
${REINPLACE_CMD} -e 's|$${LIBDIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \